Closed Bug 982371 Opened 6 years ago Closed 6 years ago

remotePartyName is not filtered in call_logger

Categories

(Core :: WebRTC: Signaling, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30

People

(Reporter: arai, Assigned: ehugg)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140306171728



Actual results:

In handlePlacedCall in call_logger.c,
http://dxr.mozilla.org/mozilla-central/source/media/webrtc/signaling/src/sipcc/core/ccapp/call_logger.c#190
>        if ( partyInfoPassedTheNameFilter(data->cld_name) &&
>             partyInfoPassedTheNumberFilter(data->cld_number) )
>            data->call_log.remotePartyNumber[0] = strlib_update(data->call_log.remotePartyNumber[0], data->cld_number);
>            data->call_log.remotePartyName[0] = strlib_update(data->call_log.remotePartyName[0], data->cld_name);

Assignment to remotePartyName is outside of if-statement.



Expected results:

I'm not sure what is the correct behavior,
but infer from indent and function name that it seems to be a bug,
and should be following:
>        if ( partyInfoPassedTheNameFilter(data->cld_name) &&
>             partyInfoPassedTheNumberFilter(data->cld_number) ) {
>            data->call_log.remotePartyNumber[0] = strlib_update(data->call_log.remotePartyNumber[0], data->cld_number);
>            data->call_log.remotePartyName[0] = strlib_update(data->call_log.remotePartyName[0], data->cld_name);
>        }

Could anyone verity it?
Ethan, can you look at this?
Assignee: nobody → ethanhugg
Flags: needinfo?(ethanhugg)
Yes Tooru, I think your analysis is correct.  Thanks for finding this.  I'll upload a patch.
Flags: needinfo?(ethanhugg)
Attachment #8389992 - Flags: review?(rjesup)
Attachment #8389992 - Flags: review?(rjesup) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a3b20eb15f82
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.