Closed Bug 982556 Opened 6 years ago Closed 4 years ago

JavaScript Error: "TypeError: self.app is null" {file: "app://homescreen.gaiamobile.org/gaia_build_defer_index.js" line: 84}

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: askeing, Unassigned)

References

Details

Attachments

(1 file)

When running test_system_message.py of Gaiatest, it sometimes failed.

Buri
Gaia      a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko     https://hg.mozilla.org/mozilla-central/rev/41d962d23e81
BuildID   20140311040203
Version   30.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013


Traceback (most recent call last):
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 163, in run
testMethod()
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/system/test_system_message.py", line 30, in test_app_launched_by_system_message
self.on_app_launched()
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/system/test_system_message.py", line 44, in on_app_launched
""" % (self._testing_system_message, self._testing_message_id))
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 1114, in execute_script
filename=os.path.basename(frame[0]))
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 604, in _send_message
"Connection timed out", status=ErrorCodes.TIMEOUT)
TimeoutException: TimeoutException: Connection timed out


Most recent errors/exceptions are:

03-12 16:04:02.309 E/GeckoConsole( 4640): [JavaScript Error: "TypeError: self.app is null" {file: "app://homescreen.gaiamobile.org/gaia_build_defer_index.js" line: 84}]
03-12 16:04:02.329 E/GeckoConsole( 4640): [JavaScript Error: "TypeError: self.app is null" {file: "app://homescreen.gaiamobile.org/gaia_build_defer_index.js" line: 84}]
03-12 16:04:02.359 E/GeckoConsole( 4640): [JavaScript Error: "TypeError: self.app is null" {file: "app://homescreen.gaiamobile.org/gaia_build_defer_index.js" line: 84}]
03-12 16:04:02.379 E/GeckoConsole( 4640): [JavaScript Error: "TypeError: self.app is null" {file: "app://homescreen.gaiamobile.org/gaia_build_defer_index.js" line: 84}]
03-12 16:04:03.769 E/GeckoConsole( 4640): Content JS ERROR at app://homescreen.gaiamobile.org/gaia_build_defer_index.js:61 in retrieve: Got an exception when trying to load icon "app://music2.gaiamobile.org/style/icons/60/Music.png +" falling back to cached icon. Exception is:
The B2G process has restarted after crashing during the tests so Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.



Traceback (most recent call last):
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 191, in run
self.tearDown()
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 1067, in tearDown
MarionetteTestCase.tearDown(self)
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 339, in tearDown
self.marionette.set_context("content")
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 860, in set_context
return self._send_message('setContext', 'ok', value=context)
File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 589, in _send_message
raise MarionetteException("Please start a session")
MarionetteException: MarionetteException: Please start a session
I will take a look
Assignee: nobody → florin.strugariu
I'm not able to reproduce this issue I run it on both desktop and phone
Assignee: florin.strugariu → nobody
This is not a bug in the test, it's a bug in the homescreen app.
Component: Gaia::UI Tests → Gaia::Homescreen
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Patch v1
Attachment #8393516 - Flags: review?(21)
Comment on attachment 8393516 [details]
Patch v1

(In reply to Cristian Rodriguez (:crdlc) from comment #4)
> Created attachment 8393516 [details]
> Patch v1

Christian, the patch looks fine to me but do you know how this is happening and what is the core issue ? (please ask r? again when you reply!)
Attachment #8393516 - Flags: review?(21)
Really I don't know what it's happening, I mean, I cannot reproduce it in my devices. Maybe a wrong app installed, wrong bookmark, ...
Flags: needinfo?(21)
(In reply to Cristian Rodriguez (:crdlc) from comment #6)
> Really I don't know what it's happening, I mean, I cannot reproduce it in my
> devices. Maybe a wrong app installed, wrong bookmark, ...

Do you know how to run the python Gaia UI tests to see if you can reproduce ? I'm a bit worried that this error is a real error. If that's the case fixing the error effect is likely not the right thing to do, but we should find the root cause.
Flags: needinfo?(21)
I don't know how to do that so releasing the bug in order to another person can take it
Assignee: crdlc → nobody
Status: ASSIGNED → NEW
This is/was probably completely unrelated to the test. The test had a bad failure and as such dumped the last 5 Gecko failures and by co-incidence 3 of them were this error.

They should be observable just in the logcat. However I tried a few ways to try and trigger the errors and could not see them.

Vingetun, do you want to mark this worksforme or proceed with the patch?
Flags: needinfo?(21)
(In reply to Zac C (:zac) from comment #9)
> This is/was probably completely unrelated to the test. The test had a bad
> failure and as such dumped the last 5 Gecko failures and by co-incidence 3
> of them were this error.
> 
> They should be observable just in the logcat. However I tried a few ways to
> try and trigger the errors and could not see them.
> 
> Vingetun, do you want to mark this worksforme or proceed with the patch?

I would like to keep this bug opened until we figure out how this things can happen.
I don't want to land the patch as if as it may only hide one of the consequence of the bug while the real bug is still here.
Flags: needinfo?(21)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.