Closed Bug 982573 Opened 6 years ago Closed 4 years ago

[Media Recorder] Let WebM output video data to be seek-able.

Categories

(Core :: Audio/Video: Recording, defect, P2)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 657791

People

(Reporter: rlin, Unassigned)

References

Details

(Keywords: DevAdvocacy)

If user call the start without timeslice, we can modify the data in memory and insert the duration/cue section, and let it is seekable.
For case with timeslice case, we can add description on API to tell the developer what happened.
Summary: [Media Recorder] Let WebM output video data seek-able. → [Media Recorder] Let WebM output video data to be seek-able.
Maire - we need to fix video playback or recording.
Flags: needinfo?(mreavy)
It sounds like this would either be a dup of bug 657791 if we fix it in playback or a "P2" bug if we fix it in media recording.  P2 means it's important, but not critical;  timing-wise it means it will likely get fixed before Orlando, but no promises. 

Anthony -- Are there any other apps (other than media recording) that we care about that do not provide seeking information?  I'll also check to see if this is a violation of the media recording spec.  It may well be; in which case, fixing it in media recorder and making it a P2 feels about right.
Rank: 22
Flags: needinfo?(mreavy) → needinfo?(ajones)
Priority: -- → P2
I'm not aware of other instances of VP9 seeking not working. Given that I live under a rock that doesn't mean they don't exist.
Flags: needinfo?(ajones)
Duplicate of this bug: 1219923
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 657791
You need to log in before you can comment on or make changes to this bug.