Zooming the conversation content is broken

RESOLVED FIXED in 1.6

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mic, Assigned: aleth)

Tracking

({regression})

Details

(Whiteboard: [1.6-blocking])

Attachments

(1 attachment, 1 obsolete attachment)

The content of a conversation can't be zoomed at the moment. Neither Ctrl+Plus nor Ctrl+Minus nor Ctrl+Mouse Wheel work on Windows.
Florian confirmed that on Mac. Gestures aren't working neither on Mac.

There are no errors on the error console.

It's still been working in Instantbird 1.5.
Keywords: regression
Whiteboard: [1.6-blocking]
Posted patch zoomfix.diff.diff (obsolete) — Splinter Review
Ported from browser.xml
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8492726 - Flags: review?(florian)
Comment on attachment 8492726 [details] [diff] [review]
zoomfix.diff.diff

Review of attachment 8492726 [details] [diff] [review]:
-----------------------------------------------------------------

Don't we also need the isSyntheticDocument getter at http://hg.mozilla.org/mozilla-central/rev/29567f7cdd3d#l6.31 to avoid a warning from http://hg.mozilla.org/mozilla-central/rev/29567f7cdd3d#l5.17 when running that code?
Depends on: 1070953
No longer depends on: 1070953
It doesn't cause a warning, but you're right, it's cleaner to include it.
Attachment #8492726 - Attachment is obsolete: true
Attachment #8492726 - Flags: review?(florian)
Attachment #8493606 - Flags: review?(florian)
Comment on attachment 8493606 [details] [diff] [review]
zoomfix.diff.diff 2

Review of attachment 8493606 [details] [diff] [review]:
-----------------------------------------------------------------

Not causing a warning is probably because by default this.useFullZoom is always true for Instantbird.
Attachment #8493606 - Flags: review?(florian) → review+
https://hg.mozilla.org/comm-central/rev/58a611a12239
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.6
You need to log in before you can comment on or make changes to this bug.