Closed Bug 982615 Opened 7 years ago Closed 7 years ago

Sync panel is not entirely displayed in localized builds

Categories

(Firefox :: Preferences, defect)

defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox28 --- unaffected
firefox29 + verified
firefox30 + verified
firefox31 --- verified

People

(Reporter: flod, Assigned: aryx)

References

Details

(Keywords: regression)

Attachments

(5 files)

Attached image Nightly on Mac
Disconnect button is cut on both Mac and Windows.
Also the text field for device name is cut on the right.
CCing community alias to see if others are having the same problem.
Attached image Nightly on Win
Same problem on Linux, French Nightly build.
I think it's because the panel is sized to accommodate the welcome.description string which is shown if no account has been setup yet. This string can be quite long in many locales, and it doesn't wrap.
Even when there's no account configured this is broken.
Trying to raise importance of this issue: this is now in Beta, and I expect a lot of complaints for localized builds.
http://transvision.mozfr.org/string/?entity=browser/chrome/browser/preferences/sync.dtd:welcome.description&repo=beta

Right now the only alternative is to increase the size of the entire Preferences window, which would be crazy considered the amount of whitespace available in this section.
Severity: normal → major
Attached patch patch, v1Splinter Review
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #8395193 - Flags: review?(mak77)
Comment on attachment 8395193 [details] [diff] [review]
patch, v1

Review of attachment 8395193 [details] [diff] [review]:
-----------------------------------------------------------------

oops, my fault, thank you.
Attachment #8395193 - Flags: review?(mak77) → review+
Comment on attachment 8395193 [details] [diff] [review]
patch, v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 965032
User impact if declined: malformed Sync preferences pane in some localizations
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: none
Attachment #8395193 - Flags: approval-mozilla-beta?
Attachment #8395193 - Flags: approval-mozilla-aurora?
We will approve it once it landed in m-c
Duplicate of this bug: 982730
https://hg.mozilla.org/mozilla-central/rev/5c505113afb2
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attachment #8395193 - Flags: approval-mozilla-beta?
Attachment #8395193 - Flags: approval-mozilla-beta+
Attachment #8395193 - Flags: approval-mozilla-aurora?
Attachment #8395193 - Flags: approval-mozilla-aurora+
Verified on 31.0a1 (2014-03-24). Panel now behaves correctly in both states (logged in, not logged in).
Status: RESOLVED → VERIFIED
Verified as fixed on FR localized builds: Aurora 30.0a2 (20140324150430) and Nightly 31.0a1 (20140324030203) under Win 7 64-bit, Ubuntu 32-bit and Mac OS X 10.8.5.

The fix is not included in Firefox 29 beta 2 (20140324101726), so will be verified in next beta.
Has this regressed again? I have seen this today with latest Slovak central and aurora builds on Win7 and Win8.1U1.
Flags: needinfo?(francesco.lodolo)
On Nightly (OS X) I'm not seeing anything funny, and the history of sync.xul on Aurora branch doesn't give me any possible explanation for it.
https://hg.mozilla.org/releases/mozilla-aurora/log/default/browser/components/preferences/sync.xul
Flags: needinfo?(francesco.lodolo)
(In reply to Francesco Lodolo [:flod] from comment #18)
> On Nightly (OS X) I'm not seeing anything funny

Checked also Win8.1, everything looks good (both logged in/out statuses).
The issue is here:

               <!-- logged in to an unverified account -->
              <hbox flex="1">
                <description>
                  &signedInUnverified.beforename.label;
                  <span id="fxaEmailAddress2"></span>
                  &signedInUnverified.aftername.label;
                </description>
                ...
              </hbox>

Shortening the value of &signedInUnverified.beforename.label; fixes the width. Anyway, this should be filed as a new bug.
I have verified on 1st April that this is fixed on Firefox 29 beta 4 - French localized build, under Win 7 64-bit, Ubuntu 32-bit and Mac OS X 10.8.5, but forgot to update the bug.

On latest Nightly (2014-04-13) I can see the issue on Slovak build, but not on Italian and French. I used the same profile and sync account, without disconnecting. Could it be connected to specific locales?

Please let me know if I could help further.
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.