Closed Bug 982651 Opened 6 years ago Closed 6 years ago

Low-res tiling glitches

Categories

(Core :: Graphics: Layers, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
fennec 30+ ---

People

(Reporter: kats, Assigned: cwiiis)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files, 1 obsolete file)

Attached file Test page
I'm able to reproduce some low-res tiling glitches on Fennec, although it's not easy to do. Presumably on a slower device it's easier, and you might be able to force the condition by inserting sleeps in the right place. I don't have really solid STR but here's my best attempt:

1. Load the attached page in Fennec (this might happen in B2G as well if the same code is used there)
2. Pan around to make sure the low-res cache is populated
3. Zoom in and pan around rapidly
4. Zoom out and pan around rapidly

Repeat steps 3 and 4 and observe glitches where tiles are drawn at obviously wrong resolutions.

I put up a video on Youtube [1] demonstrating this; you can see the glitches show up at 0:17 when I pan left a couple of times. There's another small glitch at 1:23 where there's a line that shouldn't be there. At 1:35 again you can see some tiles that don't fit together right zoom by on the left side of the screen and at 1:36 more scaled-up content that shouldn't be scaled up.

I suspect it happens more frequently than is obvious from the video but there are only a few times where things look really out of place and it's noticeable (such as when a tile is rendered at the wrong resolution right next to a tile at the right resolution).

[1] http://youtu.be/HLL8wZ9M1mE
Assume this is a recent regression? I see this on Nightly (03/13) on my fast Galaxy S4 (4.4.2) easily on your test-case and similarly on CNN and other pages.
tracking-fennec: --- → ?
Keywords: regression
Keywords: reproducible
See Also: → 983169
No, this is not recent, it's been happening for a while now. I thought I filed another bug about it a while ago but can't find it. I filed this one because Chris wanted some way to reproduce the problem in relation to the tiling stuff that just landed on B2G.
Assignee: nobody → chrislord.net
tracking-fennec: ? → 30+
I must've nuked this during the port to new textures. I think it'd be nicer on the SurfaceDescriptorTiles than what I've done in this patch, just a first run.
So I tested the above patch on top of the latest m-c and it seemed to fix the problem. I didn't see the mismatch of different zoom levels I was seeing before. However it was hard to verify because I ran into other bugs where large grey squares appeared often (probably one of the recent tiling bugs). I pulled down the backout from bug 983157 and applied that locally too but it made things worse - now after initially painting some things it gets stuck in perma-checkerboarding and perma-low-res-tiles.
I believe what I described above is bug 983202 and is unrelated to your patch, Chris. So while I have no reason to believe your patch doesn't work, I cannot 100% confirm it either; I'd have to wait until the other tiling breakages are fixed before I can do that.
Attachment #8390675 - Attachment is obsolete: true
Attachment #8391100 - Flags: review?(nical.bugzilla)
Attachment #8391100 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/7e40555e25f7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.