Closed Bug 982712 Opened 7 years ago Closed 7 years ago

[Fugu][Buri] Background painting has sometimes a wrong line at the top of the background

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1023190

People

(Reporter: julienw, Unassigned)

Details

Attachments

(1 file)

URL is: http://everlong.org/mozilla/testcase-background/

On the Fugu device, on some zoom factors, we see a grey line at the background top limit.

I found this issue while working on the Gaia bug 947139, on a more complex testcase.

I didn't reproduce on a Peak yet, so this might be a driver issue on the Fugu.
Peter, do u have fugu to verify this bug?
Flags: needinfo?(pchang)
Attached image screenshot on Buri
I reproduced on Buri as well, see screenshot attachment 8390471 [details].

I don't reproduce on Peak at all (and I don't see the bug I got in Bug 947139 on Peak either).
Summary: [Fugu] Background painting has sometimes a wrong line at the top of the background → [Fugu][Buri] Background painting has sometimes a wrong line at the top of the background
http://everlong.org/mozilla/testcase-background/index2.html shows it in a more easy manner. And I actually see slightly different behaviors on Fugu and Buri.

* on fugu, you get the grey line when you click once on the button, then it disappears at the next click, then appears again at the next click, etc. Once every 2 clicks, there is the grey line.

* on Buri, you first need to zoom in (double click on the button does it) and then the grey line appears sometimes, but not in such a steady way. Sometimes it stays 2 clicks in a row, sometimes we don't see it for several clicks. And I couldn't make it appear without zooming in.

This is both 1.3 and 1.4, both using APZC, didn't try without.
I could reproduce it on my Nexus 4 device and it should be related to layout.
Component: Graphics → Layout
Flags: needinfo?(pchang)
(In reply to peter chang[:pchang][:peter] from comment #5)
> I could reproduce it on my Nexus 4 device and it should be related to layout.

or APZ...
(In reply to peter chang[:pchang][:peter] from comment #5)
> I could reproduce it on my Nexus 4 device and it should be related to layout.

I don't see how it could be layout since it doesn't reproduce on Peak.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1023190
You need to log in before you can comment on or make changes to this bug.