Box Model updates its values with a multi-second delay

RESOLVED WORKSFORME

Status

defect
P2
normal
RESOLVED WORKSFORME
5 years ago
a year ago

People

(Reporter: anton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
When switching between elements our Box Model sidebar updates with a pretty significant delay. I noticed delays ranging from half a second to 4-5 seconds. Initially I thought that it isn't updating at all but it seems like it just takes a long time. When you switch from Box Model to any other sidebar tab and then back, it updates immediately.

STR:

 1. Open medium.com (thats where I can reproduce it consistently)
 2. Inspect header
 3. Open box model sidebar
 4. Switch between elements in the element tree.

Then you should notice delays.
I can confirm this is an issue
Depends on: 663778
Priority: -- → P2

Comment 2

5 years ago
I think it's a regression of the "Make highlighter remote" bug. I started to get the issue at that time.
We need to make the layout view only update on layout change... we have access to this from an actor.

At the moment we are using MozAfterPaint on browser which makes the layout view update way too many times... moving the mouse is moved across the browser will refresh it hundreds of times.

Comment 4

5 years ago
I may have filed a duplicate of this bug at #999712.

In my case, when there is a delay in the Box Model diagram being updated, what causes it to finally update is moving the mouse cursor into the Box Model pane.

Comment 5

3 years ago
I've been unable to reproduce this bug as well as the listed duplicate bug #982822.

Tested in Firefox 46.0a2
Build ID: 20160204004009
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:46.0) Gecko/20100101 Firefox/46.0
Flags: needinfo?(anton)
Reporter

Updated

3 years ago
Flags: needinfo?(anton)
(In reply to George Crary from comment #5)
> I've been unable to reproduce this bug as well as the listed duplicate bug
> #982822.
> 
> Tested in Firefox 46.0a2
> Build ID: 20160204004009
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:46.0)
> Gecko/20100101 Firefox/46.0

Mike, can you confirm this problem has gone away?
Flags: needinfo?(mratcliffe)
Yes, this was fixed as part of switching to the reflow actor in bug 997198.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mratcliffe)
Resolution: --- → WORKSFORME

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.