Closed Bug 982848 Opened 6 years ago Closed 6 years ago

Don't clear syncKeyBundle in BrowserID Identity manager during failures to fetch token

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: ckarlof, Assigned: ckarlof)

References

Details

Attachments

(1 file)

Since we stay logged in to Service, there was no code path that was triggering us to refetch the syncKeyBundle, which triggered _remoteSetup() to fail as well via a failed syncKeyUpgrade.

In addition, we use the presence of the syncKeyBundle as a quick success in ensureLogin rather than Weave.Status.login == LOGIN_SUCCEEDED.
r=markh over my shoulder
Attachment #8390056 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/58252ac4f28d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8390056 [details] [diff] [review]
0001-Bug-982848-Don-t-clear-syncKeyBundle-in-BrowserID-Id.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: Sync will not recover after failure
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low 
String or IDL/UUID changes made by this patch: None
Attachment #8390056 - Flags: approval-mozilla-aurora?
Attachment #8390056 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.