Enable Pause/Resume when downloading via http

VERIFIED FIXED in Future

Status

--
enhancement
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
found using 2001.09.04.xx-comm bits on all platforms. the Pause [and
subsequently, Resume] button doesn't seem to appear when i download via http.

not sure what caused this. punt as needed.

1. click on an http download link --eg,
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-macosX-trunk.sit.bin
--if the helper app dialog appears, make sure "save this file to disk" is
selected, then click OK.
2. chose a download location in the resulting file picker dialog, then click OK.
3. look at the download progress dialog that appears.

expected: you should see a Pause button in the download progress dialog.

actual: no Pause button. unable to pause download.
(Reporter)

Comment 1

17 years ago
Created attachment 48231 [details]
shot of dialog lacking Pause button for http download
(Reporter)

Comment 2

17 years ago
definitely a regression. would it be possible to fix for 0.9.4?

this is not a problem when i downloaded via ftp, eg,
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-macosX-trunk.sit.bin

will attach a shot of this, for comparison.
Keywords: mozilla0.9.4, nsbranch, regression
(Reporter)

Comment 3

17 years ago
Created attachment 48232 [details]
shot of ftp download --buttons look fine
(Reporter)

Updated

17 years ago
Attachment #48231 - Attachment description: shot of dialog lacking Pause button → shot of dialog lacking Pause button for http download
(Reporter)

Comment 4

17 years ago
spoke with bill and blake --this might be expected behavior.

dang, my memory is really rusty about this, so i'm gonna check the 6.1rtm bits...
(Reporter)

Comment 5

17 years ago
6.1rtm shows the same behavior. marking invalid. apologies for the noise.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

17 years ago
"nothing to see here"
Status: RESOLVED → VERIFIED

Comment 7

17 years ago
REOPEN:

This isn't really invalid, it should be an RFE.

You can use byteranges + etags and other headers to continue the loading of a
file you did not fully receive.

This might also be a dupe of something already in bugzilla.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 8

17 years ago
okay, i'll make this an rfe...however, methinks this might be taken care of by
ben's proposed download manager? see bug 25995 for details on that.
Severity: major → enhancement
Summary: Pause/Resume buttons missing when downloading via http → add Pause/Resume buttons when downloading via http
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.4, nsbranch, regression

Comment 9

17 years ago
I think what I describe is the the method he plans to use.
(Reporter)

Comment 10

17 years ago
spam: over to File Handling. i have not changed the assigned developer [or the
other fields for that matter], so if anyone realizes that a bug should have a
more appropriate owner, go ahead and change it. :)
Component: XP Apps: GUI Features → File Handling
(Assignee)

Comment 11

17 years ago
--> law
Assignee: blakeross → law
Status: REOPENED → NEW

Comment 12

17 years ago
Changed summary to note this is an RFE (and clarify what it is).

->Futre because I don't think we will have time to do this and I don't believe 
the download manager includes this feature.
Keywords: helpwanted
Summary: add Pause/Resume buttons when downloading via http → [RFE] Enable Pause/Resume when downloading via http
Target Milestone: --- → Future

Updated

17 years ago
Depends on: 107552

Comment 13

17 years ago
bug 107552 will resolve resuming in ftp. After that, we could use the ui for 
pausing and resuming.
I really dont know if http resuming is currently possible. If yes, then that 
dependency i just put is wrong and we need another bug for it
(Assignee)

Comment 14

17 years ago
It would be nice to get this feature for download manager, which I'm currently 
working on, but not a formal requirement at this time.  Cc'ing bbaetz, who was 
starting work on this before he left, I believe, and Darin.  Darin, should this 
belong to the necko group?
I have this hacked up for ftp-cross session support - not sure what the bug# 
for that is. It works in heory, but I didn't write a test program before I 
left, so...

Once that is in, getting this working for http would belong to necko, I think. 
The APIs got posted to npm.netlib a couple of months ago, but I didn have to 
modify them a bit.
Blocks: 18004

Comment 16

17 years ago
yeah, full support for HTTP suspend/resume is going to require significant necko
land work.

Comment 17

17 years ago
*** Bug 134821 has been marked as a duplicate of this bug. ***
*** Bug 135956 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 150463 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
*** Bug 153548 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 171338 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
I think this bug depends on bug 18004 but not block it. Having no engine for
pausing/resuming http downloads, it is impossible to implement requested feature.
Moreover, it seems reasonable for me to mark this bug simply as duplicate of bug
18004 since they both are long-life RFE's with almost negligible difference.
Do you agree?
(Reporter)

Updated

16 years ago
QA Contact: sairuh → petersen

Comment 23

16 years ago
.
Assignee: law → darin
Component: File Handling → Networking: HTTP
QA Contact: petersen → httpqa
Summary: [RFE] Enable Pause/Resume when downloading via http → Enable Pause/Resume when downloading via http
*** Bug 178318 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 164878

Comment 25

16 years ago
bug 176919 should make this easier to implement.
Depends on: 176919
*** Bug 217826 has been marked as a duplicate of this bug. ***

Comment 27

15 years ago
-> Download manager.

All the dupes are in download manager, and clearly people are not seeing this
open bug in HTTP.

This needs to be tested in download manger when it is fixed, and would depend on
additional support in necko, for which I've created bug 219556.

I've also removed the depends on 107552, because this would not depend on an FTP
fix (as well as still not working even though all the dependencies are fixed.
Assignee: darin → blake
Component: Networking: HTTP → Download Manager
Depends on: 219556
No longer depends on: 107552
QA Contact: httpqa → petersen

Comment 28

15 years ago
I have never seen pause/resume download functions as the default in Netscape or Mozilla. Can 
anyone explain how this is supposed to work?

Is it better to make downloads resumable only from the list which is within the download manager 
widget, or also to make downloads resumable when saving to an existing file, by assuming that 
the person knows what they are doing and is intending to resume a download?

Should a "Resume download..." function be added to the context menus for links or downloads, 
rather than only an option to save the file? If this was done, then it would be then easier to 
integrate downloading and resuming with necko, after prompting the user with a dialogue saying, 
"Locate download file to continue downloading..." after they had clicked on a link to "Resume" 
downloading it.

Comment 29

15 years ago
*** Bug 231208 has been marked as a duplicate of this bug. ***

Comment 30

15 years ago
*** Bug 237156 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
*** Bug 238996 has been marked as a duplicate of this bug. ***

Comment 32

14 years ago
Should not this bug be closed now? The Pause/Resume button is now available and
working fine when downloading files via HTTP (tested with Mozilla 1.7 RC2 on
Linux). Or I do not understand what you are talking about!?!
download manager bugs are a mess. everything after comment 7 disagrees with
comment 0 and the summary. oh well.

Comment 34

14 years ago
This was fixed by the checkin for bug 219556
Status: NEW → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → FIXED
that checkin did not affect anything that users can see... anyway, comment 0 and
the summary are fixed (because of a different bug). marking verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.