Closed Bug 982885 Opened 6 years ago Closed 6 years ago

'Check for Updates' link is missing on Aurora 29.0a2

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P1)

29 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 --- verified

People

(Reporter: krupa.mozbugs, Assigned: myk)

Details

(Keywords: reproducible)

Attachments

(3 files)

Attached image screenshot
Android 4.0.3/Samsung 
Aurora 29.0a2 (2014-02-12)

steps to reproduce:
1. Load marketplace on Aurora
2. Install a few apps
3. Go to about:apps

expected behavior:
There is a link to Check for Updates.

actual behavior:
Link to Check for Updates is missing. See screenshot.
Severity: normal → blocker
OS: Mac OS X → Android
Priority: -- → P1
Hardware: x86 → ARM
Assignee: nobody → myk
I'm pretty sure I got my Aurora build from http://www.mozilla.org/en-US/firefox/channel/#aurora
I see this too Aurora (03/12). I'll check for a regression-range tomorrow unless a dev gets to this before.
Keywords: reproducible
Flags: needinfo?(aaron.train)
I can now reproduce this on a custom Aurora build.  Investigating…
Status: NEW → ASSIGNED
After looking into this further, I realized that I intentionally didn't uplift this UI when uplifting the rest of the automated updates patch over in bug 934760, comment 36:

> I don't want to uplift the manual updates implementation, however, as it isn't
> part of the MVP and contains a new string that would trigger late-l10n.  I'll
> attach a patch containing the specific set of changes I'd like to uplift.

So this shouldn't be a blocker for the MVP.


But I know that makes it harder to test automated updates, so I've created a custom build of Aurora with the UI to help with testing:

  https://people.mozilla.org/~myk/synthapk/fennec-29.0a2.check-for-updates.apk


It includes these simple, low-risk, well-contained changes:

  https://github.com/mykmelez/gecko-dev/compare/aurora...aurora-check-for-updates


And theoretically we could uplift them to Aurora.  But they include a new string that would be very late L10N, which we shouldn't do unless it's absolutely necessary.  Another option would be to reuse the "Check for Updates »" string in Fennec's About page, which is identical except for the trailing chevron:

  http://mxr.mozilla.org/mozilla-central/source/mobile/android/locales/en-US/chrome/about.dtd?rev=48b38e667074#9
Severity: blocker → normal
Flags: needinfo?(aaron.train)
Here's what it would look like to use the string from the About page.
And here's the straightforward patch we would use to uplift the feature without changing strings.  Is it worth doing?
Attachment #8391553 - Flags: review?(mark.finkle)
Version: unspecified → Firefox 29
Comment on attachment 8391553 [details] [diff] [review]
patch v1: adds item without changing strings

Looks technically sound.

I can't say I think this is a MUST HAVE for Webapps, as long as we have automatic updates. I wouldn't push back on uplifting the patch if others felt stronger about it.
Attachment #8391553 - Flags: review?(mark.finkle) → review+
Comment on attachment 8391553 [details] [diff] [review]
patch v1: adds item without changing strings

(In reply to Mark Finkle (:mfinkle) from comment #7)
> I can't say I think this is a MUST HAVE for Webapps, as long as we have
> automatic updates. I wouldn't push back on uplifting the patch if others
> felt stronger about it.

I agree that it isn't a must-have.  But it's helpful for testing updates and diagnosing update problems, which is especially useful in this early stage of the project.  So I'm going to request approval to uplift it.


[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  This isn't a bug, it's an enhancement that we landed on Central
  in bug 934760.

User impact if declined: 
  Users will not be able to check for webapp updates manually (although
  Fennec will continue to check for webapp updates automatically).

Testing completed (on m-c, etc.): 
  The enhancement has been on Central for several weeks now.

Risk to taking this patch (and alternatives if risky): 
  It's a low risk patch that adds a small amount of straightforward code.

String or IDL/UUID changes made by this patch:
  None (the patch avoids adding a string by reusing an existing one).
Attachment #8391553 - Flags: approval-mozilla-aurora?
Attachment #8391553 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/671dd10087cd
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.