Closed Bug 983074 Opened 6 years ago Closed 6 years ago

[MADAI][SMS] @2.25x assets update for SMS

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: HHuang, Assigned: steveck)

References

Details

Attachments

(4 files, 2 obsolete files)

Attached file SMS@2.25x.zip (obsolete) —
No description provided.
Blocks: 983069
Hi, We would like to update 2.25x assets for Madai, could someone help with it?
Flags: needinfo?(felash)
You can contact me first because of the same timezone ;)
Assignee: nobody → schung
Status: NEW → ASSIGNED
Flags: needinfo?(felash)
Hi Helen, there are some images you didn't include in the attachments. I'll contact you offline.
Attached file missed icon.zip (obsolete) —
Hi Helen, there are the icons that we also need for message app, thanks.
Flags: needinfo?(hhuang)
Attached file missed icon.zip
I missed one more icon in the previous zip, update with new package.
Attachment #8398303 - Attachment is obsolete: true
Just a heads up: remember to re-compress the new icons with the png_recompress.sh script provided in gaia  (it's under the tools directory) before committing them. If you need help with that just ping me.
(In reply to Gabriele Svelto [:gsvelto] from comment #6)
> Just a heads up: remember to re-compress the new icons with the
> png_recompress.sh script provided in gaia  (it's under the tools directory)
> before committing them. If you need help with that just ping me.

Yep I remeber that. I will also provide the re-compress images to desinger for second confirmation(to see if there is any noticible difference for them), thanks.
Attached file SMS@2.25x.zip
Hi Steve,
The missing images has been added to the updated attachment, please check it. Thanks!
Attachment #8390388 - Attachment is obsolete: true
Flags: needinfo?(hhuang)
Hi Gabriele, I faced some error while running the script:

Error: Lossy operations are not currently supported
error: optipng -o7 -strip all -clobber -quiet PNG_FILE_PATH returned 1

Finally I tried another MAC laptop and success, but I still don't understand why I failed on linux. Did I installed wrong lib for optipng?
Flags: needinfo?(gsvelto)
Hi Helen, these images are compressed by tools and got smaller size than original. Would you mind have a check with the quality? (I think it's fine since almost all the png files already applied it. Just notice you that we got this step for the final result).
Attachment #8399338 - Flags: feedback?(hhuang)
Attached file Link to github
Hi Borja, could you please take a look for the image assets changes? I also clean up some unused image and styling. It might be related to your refresh task and need your help to verify if these changes is safe or not, thanks.
Attachment #8399352 - Flags: review?(borja.bugzilla)
(In reply to Steve Chung [:steveck] from comment #9)
> Hi Gabriele, I faced some error while running the script:
> 
> Error: Lossy operations are not currently supported
> error: optipng -o7 -strip all -clobber -quiet PNG_FILE_PATH returned 1
> 
> Finally I tried another MAC laptop and success, but I still don't understand
> why I failed on linux. Did I installed wrong lib for optipng?

I think you might have optipng version 0.6.x installed; the script works only with optipng 0.7.0 or newer. I'll add a check to the script so we print a meaningful error when using an older version of optipng.
Flags: needinfo?(gsvelto)
Hi Steve,
I checked the compressed images, they look good.
let's implement it!
Attachment #8399338 - Flags: feedback?(hhuang) → feedback+
Hi Steve, just want to know how this bug going?
Flags: needinfo?(schung)
Hi Borja, any suggestion for these image assets update?
Flags: needinfo?(schung) → needinfo?(borja.bugzilla)
Taking a look right now!
Flags: needinfo?(borja.bugzilla)
Comment on attachment 8399352 [details] [review]
Link to github

No regression in the current App, and more assets for 2.25x added, so R+ for sure! Thanks!
Attachment #8399352 - Flags: review?(borja.bugzilla) → review+
Thanks for spending you time on this patch! I know you're struggling in visual refresh task but just what to make sure these changes won't conflict to your changes.

in master: 817c24ccb2a69ba5bbd12eaae010a0a87b0c454b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Oleg, can you have a look here, I think this didn't land in the correct place after your bug 951687, can you file a bug and take care of this?
Flags: needinfo?(azasypkin)
(In reply to Julien Wajsberg [:julienw] from comment #19)
> Oleg, can you have a look here, I think this didn't land in the correct
> place after your bug 951687, can you file a bug and take care of this?

Sure, filed a follow-up bug 997053.
Flags: needinfo?(azasypkin)
You need to log in before you can comment on or make changes to this bug.