Closed Bug 983176 Opened 7 years ago Closed 7 years ago

[B2g][Contacts] Unresponsive "done" button while searching FB contacts

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 unaffected)

VERIFIED FIXED
1.4 S3 (14mar)
blocking-b2g 1.3+
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- unaffected

People

(Reporter: noemi, Assigned: crdlc)

References

Details

(Keywords: regression)

Attachments

(2 files)

STRs:
1) Tap contacts app
2) Tap gear icon
3) Import contacts from FB
4) Once the list of FB contacts appear, insert some characters to find a specific FB contact
5) Tap 'Done' button

Actual result:
'Done' button does not respond. It is necessary to close contacts app in order to go out of the FB search screen

Expected result:
return to FB contact list reflecting the changes in the selection made while searching

Tested on today's v1.3 build (03/13):
Device: hamachi
BuildId: 20140313095619
Gecko: ccc26f7
Gaia: 6194def
Platform version: 28.0

Please find attached a video showing the anomalous behaviour reported

Notice that it is working fine on today's master build (03/13):
Device: hamachi
BuildId: 20140313064116
Gecko: 7312341
Gaia: b5d0f9b
Platform version: 30.0a1
blocking-b2g: --- → 1.3?
Hi guys! I just confirmed that it works as expected in 1.2 (Gecko-04ef95a.Gaia-539a2) ;-)
blocking-b2g: 1.3? → 1.3+
Keywords: regression
Assignee: nobody → crdlc
Depends on: 972091
Attached file Patch v1
My mistake :(
Attachment #8391082 - Flags: review?(jmcf)
Comment on attachment 8391082 [details]
Patch v1

thanks for discovering it
Attachment #8391082 - Flags: review?(jmcf) → review+
not needed test suite as this is a workaround that comes from a Gecko issue described in bug 972091

landed:

https://github.com/mozilla-b2g/gaia/commit/72c45879d1ef1c3328906ef3783adaefdde1213f
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
All patches need approval before landing on 1.3, per the policy change made a few weeks ago. Please revert or get approval for this.
Flags: needinfo?(crdlc)
Comment on attachment 8391082 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: high, users cannot exit from search mode
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]:
Attachment #8391082 - Flags: approval-gaia-v1.3?(fabrice)
Flags: needinfo?(crdlc)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #6)
> All patches need approval before landing on 1.3, per the policy change made
> a few weeks ago. Please revert or get approval for this.

The reviewer thought that the pr was for master and he lands it. It was my mistake because I did not write this comment on the patch. I implemented it directly for v1.3 because v.1.4 was not affected. I think that if Fabrice approves it we don't need to revert otherwise I will revert it on Monday
I have no problem waiting for Fabrice to weigh in :)
Attachment #8391082 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Target Milestone: --- → 1.4 S3 (14mar)
Tested and working
1.3
Platform version: 28.0
Build ID: 20140319100231
Git commit: f2f2be55

1.4
Platform version: 30.0a2
Build ID: 20140319105930
Git commit: c036afe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.