Closed Bug 983255 Opened 6 years ago Closed 6 years ago

[B2G][General] Faint crosshairs or grid lines seen in the background layer on multiple pages

Categories

(Core :: Graphics, defect)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 984823
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- affected

People

(Reporter: rpribble, Unassigned)

Details

(Keywords: regression, Whiteboard: dogfood1.4)

Attachments

(4 files, 1 obsolete file)

Attached image SettingsCrosshair.png
Description:
Faint crosshair or grid lines can be seen in the background on numerous different pages on v1.4. Once page is scrolled or selection is made, grid lines disappear. Does not occur on v1.3. (Difficult to see on attached images. More easily seen by opening either the settings app of the High Score page in Zombie Line app.)

Repro Steps:
1) Updated buri to BuildID: 20140312040203
2) Tap the settings icon
3) Observe faint crosshair lines behind the settings options
4) Scroll page down
5) Observe lines disappear

Actual:
Faint grid lines can be seen behind numerous pages.

Expected:
No grid lines seen.

Environmental Variables:
Device: buri v1.4 MOZ ril
BuildID: 20140312040203
Gaia: 3005269d4dcabcc7d27eaf72bda44a969873af8c
Gecko: 23005b395ae8
Version: 30.0a1
Firmware Version: v1.2-device.cfg

Notes:

Repro frequency: 100%
See attached: Screenshots
Something tells me you turned on a dev setting here by accident that enabling this behavior. Can you check this with a clean build?
Flags: needinfo?(rpribble)
I reflashed the device to the Buri v 1.4.0 Mozilla RIL without touching the developer options menu and the issue still reproduces.  

Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140312040203
Gaia: 3005269d4dcabcc7d27eaf72bda44a969873af8c
Gecko: 23005b395ae8
Version: 30.0a1
Firmware Version: v1.2-device.cfg

The user is still able to see grid-like lines behind various screens (such as settings or High Score window of Zombie Lines).
Flags: needinfo?(rpribble)
Whiteboard: dogfood1.4
I don't think that's enough here - you want to guarantee the developer options are clear when flashing 1.4 here. If the developer options persist post flashing, then you'll still see this. Try this:

1. Factory reset the phone
2. Flash a new 1.4 build
3. Try to reproduce the bug

What happens here?
Flags: needinfo?(rpribble)
Followed steps listed in comment 4 on the Buri v1.4 MOZ RIL and the issue does still reproduce.

Environmental Variables:
Device: Buri v1.4 MOZ RIL
BuildID: 20140314093423
Gaia: 1cef557f9e9a865d1bf49d99a8f1cca1f0f4f5c4
Gecko: 142911d6d987
Version: 30.0a1
Firmware Version: v1.2-device.cfg

User sees a crosshair or grid lines behind various screens.
Flags: needinfo?(rpribble)
Okay - two questions:

1. Can you list what developer settings you have enabled on your device?
2. Can you reproduce this on a different device other than your own?
Flags: needinfo?(rpribble)
Developer settings that are enabled are: 

1. Debug: developer HUD
2. Remote debugging: ADB only
3. Enable APZ for all content
4. Layers: enable tiles
5. Displayport Heuristics: Default
6. App transition enabled

I am able to reproduce on other devices.
Flags: needinfo?(rpribble)
To help clarify the faintness of the bug - let's get a video of this issue.
Keywords: qawanted
QA Contact: rpribble
Attached audio GridLinesNotes.ogg (obsolete) —
I've attached a video of the issue (GridLinesNotes.ogg) as seen in the Notes app.
Attached audio GridLinesRetry.ogg
The video appears corrupted in the initial attachment. Retrying (GridLinesRetry.ogg).
Attachment #8392599 - Attachment is obsolete: true
Keywords: qawanted
Minor regression, mainly because it's faint.
Component: General → Graphics
Keywords: regression
Product: Firefox OS → Core
Version: unspecified → 30 Branch
Can be seen in Gallery app when pinching to zoom on images, very noticeable. Attached image taken from separate device as it seems to show up better than with screenshots for some reason.
Nical - Is this a dupe of bug 984823 by any chance?
Flags: needinfo?(nical.bugzilla)
(In reply to Jason Smith [:jsmith] from comment #13)
> Nical - Is this a dupe of bug 984823 by any chance?

Yes indeed, bug 984823 hasn't been uplifted yet. I don't know exactly how long we want to test it in m-c before the uplift. I don't think it's a risky patch, so we should uplift it soon.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(nical.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 984823
You need to log in before you can comment on or make changes to this bug.