Closed Bug 983259 Opened 8 years ago Closed 7 years ago

Australis - Use Windows 8 style icons for new-tab, tab scrollbox, and dropdowns (on Windows 8)

Categories

(Firefox :: Theme, defect)

30 Branch
All
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 36
Iteration:
36.2

People

(Reporter: ntim, Assigned: ntim)

References

Details

(Keywords: ux-consistency, Whiteboard: [Australis:P-])

Attachments

(4 files, 4 obsolete files)

No description provided.
Blocks: theme-win8
Keywords: ux-consistency
Whiteboard: [Australis:P-]
Summary: Australis - Use Windows 8 style icons for new-tab, tab scrollbox, and dropdowns. → Australis - Use Windows 8 style icons for new-tab, tab scrollbox, and dropdowns (on Windows 8)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mdeboer)
Flags: needinfo?(jaws)
Stanzilla, why did you n-i'd us? Anything specific you wanted to ask?
Flags: needinfo?(staneck)
Flags: needinfo?(mdeboer)
Flags: needinfo?(jaws)
Oh, sorry. that was a mistake :/(In reply to Mike de Boer [:mikedeboer] from comment #1)
> Stanzilla, why did you n-i'd us? Anything specific you wanted to ask?
Flags: needinfo?(staneck)
I had a question but forgot what it was and somehow sent the comment, Sorry!
What does a new-tab icon for Windows 8 look like? I looked at IE11 and didn't see anything unique to Windows 8 there. Thanks!
Flags: needinfo?(ntim007)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #4)
> What does a new-tab icon for Windows 8 look like? I looked at IE11 and
> didn't see anything unique to Windows 8 there. Thanks!

http://people.mozilla.org/~shorlander/mockups-interactive/australis-interactive-mockups/windows8.html

They are flat icons, without the slight gradient in it.
Flags: needinfo?(ntim007)
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
How did you make Toolbar.png specific to each Windows version ? I'd like to use the same technique for this bug. Thanks !
Flags: needinfo?(mdeboer)
(In reply to Tim Nguyen [:ntim] from comment #6)
> How did you make Toolbar.png specific to each Windows version ? I'd like to
> use the same technique for this bug. Thanks !

Nevermind, just figured it out.
Flags: needinfo?(mdeboer)
Can you provide assets here please ? Thanks :)
Flags: needinfo?(mmaslaney)
Attached file Toolbar.psd (obsolete) —
Flags: needinfo?(mmaslaney)
Attached image newtab.png (obsolete) —
Attachment #8490859 - Attachment is obsolete: true
Attached image newtab.png
Optimized.
Attachment #8496431 - Attachment is obsolete: true
Attached image tab-arrow-left.png
Attached image dropdown.png
Tim, are you going to put up a patch here?
Flags: needinfo?(ntim007)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #14)
> Tim, are you going to put up a patch here?

Yes, I've made one, though, I noticed it introduces a contrast regression, which is why I haven't posted anything yet. I simply need to update the colors of the new graphics to a darker one first :)
Flags: needinfo?(ntim007)
Assignee: nobody → ntim007
Status: NEW → ASSIGNED
Flags: qe-verify?
Attached patch Patch (obsolete) — Splinter Review
Attachment #8496939 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8496939 [details] [diff] [review]
Patch

Review of attachment 8496939 [details] [diff] [review]:
-----------------------------------------------------------------

If I understand correctly, you've moved the original png files to -XPVista7.png -- why aren't these reflected as hg moves in the patch?

::: browser/themes/windows/jar.mn
@@ +81,5 @@
>          skin/classic/browser/Toolbar.png                             (Toolbar-XP.png)
>          skin/classic/browser/Toolbar-inverted.png
>          skin/classic/browser/Toolbar-lunaSilver.png
>          skin/classic/browser/toolbarbutton-dropdown-arrow.png
> +        skin/classic/browser/toolbarbutton-dropdown-arrow-XPVista7.png

You can just use this file and have it be packaged as toolbarbutton-dropdown-arrow.png in the classic theme, can't you - the non-aero theme doesn't ever get used on Windows 8, I thought? That way we can avoid shipping the same files multiple times. See how this was done for the menuPanel.png images.

@@ +187,5 @@
>          skin/classic/browser/social/chat-icons.svg                   (../shared/social/chat-icons.svg)
>          skin/classic/browser/social/gear_default.png                 (../shared/social/gear_default.png)
>          skin/classic/browser/social/gear_clicked.png                 (../shared/social/gear_clicked.png)
>          skin/classic/browser/tabbrowser/newtab.png                   (tabbrowser/newtab.png)
> +        skin/classic/browser/tabbrowser/newtab-XPVista7.png          (tabbrowser/newtab-XPVista7.png)

Same here and for tab-arrow-left.
Attachment #8496939 - Flags: review?(gijskruitbosch+bugs) → review-
Attached patch Patch v2 (obsolete) — Splinter Review
Addresses review comments.
Attachment #8496939 - Attachment is obsolete: true
Attachment #8511976 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8511976 [details] [diff] [review]
Patch v2

Why no update in the classic theme for toolbarbutton-dropdown-arrow.png - that should also use the XPVista7 thing, right?

But the r- is because you override *.png with *-XPVista7.png on osversion<6.2, which includes XP, where (non-aero) you don't package a file called *-XPVista7.png. You should override on 6.1 and 6.0 only.
Attachment #8511976 - Flags: review?(gijskruitbosch+bugs) → review-
Attached patch Patch v3Splinter Review
Addressed review comments
Attachment #8511976 - Attachment is obsolete: true
Attachment #8512053 - Flags: review?(gijskruitbosch+bugs)
Attachment #8512053 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed
OS: Windows 8.1 → Windows 8
Hardware: x86_64 → All
https://hg.mozilla.org/integration/fx-team/rev/c0e559c7fb5a
Keywords: checkin-needed
Whiteboard: [Australis:P-] → [Australis:P-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/c0e559c7fb5a
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P-][fixed-in-fx-team] → [Australis:P-]
Target Milestone: --- → Firefox 36
Iteration: --- → 36.2
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.