Closed Bug 983290 Opened 7 years ago Closed 7 years ago

[B2G][Marketplace] When entering a landscape app that is open in the background, the first launching frame is abnormal

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g18 unaffected, b2g-v1.3 unaffected, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S4 (28mar)
blocking-b2g 1.4+
Tracking Status
b2g18 --- unaffected
b2g-v1.3 --- unaffected
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: rpribble, Assigned: alive)

References

()

Details

(Keywords: regression, Whiteboard: dogfood1.4)

Attachments

(2 files)

Attached image AbnormalLaunchFrame.png
Description:
When an app with a landscape layout is running in the background and the user tries to reenter it, the first frame that is seen will be abnormally displayed clipped off-screen. Takes around two seconds for the app landscape view to be displayed correctly.

Repro Steps:
1) Updated buri to BuildID: 20140312040203
2) Open a landscape app (Zombie Lines used in test)
3) Tap the home button
4) Reenter Zombie Lines
5) Observe app display in landscape mode while user is still viewing portrait mode

Actual:
First frame when reentering a landscape app is displayed abnormally.

Expected:
Landscape apps open in landscape mode correctly.

Environmental Variables:
Device: buri v1.4 MOZ ril
BuildID: 20140312040203
Gaia: 3005269d4dcabcc7d27eaf72bda44a969873af8c
Gecko: 23005b395ae8
Version: 30.0a1
Firmware Version: v1.2-device.cfg

Notes: Similar to resolved bug https://bugzilla.mozilla.org/show_bug.cgi?id=899445

Repro frequency: 100%
See attached: Screenshot
Whiteboard: dogfood1.4
What happens on 1.3?
Component: General → Gaia::System::Window Mgmt
Keywords: qawanted
QA Contact: jharvey
This issue does not reproduce in 1.3

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140314004002
Gaia: 932789749406a79c5630c27c724f1856bd3c3f10
Gecko: 0479f5480378
Version: 28.0
Firmware Version: v1.2-device.cfg
Can we get a video of the bug?
Keywords: qawanted, regression
Yuck. That looks ugly. That's going to be a problem for all landscape-locked apps (common for games).
blocking-b2g: --- → 1.4?
This issue started reproducing on the 12/11/13 1.4 build.

- Last Working -
Device: Buri v1.4 MOZ RIL
BuildID: 20131210040206
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: df82be9d89a5
Version: 29.0a1
Firmware Version: V1.2-device.cfg

- First Broken -
Device: Buri v1.4 MOZ RIL
BuildID: 20131211040203
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: 12ea03a70243
Version: 29.0a1
Firmware Version: V1.2-device.cfg


**This looks to be a gaia issue**
last working gaia/first broken gecko = NO REPRO
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: 12ea03a70243

first broken gaia/last working gecko = REPRO
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: df82be9d89a5

Push log: https://github.com/mozilla-b2g/gaia/compare/c952e2756c03eceb4de6a3eba15651741a62f9e8...6415b8b44068596404c10365394544e94edd5ce5
QA Contact: jharvey → mvaughan
Might be a regression from the work Alive did in bug 907013.

Alive - What do you think?
Flags: needinfo?(alive)
https://bugzilla.mozilla.org/show_bug.cgi?id=840126
It's a gecko bug indeed...what we could do now is avoid to show the app before screen orientation is locked.
Flags: needinfo?(alive)
(In reply to Alive Kuo [:alive][NEEDINFO!][:艾莉芙] from comment #8)
> https://bugzilla.mozilla.org/show_bug.cgi?id=840126
> It's a gecko bug indeed...what we could do now is avoid to show the app
> before screen orientation is locked.

The regression range here shows that this is a Gaia bug, not a Gecko bug. It looks like you did try to workaround this problem in 1.2 & 1.3 - https://bugzilla.mozilla.org/show_bug.cgi?id=840126#c5. Maybe the workaround regressed here?
(In reply to Jason Smith [:jsmith] from comment #9)
> (In reply to Alive Kuo [:alive][NEEDINFO!][:艾莉芙] from comment #8)
> > https://bugzilla.mozilla.org/show_bug.cgi?id=840126
> > It's a gecko bug indeed...what we could do now is avoid to show the app
> > before screen orientation is locked.
> 
> The regression range here shows that this is a Gaia bug, not a Gecko bug. It
> looks like you did try to workaround this problem in 1.2 & 1.3 -
> https://bugzilla.mozilla.org/show_bug.cgi?id=840126#c5. Maybe the workaround
> regressed here?

Might be, but I cannot repro this issue on bubble-tea. I will test it later in v1.4 branch.
Confirmed on v1.4 reproducible.
Assignee: nobody → alive
Triage: need to fix this regression in v1.4.
blocking-b2g: 1.4? → 1.4+
Let's figure out a perfect solution in v1.5 but keep this in v1.4
Attachment #8393974 - Flags: review?(timdream)
Comment on attachment 8393974 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/17362

Could you recap our discussion yesterday in the bug here to make the argument that this 1.4-release fix is justified?
Attachment #8393974 - Flags: review?(timdream) → review+
Yesterday I tried out to fix this issue by do transforming the perpendicular appWindow before it's opened.
1. The transform could not be easily done because of portrait app and landscape app's size doesn't match. For example, portrait app which is not fullscreen is 460x320 and landscape app is 300x480. We need to move statusbar into appWindow to correct the size but it's too complex to fix it in the bug.
2. We still have bug 840126 to block us from having correct opening transition to rotated appWindow.
So for v1.4 the best way is just hide the perpendicular window before it's opened and at the same time accelerate the opening transition for it.
master
https://github.com/mozilla-b2g/gaia/commit/809875568d2ca9fa5c5508e0b30fdd5263906946
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
v1.4: 6682eb78c2400c8a16791aebd006bcc5c2ffed8d
Target Milestone: --- → 1.4 S4 (28mar)
You need to log in before you can comment on or make changes to this bug.