Closed Bug 983393 Opened 9 years ago Closed 8 years ago

[B2G][Clock]After reaching lap 1000, the user is able to add more laps by switching between the Stopwatch and Alarm or Timer

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: astole, Assigned: ader.cch)

References

()

Details

(Whiteboard: dogfood1.4 [good first bug])

Attachments

(1 file)

If the user reaches lap 1000 then switches either to the Alarm or Timer with the Stopwatch still running, the option to add another lap appears when switching back to the Stopwatch.

Repro Steps:
1) Update a Buri to BuildID: 20140312040203
2) Open the Stopwatch and create 1000 laps
3) With the Stopwatch still running, switch to either the Timer or Alarm
4) Switch back to the Stopwatch

Actual:
The user is given the option to create another lap

Expected:
There is no option to create more than 1000 laps

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140312040203
Gaia: 3005269d4dcabcc7d27eaf72bda44a969873af8c
Gecko: 23005b395ae8
Version: 30.0a1
Firmware Version: v1.2-device.cfg

Repro frequency: 100%
See attached: Video
Note:
Bug 949867 talks about the changes for the Stopwatch and might help with finding a regression window.

This does not happen on the latest 1.3 since the amount of laps stops at 100.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140313004002
Gaia: 6194def5ceed3f4b9bc9de0ea2c11661cd439a27
Gecko: 9368fd13bfa6
Version: 28.0
Firmware Version: V1.2-device.cfg
Whiteboard: dogfood1.4
Not a regression if the limit was 100 before.
Whiteboard: dogfood1.4 → dogfood1.4 [good first bug]
Hello,may I take this bug as my good first bug?
Flags: needinfo?(nobody)
(In reply to Andrew from comment #3)
> Hello,may I take this bug as my good first bug?

Marcus could probably help you out with that.
Flags: needinfo?(nobody) → needinfo?(m)
Hey Andrew, thanks for your interest in helping out! I've assigned the bug to you; you're welcome to ask me if you have any questions along the way. You can find me on IRC as :mcav, or here.
Assignee: nobody → ader.cch
Flags: needinfo?(m)
Link to Github pull request:https://github.com/mozilla-b2g/gaia/pull/20262
Attachment #8437460 - Flags: review?(mike)
Flags: needinfo?(m)
Attachment #8437460 - Flags: review?(mike) → review?(m)
Flags: needinfo?(m)
Hi Marcus,
Could you review it and let me know if it works...Thank you.
Status: NEW → ASSIGNED
Flags: needinfo?(m)
Comment on attachment 8437460 [details] [review]
link to https://github.com/mozilla-b2g/gaia/pull/20262

Looks good to me. Thanks! Let me know if you need me to land for you.
Attachment #8437460 - Flags: review?(m) → review+
Flags: needinfo?(m)
(In reply to Marcus Cavanaugh [:mcav] <mcav@mozilla.com> from comment #8)
> Comment on attachment 8437460 [details] [review]
> link to https://github.com/mozilla-b2g/gaia/pull/20262
> 
> Looks good to me. Thanks! Let me know if you need me to land for you.

Thank you for your review,i am glad that it works.and Could you land for me..Thank you!
Flags: needinfo?(m)
master: https://github.com/mozilla-b2g/gaia/commit/a40e5d7ad238c03945309e45d0ccc65c815c85d5

Thanks, Andrew.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: needinfo?(m)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.