adobe.com - Adobe Type Library search requires Nav4/IE4.

RESOLVED FIXED in Jan

Status

Tech Evangelism Graveyard
English US
P1
normal
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: hsivonen, Assigned: bc)

Tracking

unspecified

Details

(Whiteboard: [USERAGENT], URL)

(Reporter)

Description

16 years ago
Build ID: 2001090105 FizzillaCFM

Steps to reproduce:
1) Load http://www.adobe.com/type/
2) Type a font name, eg. "Futura", in the keyword search box.
3) Click the button labeled ">Search".

Actual results:
There is an error message above the result page header bar. The message says you
need a browser that properly supports JavaScript and that you may need to
upgrade to Netscape Communicator 4.0 or later or IE 4.0 or later.

I didn't notice any functional problems, however.

Expected results:
Expected no error message.
Additional information:
I remember seeing the same message on other Adobe pages a long long time ago. I
guess they have forgotten to remove the message from this particular page.
(Reporter)

Comment 1

16 years ago
Contacted Adobe using their Web site feedback form. Taking bug.
Assignee: bclary → henris
Target Milestone: --- → mozilla0.9.6
(Reporter)

Updated

16 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

16 years ago
Whiteboard: message sent
(Reporter)

Comment 2

16 years ago
The site hasn't been fixed. I guess the Web site feedback form isn't an
effective channel. Reassigning to aruner@netscape, who has other Adobe
bugs.
Assignee: henris → aruner
Status: ASSIGNED → NEW
Whiteboard: message sent
Target Milestone: mozilla0.9.6 → ---
(Assignee)

Updated

16 years ago
Blocks: 114155
(Assignee)

Comment 3

16 years ago
taking.
Assignee: aruner → bclary
Priority: -- → P1
(Assignee)

Comment 4

16 years ago
contacted 12/8
Status: NEW → ASSIGNED
Target Milestone: --- → Jan
(Assignee)

Updated

16 years ago
Whiteboard: [aok]
(Assignee)

Updated

16 years ago
Keywords: evang500
(Assignee)

Comment 5

16 years ago
Error: y_styleObjShowp has no properties
Source File: http://www.adobe.com/type/
Line: 137

Looks like the type page performs server side sniffing and provides Layer based
JS to Netscape6/Mozilla/Gecko. Layers are not supported in Gecko.

Perform a search and receive this message:

To view these pages properly your browser needs to support Javascript. This may
mean that you need to upgrade to Netscape Communicator 4.0 or later, or
Microsoft Internet Explorer 4.0 or later. Also, In your browser Preferences,
enable JavaScript. Please see our error page for more information.

Although the search appears to work correctly.
Summary: adobe.com - Adobe Type Library search complains about JavaScript → adobe.com - Adobe Type Library search requires Nav4/IE4.
Whiteboard: [aok] → [USERAGENT]
(Assignee)

Updated

16 years ago
Target Milestone: Jan → May
(Assignee)

Comment 6

16 years ago
It is easy to see no one has looked at this on adobe's side.

Error: y_styleObjShowp has no properties
Source File: http://www.adobe.com/type/
Line: 142
Status: ASSIGNED → NEW
Target Milestone: May → ---

Comment 7

16 years ago
im getting the error in the debugger, but the search works ...
(Reporter)

Comment 8

16 years ago
The same problem appears on various pages on Adobe's developer site
partners.adobe.com.

Pages with the problem (there may be more):
http://partners.adobe.com/asn/developer/type/fdevsw.html
http://partners.adobe.com/asn/developer/techresources.html
http://partners.adobe.com/asn/developer/sdks.html
http://partners.adobe.com/asn/developer/serverproducts.html
http://partners.adobe.com/asn/developer/training/acrobat/main.html
http://partners.adobe.com/asn/developer/training/acrobat/eforms/mod0/main.html
http://partners.adobe.com/asn/developer/type.html
http://partners.adobe.com/asn/developer/type/main.html
http://partners.adobe.com/asn/developer/opentype/
http://partners.adobe.com/asn/developer/legalnotices.html
http://partners.adobe.com/asn/developer/technotes/acrobatpdf.html

On the support database pages the problem is slightly different:
http://support.adobe.com/devsup/devsup.nsf/main.html
(The subpages are similar.)
(Assignee)

Comment 9

15 years ago
ok, all these listed pages still have the damn message.

Comment 10

15 years ago
http://www.adobe.com/type/ (and the subsequent search page) no longer shows the
false browser warning. "y_styleObjShowp" also appears to be gone.

The false warning described by Henri Sivonen occurs on any page that references
http://partners.adobe.com/js/header_css.js

It's easy to see why:

//obsolete browser variable
var sb;
sb=0;
if ( ! document.layers && ! document.all ) {
  sb=1;
 document.write(' [html formatting omitted -F.] To view these pages properly
your browser needs to support Javascript. This may mean that you need to upgrade
to Netscape Communicator 4.0 or later, or Microsoft Internet Explorer 4.0 or
later. Also, In your browser Preferences, enable JavaScript. Please see our
error page for more information. ');
}

Note that the script is not Mac-specific, so this bug should be changed to
platform All/All.
(Assignee)

Comment 11

15 years ago
thx.
Status: NEW → ASSIGNED
OS: MacOS X → All
Hardware: Macintosh → All
Target Milestone: --- → Jan
(Reporter)

Comment 12

15 years ago
Bug 115552 covers the partners.adobe.com cases mentioned in comment #8. Marking
this bug FIXED, since the notice no longer appears in the Type Library.

Filed bug 185463 about actually purhasing fonts from Adobe online. 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.