Closed Bug 983583 Opened 6 years ago Closed 6 years ago

[Australis] Customizable items labels sometimes wrap following hyphenation rules of different language if language packs installed

Categories

(Firefox :: Menus, defect)

29 Branch
x86_64
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: aryx, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P2])

Attachments

(2 files)

Aurora 	20140313004000 on Windows 8.1 Pro

After installing a German language pack and setting general.useragent.locale to de and closing and launching Aurora again, the menu items of the Australis menu have German labels, but are wrapped following English rules, e.g.

"Seit speich-
ern"

should be

"Seite spei-
chern"

PanelUI-contents is still en-US
So I totally messed up dealing with review comments when landing this part of bug 944947. Excellent! :-\
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Whiteboard: [Australis:P2]
Attachment #8391126 - Flags: review?(archaeopteryx)
Théo, this might be affecting some of the issues you had with the French l10n for the panel :-|
Comment on attachment 8391126 [details] [diff] [review]
define missing PREF_SELECTED_LOCALE,

Review of attachment 8391126 [details] [diff] [review]:
-----------------------------------------------------------------

I am no peer, so I can only grant feedback+.
Attachment #8391126 - Flags: review?(archaeopteryx) → feedback+
(In reply to Archaeopteryx [:aryx] from comment #4)
> Comment on attachment 8391126 [details] [diff] [review]
> define missing PREF_SELECTED_LOCALE,
> 
> Review of attachment 8391126 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I am no peer, so I can only grant feedback+.

Works for me! :-)

remote:   https://hg.mozilla.org/integration/fx-team/rev/6f44869ee62c
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
Comment on attachment 8391126 [details] [diff] [review]
define missing PREF_SELECTED_LOCALE,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis / bug 944947
User impact if declined: wrong hyphenation rules followed in non-en-US
Testing completed (on m-c, etc.): was tested correctly in bug 944947, landed broken code instead of tested code - will soon be on m-c
Risk to taking this patch (and alternatives if risky): this will affect l10n, but it *should* be affecting them in a 'good' way, in that their strings get hyphenated correctly instead of the mess that it is now
String or IDL/UUID changes made by this patch: none
Attachment #8391126 - Flags: review+
Attachment #8391126 - Flags: approval-mozilla-aurora?
(In reply to :Gijs Kruitbosch from comment #3)
> Théo, this might be affecting some of the issues you had with the French
> l10n for the panel :-|

If I understand correctly, the issue here is only affecting langpacks, right? I was testing with a French localized build, not a .xpi. So, French hyphenation rules may be the cause?
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
(In reply to Théo Chevalier [:tchevalier] from comment #7)
> (In reply to :Gijs Kruitbosch from comment #3)
> > Théo, this might be affecting some of the issues you had with the French
> > l10n for the panel :-|
> 
> If I understand correctly, the issue here is only affecting langpacks,
> right? I was testing with a French localized build, not a .xpi. So, French
> hyphenation rules may be the cause?

No, as far as I can tell the code was just broken. You can verify by inspecting the "PanelUI-contents" element in DOM Inspector in a French build.
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
Attachment #8391126 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attached image Screenshot (fr build)
Well, just made a French build, "Mar-que-pages" has been fixed, but visually it's worse.
On this screenshot, the only widget that must be hyphenated is "Développement" :\
I don't know if other locales are regressing like French, though.
That behavior isn't new, see comment 0. But I agree, there should be a logic which tries to put whole words in the lines.
(In reply to Archaeopteryx [:aryx] from comment #10)
> That behavior isn't new, see comment 0. But I agree, there should be a logic
> which tries to put whole words in the lines.

I don't know that there is a way to do that. This is simple CSS hyphenation. I don't believe we have any more control over it than that, unless we switch to manual hyphenation, which would require a lot of work from localizers.
https://hg.mozilla.org/mozilla-central/rev/6f44869ee62c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 30
Keywords: verifyme
Can you please verify that this issue is fixed on Firefox 29RC and latest Aurora using french builds?
Flags: needinfo?(tchevalier)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #14)
> Can you please verify that this issue is fixed on Firefox 29RC and latest
> Aurora using french builds?

The patch is working as expected on Firefox 29.
Only the "Tabs group" widget have hyphenation that it shouldn't have, but that's my fault on the l10n side. I will fix that for Firefox 30.
Status: RESOLVED → VERIFIED
Flags: needinfo?(tchevalier)
Theo, could you please verify if this issue is also fixed on Firefox 30 beta 5? Thanks in advance.
Flags: needinfo?(tchevalier)
Thanks for asking Alexandra

Verified on Firefox 30 beta 5, put all the widgets into the menu, hyphenation is working as expected in French, "Tabs group" included.
Flags: needinfo?(tchevalier)
Thank you very much, Theo!
Marking as verified on Fx 30 based on comment 17.
Keywords: verifyme
Depends on: 1106119
You need to log in before you can comment on or make changes to this bug.