Crash while viewing email after switching themes

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
critical
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Adam Masri, Assigned: Scott MacGregor)

Tracking

({crash})

1.0 Branch
mozilla1.2alpha
PowerPC
Mac OS X
crash
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Platform: PowerBook G3/300/192Mb/25Gb, MacOS X 10.0.4
Fizzilla Build: 2001082905

I've been getting a lot of crashes with the latest builds, vs. the 7/30 build,
which was my old favorite. Here's my latest crash. This occurred while I was
deleting an email from my in box.

Some of the crashes I've been getting don't even launch Crash Reporter, which I
think is rather odd.

----------

Date/Time: 2001-09-05 07:54:19 -0700

PID:       341
Command:   Mozilla

Exception: EXC_BAD_ACCESS (0x0001)
Codes:     KERN_INVALID_ADDRESS (0x0001) at 0x05ac7198

Thread 0:
 #0   0x0166771c in RecoverMemoryReserve__18nsMacMemoryCushionFl ()
 #1   0xfffff328 in 0xfffff328 ()
 #2   0x01667684 in RepeatAction__18nsMacMemoryCushionFRC11EventRecord ()
 #3   0x0168f604 in DoRepeaters__8RepeaterFRC11EventRecord ()
 #4   0x0167b13c in DispatchEvent__16nsMacMessagePumpFiP11EventRecord ()
 #5   0x0167aa5c in DoMessagePump__16nsMacMessagePumpFv ()
 #6   0x0167a2ec in Run__10nsAppShellFv ()
 #7   0x0133313c in Run__17nsAppShellServiceFv ()
 #8   0x00094128 in main1__FiPPcP11nsISupports ()
 #9   0x00094e04 in main ()

Thread 1:
 #0   0x7000424c in _syscall ()
 #1   0x706584b8 in _ProcessReadyEvent ()
 #2   0x706582b0 in _CarbonSelectThreadFunc ()
 #3   0x70014f04 in __pthread_body ()

Thread 2:
 #0   0x70059b68 in _semaphore_wait_signal_trap ()
 #1   0x70016110 in _semaphore_wait_signal ()
 #2   0x70015f78 in __pthread_cond_wait ()
 #3   0x70015d18 in _pthread_cond_wait ()
 #4   0x70653be0 in _BSD_pthread_cond_wait ()
 #5   0x70653bc0 in _CarbonConditionWait ()
 #6   0x7065557c in _CarbonOperationThreadFunc ()
 #7   0x70014f04 in __pthread_body ()

Thread 3:
 #0   0x70059b48 in _semaphore_timedwait_signal_trap ()
 #1   0x7003f7f8 in _semaphore_timedwait_signal ()
 #2   0x70015f68 in __pthread_cond_wait ()
 #3   0x7003f7c4 in _pthread_cond_timedwait_relative_np ()
 #4   0x7029b590 in _TSWaitOnConditionTimedRelative ()
 #5   0x7029cdac in _TSWaitOnSemaphoreCommon ()
 #6   0x702e5f98 in _TSWaitOnSemaphoreRelative ()
 #7   0x702e7208 in _TimerThread ()
 #8   0x70014f04 in __pthread_body ()

Thread 4:
 #0   0x70059b68 in _semaphore_wait_signal_trap ()
 #1   0x70016110 in _semaphore_wait_signal ()
 #2   0x70015f78 in __pthread_cond_wait ()
 #3   0x70015d18 in _pthread_cond_wait ()
 #4   0x7029b550 in _TSWaitOnCondition ()
 #5   0x7029cd94 in _TSWaitOnSemaphoreCommon ()
 #6   0x7029cce4 in _TSWaitOnSemaphore ()
 #7   0x7029cba8 in _AsyncFileThread ()
 #8   0x70014f04 in __pthread_body ()

Thread 5:
 #0   0x70059b68 in _semaphore_wait_signal_trap ()
 #1   0x70016110 in _semaphore_wait_signal ()
 #2   0x70015f78 in __pthread_cond_wait ()
 #3   0x70015d18 in _pthread_cond_wait ()
 #4   0x70653be0 in _BSD_pthread_cond_wait ()
 #5   0x70653bc0 in _CarbonConditionWait ()
 #6   0x70653ab4 in _CarbonInetOperThreadFunc ()
 #7   0x70014f04 in __pthread_body ()

Thread 6:
 #0   0x700007b8 in _mach_msg_overwrite_trap ()
 #1   0x700056e4 in _mach_msg_overwrite ()
 #2   0x700277b0 in _thread_suspend ()
 #3   0x70027744 in __pthread_become_available ()
 #4   0x70027468 in _pthread_exit ()
 #5   0x70014f08 in __pthread_body ()

PPC Thread State:
  srr0: 0x0166771c srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x20000008   lr: 0x01667684  ctr: 0x0166766c   mq: 0x00000000
    r0: 0x01667684   r1: 0xbffff1e0   r2: 0x016ee000   r3: 0x05ac7198
    r4: 0x00008000   r5: 0x0000002c   r6: 0x002c9950   r7: 0x8ec93b7d
    r8: 0xee6b2800   r9: 0x8ec87470  r10: 0x00009950  r11: 0x00006d40
   r12: 0x016e6f70  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x002c4910
   r20: 0x00000000  r21: 0x002c4aa4  r22: 0x002d24c0  r23: 0x002ab100
   r24: 0x000ac9ea  r25: 0xbffff6d8  r26: 0x002bb2a8  r27: 0x002bb348
   r28: 0x002ab340  r29: 0x00000000  r30: 0xbffff328  r31: 0x016f0ff4

**********

Updated

17 years ago
Keywords: crash

Comment 1

17 years ago
->Mail.
Assignee: asa → mscott
Component: Browser-General → Mail Back End
Product: Browser → MailNews
QA Contact: doronr → esther

Comment 2

17 years ago
Adam, any word on if this crash is still occuring?

Updated

17 years ago
Blocks: 102998
(Reporter)

Comment 3

17 years ago
The number of crashes has certainly decreased in the latest builds. Whether this
specific crasher is fixed or not, I really don't know. Is there enough info in
the crash reporter log to tell you where this was coming from?

- Adam

Comment 4

16 years ago
I'm getting this, too.  Last time, I changed the theme to Modern, and then
clicked on one of the triangles associated with a mail account to view all of
its folder, and the application quit unexpectedly.  Here is the crash log:

Date/Time:  2002-01-23 16:11:56 -0600
OS Version: 10.1.2 (Build 5P48)
Host:       localhost

Command:    Mozilla
PID:        539

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x049e9460

Thread 0 Crashed:
 #0   0x01b4a478 in nsMacMemoryCushion::RecoverMemoryReserve(long)
 #1   0x000dd3ac in 0xdd3ac
 #2   0x01b4a3d8 in nsMacMemoryCushion::RepeatAction(EventRecord const &)
 #3   0x01b99b14 in Repeater::DoRepeaters(EventRecord const &)
 #4   0x01b5c998 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #5   0x01b5c570 in nsMacMessagePump::DoMessagePump(void)
 #6   0x01b5beac in nsAppShell::Run(void)
 #7   0x01b11e4c in nsAppShellService::Run(void)
 #8   0x004c8bb4 in main1(int, char **, nsISupports *)
 #9   0x004c968c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x7017bf98 in __CFRunLoopRun
 #3   0x701b7100 in CFRunLoopRunSpecific
 #4   0x7017b8e0 in CFRunLoopRunInMode
 #5   0x7061be08 in
XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
 #6   0x706141c0 in CAPThread::Entry(CAPThread *)
 #7   0x7002054c in _pthread_body

Thread 7:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x01b4a478 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000018   lr: 0x01b4a3d8  ctr: 0x01b4a3c0   mq: 0x00000000
    r0: 0x01b4a3d8   r1: 0xbffff3e0   r2: 0x01ba3000   r3: 0x049e9460
    r4: 0x00008000   r5: 0x00000000   r6: 0x00000000   r7: 0x00000000
    r8: 0x834da684   r9: 0x80240e10  r10: 0x000782f2  r11: 0x834e142c
   r12: 0x01b9c004  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000000
   r20: 0x00000000  r21: 0x00000000  r22: 0x00000000  r23: 0x00000000
   r24: 0x0010a070  r25: 0x004dfc98  r26: 0x004dfbd8  r27: 0x0010a04c
   r28: 0x00110574  r29: 0x000f7c9c  r30: 0xbffff518  r31: 0x01ba6478

**********

Date/Time:  2002-02-14 12:15:59 -0600
OS Version: 10.1.3 (Build 5Q28)
Host:       localhost

Command:    Mozilla
PID:        17600

Exception:  EXC_BAD_INSTRUCTION (0x0002)
Code[0]:    0x00000002
Code[1]:    0x03496b6c

Thread 0 Crashed:
 #0   0x03496b6c in 0x3496b6c
 #1   0x005326f0 in _pool_free
 #2   0x00560348 in hashEnumerate(PLHashEntry *, int, void *)
 #3   0x004cf524 in PL_HashTableEnumerateEntries
 #4   0x00560ab8 in nsHashtable::Enumerate(int (*)(nsHashKey *, void *, void *),
void *)
 #5   0x01ca9964 in CSSLoaderImpl::_dt(void)
 #6   0x01ca9b24 in CSSLoaderImpl::Release(void)
 #7   0x00605f14 in nsCOMPtr_base::_dt(void)
 #8   0x01ad00fc in nsDocument::_dt(void)
 #9   0x01b77b3c in nsMarkupDocument::_dt(void)
 #10  0x01af7ee0 in nsHTMLDocument::_dt(void)
 #11  0x01ad0e44 in nsDocument::Release(void)
 #12  0x01af7fb0 in nsHTMLDocument::Release(void)
 #13  0x033ee3fc in XPCJSRuntime::GCCallback(JSContext *, JSGCStatus)
 #14  0x01ff3af0 in DOMGCCallback(JSContext *, JSGCStatus)
 #15  0x019323c0 in js_GC
 #16  0x01931ae4 in js_ForceGC
 #17  0x0190fabc in JS_GC
 #18  0x01ff3924 in nsJSContext::Notify(nsITimer *)
 #19  0x006108bc in nsTimerImpl::Process(void)
 #20  0x00610954 in handleMyEvent(MyEventType *)
 #21  0x005dc990 in PL_HandleEvent
 #22  0x005dc7fc in PL_ProcessPendingEvents
 #23  0x0058165c in nsEventQueueImpl::ProcessPendingEvents(void)
 #24  0x00581704 in nsEventQueueImpl::ProcessPendingEvents(void)
 #25  0x0331fabc in nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
 #26  0x0331f880 in nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
 #27  0x0170db14 in Repeater::DoRepeaters(EventRecord const &)
 #28  0x03333938 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #29  0x03333510 in nsMacMessagePump::DoMessagePump(void)
 #30  0x03332e8c in nsAppShell::Run(void)
 #31  0x019a4d3c in nsAppShellService::Run(void)
 #32  0x004adba4 in main1(int, char **, nsISupports *)
 #33  0x004ae67c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x7017bf98 in __CFRunLoopRun
 #3   0x701b7100 in CFRunLoopRunSpecific
 #4   0x7017b8e0 in CFRunLoopRunInMode
 #5   0x7061be08 in
XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
 #6   0x706141c0 in CAPThread::Entry(CAPThread *)
 #7   0x7002054c in _pthread_body

Thread 7:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x03496b6c srr1: 0x0008d030                vrsave: 0x00000000
   xer: 0x20000008   lr: 0x01ca967c  ctr: 0x03496b6c   mq: 0x00000000
    r0: 0x03496b6c   r1: 0xbfffec90   r2: 0x00000000   r3: 0x050cba20
    r4: 0x050cba20   r5: 0x00000000   r6: 0xbfffedb8   r7: 0x0454360c
    r8: 0x00000004   r9: 0x00000000  r10: 0x2f007a70  r11: 0x00000002
   r12: 0x034963f0  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000000
   r20: 0x00000001  r21: 0x0688c098  r22: 0x0688c0a0  r23: 0x00000000
   r24: 0x00000010  r25: 0x00000007  r26: 0x051a9d5c  r27: 0x051b8f30
   r28: 0x0000001c  r29: 0x0650761c  r30: 0x006c7404  r31: 0xbfffedb8

**********

System Config:  PowerBook (FireWire) 500MHz, 160 MB RAM, 12GB HD, Mac OS X
version 10.1.3 build 5Q28 (I know that Console.app reported an older version,
but that's the latest actual release from Apple), DVD-ROM expansion bay module
installed, running from power adaptor, on DHCP Ethernet over multiple T1's.  The
only other app running was the Finder.  Also, the theme wasn't drawing the
verticle scroll arrows.

Comment 5

16 years ago
Updated Summary to reflect crash occurs after switching themes (and I'm actually
commandeering this bug as that crash is different than the one originally
reported when this bug was opened which was actually #124517) and added nsbeta1
keyword.  The log for the crash post theme switch is the 2nd log in the comment
by Miles Bainbridge

hyatt/mscott: any comments on this?  Do we have other bugs filed for crashes
post theme switch? 

Miles: Please don't put two completely different crash logs from crashes 3 weeks
apart into one comment as it just obfuscates things.
Keywords: nsbeta1
Summary: Crash while viewing email → Crash while viewing email after switching themes

Comment 6

16 years ago
Could this be related to bug 98359?

Comment 7

16 years ago
Ack.  Sorry for the mistake.  Could this be related to bug 122111?

Comment 8

16 years ago
Per mail triage, trying to determine if this is the same as 122111.  I can't
determine that by reading the talkback reports (posted in bug 122111) using
current builds on my winxp.  I do know that I can crash runing through the same
steps on MacOS9.1 Mac OSx and winxp.  
1. Launch app (browser page comes up by default)
2. Edit preference to change from Modern to Classic
3. File|Exit  or File Quit (mac os9.1)  = Crash  

Comment 9

16 years ago
Discussed at 3/4 Mail & News bug mtg with Mktng, Eng., and PjM.  Decison was to
minus bug, set for 1.2, and make dependent on bug 122111.  Please renominate if
this issue is not fixed when bug 122111 is fixed.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2

Comment 10

16 years ago
Setting dependency as described in the previous comment
Depends on: 122111

Comment 11

16 years ago
Considering bug's current status removing as a blocker for 102998
No longer blocks: 102998

Comment 12

16 years ago
Since bug# 122111 has been closed as a duplicate of bug#129620 should the
dependancy of this bug be changed so that it depends on #129620 now instead of
depending on the dupe?

Comment 13

16 years ago
I've switched over to a new system (PowerBook G4, 500 MHz, 768 MB RAM, Mac OS X
10.1.3 Build 5Q45), and have installed the final build of Mozilla 0.9.9, and I
cannot duplicat this bug anymore.  Would other people try to reproduce this in
0.9.9 to see if it has indeed been fixed, or if this is perhaps an OS/hardware
dependant bug?

Updated

16 years ago
Blocks: 134260
Product: MailNews → Core

Comment 14

13 years ago
Old version, no further responses, seems fixed.

Resolving. Feel free to reopen if you can reproduce the problem with current builds.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 1.0 Branch
Product: Core → MailNews Core

Comment 15

8 years ago
Marked as fixed, based on 4 years of 'WORKSFORME'
Resolution: WORKSFORME → FIXED

Comment 16

8 years ago
Alfred.  I dont' see how 4 years of working makes it OK to use fixed, given that FIXED has a clear technical description. Unless you've decisively concluded this was fixed by a specific patch in a specific bug#, like 129620. In which case it would be instructive to cite the bug# when closing.
Resolution: FIXED → WORKSFORME

Comment 17

8 years ago
Make it 8 years (see comment 13), which I consider more than enough proof, unless someone has a counter proof.

There was not a specific bug pinpointed, only the crash(reports), so it is not possible to pinpoint a specific fix that specifically fixed this problem.
In the years of 2000/2001/2002, the mozilla codebase could crash over so many things...
You need to log in before you can comment on or make changes to this bug.