Status

defect
--
critical
RESOLVED WORKSFORME
18 years ago
9 years ago

People

(Reporter: tt_toe, Assigned: sep)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jpibug], URL)

(Reporter)

Description

18 years ago
After running the java applet on the above page, going to a non-cached page
causes java to crash and the browser no longer responds.  All open browser
windows hang and task must be killed.

Comment 1

18 years ago
Moving to OJI
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI
QA Contact: avm → pmac

Comment 2

18 years ago
java.lang.IllegalStateException: Can't dispose InputContext while it's active

	at sun.awt.im.InputContext.dispose(InputContext.java:553)

	at java.awt.Window$1$DisposeAction.run(Unknown Source)

	at java.awt.Window.dispose(Unknown Source)

	at sun.plugin.navig.win32.PluginFrame.windowClosing
(PluginFrame.java:125)

	at java.awt.Window.processWindowEvent(Unknown Source)

	at java.awt.Window.processEvent(Unknown Source)

	at java.awt.Component.dispatchEventImpl(Unknown Source)

	at java.awt.Container.dispatchEventImpl(Unknown Source)

	at java.awt.Window.dispatchEventImpl(Unknown Source)

	at java.awt.Component.dispatchEvent(Unknown Source)

	at java.awt.EventQueue.dispatchEvent(Unknown Source)

	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

	at java.awt.EventDispatchThread.run(Unknown Source)

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 3

18 years ago
bugtraq bug 4501029.
Whiteboard: [jpibug]

Comment 4

18 years ago
Ressign to Joe Chou, as I am no longer working officially on OJI.
Assignee: edburns → joe.chou
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla0.9.6

Comment 5

18 years ago
using build 2001092603 on Win2k with JRE 1.4 beta2, I don't crash but I
sometimes get this in Java Console, browser is still usable after going to this
site. However, drawing is completely trashed, it shows the previous site, moving
the mouse over the new (uncached) page loads the mouseover images.

java.lang.IllegalStateException: Can't dispose InputContext while it's active
	at sun.awt.im.InputContext.dispose(Unknown Source)
	at java.awt.Window$1$DisposeAction.run(Unknown Source)
	at java.awt.Window.dispose(Unknown Source)
	at sun.plugin.viewer.frame.WNetscapeEmbeddedFrame.windowClosing(Unknown Source)
	at java.awt.Window.processWindowEvent(Unknown Source)
	at java.awt.Window.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Comment 6

18 years ago
Works for me on Solaris (build 095) and Linux Redhat 6.2 (build 094)
I think this is specific windows bug

Comment 7

18 years ago
Re-assign to sep.
Assignee: joe.chou → sep
Target Milestone: mozilla0.9.6 → mozilla0.9.8

Comment 8

18 years ago
Related bug bugtraq bug 4501029 was closed as duplicate of bug 4464761(related 
bugzilla bug is 82176).

To sep: I propose to close this bug as duplicate of 82176

Comment 9

18 years ago
Oops, this bug is reprodisible on w2k with JRE 1.4.0-betta3-b84.
I use current trunk and I observe the described behavior. 
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla1.0

Updated

17 years ago
QA Contact: pmac → petersen
Target Milestone: mozilla1.0 → ---
*** Bug 232086 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
(In reply to comment #0)
> After running the java applet on the above page, going to a non-cached page
> causes java to crash and the browser no longer responds.  All open browser
> windows hang and task must be killed.

Cannot access site.

Alert window:

The operation timed out when attempting to contact dmxweb.mfi.com.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040330
Microsoft Windows 2000 Pro 5.00.2195 SP4
If you want a slow loading applet to trigger this bug, go to
https://www2.bancobrasil.com.br/aapf/aai/login.pbk

But anyway, I don't believe bug #232086 is a dup of this one. So, let's turn it
into one. ;)

I'm having the same issue in Mozilla on Linux for a long time. Java
applets work great, but if you close the browser window before the applet starts
Mozilla will just hang. (see also bug #143276).

I can reproduce it all the time, just need a slow loading applet. I'm using
Mozilla 1.6, with Sun JDK 1.4.2_05, on Fedora Core 2 (kernel 2.6.6). But this
bug bugs me since Red Hat 7.3 and Sun JDK 1.3.x.

I've never tried it on Windows or Firefox, but bugs 232086 and 143276 make me
believe this issue is present in these configurations also.

If I can be of any assistance, please let me know. I've never bothered with this
bug before it is related to **** proprietary code, the Sun JRE. But, almost
two years later, it's time to do something. :)

Comment 13

15 years ago
OS > All ?

Should this have a Severity of Critical due to it crashing Mozilla (or not since
it's due to a plugin)?

Comment 14

15 years ago
Should the following changes be made?
OS -> All
Keywords -> Crash
Severity -> Critical

BTW, if the bug can't be fixed in Firefox, could we instead put in a temporary
fix to not allow the user to leave the page until the java applet has loaded?
Severity: major → critical
Keywords: crash
OS: Windows NT → All
Hardware: PC → All

Comment 15

14 years ago
*** Bug 264740 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Blocks: 353557

Comment 16

13 years ago
Testcase WFM under latest Camino TRUNK nightly 2006102501 (v1.2+) running under Mac OS 10.3.9.

No crashes.
Well, this bug dissapeared for me a long time ago. Maybe when I switched to JRE 1.5, but I can't remember.

Updated

13 years ago
No longer blocks: 353557
WFM also SM 1.1.1 using https://www2.bancobrasil.com.br/aapf/aai/login.pbk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.