Closed Bug 983699 Opened 6 years ago Closed 6 years ago

View widgets in overflow panel show panel anchored on themselves instead of chevron

Categories

(Firefox :: Toolbars and Customization, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3+])

Attachments

(1 file, 1 obsolete file)

I don't know if this is a regression, but builds from early December have this bug, so I think we just never fixed this.
Comment on attachment 8391268 [details] [diff] [review]
fix widgets in Australis overflow panel to show view on the right anchor,

Review of attachment 8391268 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8391268 - Flags: review?(jaws) → review+
Tested on Mac this time, but could do with a check on Windows because this relies on popuphiding happening sync when you hide the panel (which I believe is the case, but hey... checking wouldn't go amiss)
Attachment #8391504 - Flags: review?(jaws)
Attachment #8391268 - Attachment is obsolete: true
Comment on attachment 8391504 [details] [diff] [review]
fix widgets in Australis overflow panel to show view on the right anchor,

Review of attachment 8391504 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, however the Downloads button and the Bookmark This Page button don't set open=true on the anchor when their related panels are opened. That's not a regression from this bug though, I'm pretty sure of it since both of those buttons are pretty special.
Attachment #8391504 - Flags: review?(jaws) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/0301840bcb50
Status: NEW → ASSIGNED
Whiteboard: [Australis:P3+] → [Australis:P3+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0301840bcb50
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3+][fixed-in-fx-team] → [Australis:P3+]
Target Milestone: --- → Firefox 30
Comment on attachment 8391504 [details] [diff] [review]
fix widgets in Australis overflow panel to show view on the right anchor,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: history/developer tools/... and other view widgets that get moved into the overflow panel open their overflows in the wrong place
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8391504 - Flags: approval-mozilla-aurora?
Attachment #8391504 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:30.0) Gecko/20100101 Firefox/30.0

Verified fixed on Mac OS X 10.8 using:
- Firefox 29 RC, build ID: 20140421221237
- latest Aurora, build ID: 20140428004000.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.