Closed Bug 983809 Opened 6 years ago Closed 4 years ago

"Switch to tab" lists tab, but fails to switch to tab

Categories

(Firefox :: Address Bar, defect)

defect
Not set
Points:
5

Tracking

()

RESOLVED DUPLICATE of bug 1104165

People

(Reporter: nicolas.barbulesco, Unassigned)

References

Details

Firefox 27.

For some tabs, "Switch to tab" fails to switch to tab. 
This is not the first time I encounter this bug. 
Now, I have one recalcitrant tab, and "Switch to tab" works for other tabs. 
The bug occurs whether I choose "Switch to tab" with my mouse or with my keyboard.

Thank you for fixing this bug.
I can indeed reproduce with that specific url, thanks for the test case
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: fxdesktopbacklog
No longer blocks: fxdesktoptriage
Whiteboard: p=0
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: p=0 → p=5
Summary: "Switch to tab" fails to switch to tab → "Switch to tab" lists, but fails to switch to tab
Confirming this too.
Firefox 31.0 on Linux.

This works very unreliably when I try to type a few characters and the page history pops up under the location bar and I say "Switch to tab". It might sometimes even suggest to switch to a tab if the tab has already been closed! Then, moving to that site is very cumbersome: I have to press the mouse button in the location bar to get rid of the dropdown menu and then manually press the right "go to" arrow.
P.S. Warning: do *not* press ESC as you would do to get rid of the menu with other programs! You will end up with exactly the few characters you've typed in, with the cursor at their end position.
In Firefox 31 on Windows, I reproduce the bug.
OS: Mac OS X → All
Assignee: nobody → netzen
Points: --- → 5
Flags: qe-verify?
Whiteboard: p=5
Assignee: netzen → nobody
I suspect this might be a dupe of bug 1104165
If so, bug 1104165 is a dupe of THIS one here!
Remember that 7-digit numbers indicate that the bug report was more recent than those with 6-digit numbers.
if a bug has more context/patches/discussion, that bug is the one that stays. Bug age doesn't matter.
OK, let's quit the dupe/non-dupe discussion...there is some way more important thing.
Bug 1104165 has recently been marked RESOLVED-FIXED, so if you're right this _ought to_ implicitly fix bug 983809 as well.
yep
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1104165
(In reply to Nicolas Barbulesco from comment #1)

> With this tab the bug does occur : 
> http://webcache.googleusercontent.com/search?q=cache:1_mUPEwr9AcJ:fr.
> wikipedia.org/wiki/
> L%25C3%25A9on_Trotski+&cd=1&hl=fr&ct=clnk&gl=fr&lr=lang_af%7Clang_id%7Clang_c
> a%7Clang_cs%7Clang_da%7Clang_de%7Clang_et%7Clang_en%7Clang_fr&client=firefox-
> a
> 
> With this tab the bug does not occur : 
> https://fr.wikipedia.org/wiki/L%C3%A9on_Trotski

This case of the bug is caused by some characters in the address: the same address systematically triggers the bug.

(In reply to Marco Bonardo [::mak] from comment #6)
> I suspect this might be a dupe of bug 1104165

The issue bug 1104165 deals with the characters of the address.

Now, I encounter a different case of this bug, in Firefox 35: 
I have a tab loaded with the address https://phabricator.wikimedia.org/T98528 . This tab has the bug: when I type T98528 in another tab, "Switch to tab" is proposed but fails when chosen. *But*, when I create a new tab with the same address, this new tab does not have the bug.
Status: RESOLVED → REOPENED
Depends on: 1104165
Resolution: DUPLICATE → ---
(In reply to Nicolas Barbulesco from comment #11)

> Now, I encounter a different case of this bug, in Firefox 35: 
> I have a tab loaded with the address
> https://phabricator.wikimedia.org/T98528 . This tab has the bug: when I type
> T98528 in another tab, "Switch to tab" is proposed but fails when chosen.
> *But*, when I create a new tab with the same address, this new tab does not
> have the bug.

If it can help, here is the entry for the recalcitrant tab in the session store file: 

{"entries":[{"url":"https://phabricator.wikimedia.org/T98528","title":"⚓ T98528 mobileview \"thumbwidth\" parameter doesn't always result in return of desired image url","ID":4209,"docshellID":2214,"docIdentifier":4243}],"lastAccessed":1431787220766,"hidden":false,"attributes":{},"image":null,"index":1}
Summary: "Switch to tab" lists, but fails to switch to tab → "Switch to tab" lists tab, but fails to switch to tab
(In reply to Nicolas Barbulesco from comment #11)
> Now, I encounter a different case of this bug, in Firefox 35: 
> I have a tab loaded with the address
> https://phabricator.wikimedia.org/T98528 . This tab has the bug: when I type
> T98528 in another tab, "Switch to tab" is proposed but fails when chosen.
> *But*, when I create a new tab with the same address, this new tab does not
> have the bug.

The switch to tab fix landed in Firefox 40, and I still think it also fixed this issue. It's clearly not fixed in Firecox 35. Why should this bug be reopened?
(In reply to Marco Bonardo [::mak] from comment #13)

> (In reply to Nicolas Barbulesco from comment #11)
> > Now, I encounter a different case of this bug, in Firefox 35: 
> > I have a tab loaded with the address
> > https://phabricator.wikimedia.org/T98528 . This tab has the bug: when I type
> > T98528 in another tab, "Switch to tab" is proposed but fails when chosen.
> > *But*, when I create a new tab with the same address, this new tab does not
> > have the bug.
> 
> The switch to tab fix landed in Firefox 40, and I still think it also fixed
> this issue. It's clearly not fixed in Firecox 35. Why should this bug be
> reopened?

Marco,

Here, I described a different case of the bug. I think that it is not fixed even in Firefox 40. Here, the failure depends on something else than the address of the tab. This case is trickier, I don't know (yet) how to reproduce it.
So, different case means different bug... this should stay duped, please file a new bug for the new steps, or this is becoming hard to follow.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1104165
(In reply to Marco Bonardo [::mak] from comment #15)

> So, different case means different bug... this should stay duped, please
> file a new bug for the new steps, or this is becoming hard to follow.

Yes, it will be clearer. 

We handle the new case in this new issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1168121
You need to log in before you can comment on or make changes to this bug.