Closed Bug 984114 Opened 7 years ago Closed 7 years ago

[meta] JSHint fixes for Calendar

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kgrandon, Unassigned)

References

Details

It would be nice if Calendar was passing JSHint. I'll open blocking bugs against this one for various sections of the JS folder, and folks can feel free to grab a bug if it's unassigned.
Depends on: 984115
Depends on: 984116
Depends on: 984117
Depends on: 984118
I opened a few bugs here, there may be more to do. Also feel free to combine a few tasks if they make sense, and it's not too difficult to do. E.g., perhaps doing views/ and templates/ in one path might make sense.
Duplicate of this bug: 972865
Oops, did not see that bug! If you want to do it all in one go, feel free to, it just seemed like a ton of work to do :)
:kgrandon, it's indeed too much work to do in a single run and will be hard to review/revert a patch with too many changes.. so I'll keep doing like you initially proposed (in batches), and open new bugs for each part of the app. thanks!
Depends on: 990448
All done!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.