Closed Bug 984234 Opened 6 years ago Closed 6 years ago

Intermittent TalosError: Exception caught: junit.framework.AssertionFailedError: EditText is not found! [browser_output.txt]

Categories

(Testing :: Talos, defect)

ARM
Android
defect
Not set

Tracking

(firefox29 affected, firefox30 affected)

RESOLVED DUPLICATE of bug 915449
Tracking Status
firefox29 --- affected
firefox30 --- affected

People

(Reporter: philor, Assigned: gbrown)

Details

(Keywords: intermittent-failure)

Apparently the somebody that has to file this failure which has been going on for weeks is me.

https://tbpl.mozilla.org/php/getParsedLog.php?id=36249310&tree=Mozilla-Inbound
Android 4.0 Panda mozilla-inbound talos remote-trobocheck2 on 2014-03-16 22:00:07 PDT for push 2677424bcd7c
slave: panda-0577

22:14:51     INFO -  INFO : EventExpecter: no longer listening for Gecko:Ready
22:14:51     INFO -  Exception caught during test!
22:14:51     INFO -  junit.framework.AssertionFailedError: EditText is not found!
22:14:51     INFO -  	at junit.framework.Assert.fail(Assert.java:47)
22:14:51     INFO -  	at junit.framework.Assert.assertTrue(Assert.java:20)
22:14:51     INFO -  	at com.jayway.android.robotium.solo.Waiter.waitForAndGetView(Waiter.java:510)
22:14:51     INFO -  	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:50)
22:14:51     INFO -  	at com.jayway.android.robotium.solo.Solo.getEditText(Solo.java:1835)
22:14:51     INFO -  	at org.mozilla.gecko.tests.BaseTest$1.isSatisfied(BaseTest.java:197)
22:14:51     INFO -  	at com.jayway.android.robotium.solo.Waiter.waitForCondition(Waiter.java:370)
22:14:51     INFO -  	at com.jayway.android.robotium.solo.Solo.waitForCondition(Solo.java:426)
22:14:51     INFO -  	at org.mozilla.gecko.tests.BaseTest.waitForCondition(BaseTest.java:304)
22:14:51     INFO -  	at org.mozilla.gecko.tests.BaseTest.focusUrlBar(BaseTest.java:194)
22:14:51     INFO -  	at org.mozilla.gecko.tests.BaseTest.enterUrl(BaseTest.java:213)
22:14:51     INFO -  	at org.mozilla.gecko.tests.BaseTest.inputAndLoadUrl(BaseTest.java:244)
22:14:51     INFO -  	at org.mozilla.gecko.tests.PixelTest.loadAndGetPainted(PixelTest.java:10)
22:14:51     INFO -  	at org.mozilla.gecko.tests.PixelTest.loadAndPaint(PixelTest.java:23)
22:14:51     INFO -  	at org.mozilla.gecko.tests.testCheck2.testCheck2(testCheck2.java:13)
22:14:51     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
22:14:51     INFO -  	at java.lang.reflect.Method.invoke(Method.java:511)
22:14:51     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
22:14:51     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
22:14:51     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
22:14:51     INFO -  	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:152)
22:14:51     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:127)
22:14:51     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:106)
22:14:51     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:124)
22:14:51     INFO -  	at junit.framework.TestResult.run(TestResult.java:109)
22:14:51     INFO -  	at junit.framework.TestCase.run(TestCase.java:118)
22:14:51     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
22:14:51     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
22:14:51     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:545)
22:14:51     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1551)
22:14:51     INFO -  __FAILException caught: junit.framework.AssertionFailedError: EditText is not found!__FAIL
22:14:51     INFO -  __startBeforeLaunchTimestamp1395033214004__endBeforeLaunchTimestamp
22:14:51     INFO -  __startAfterTerminationTimestamp1395033231629__endAfterTerminationTimestamp
22:14:52     INFO -  Failed tcheck2:
22:14:52     INFO -  		Stopped Sun, 16 Mar 2014 22:14:52
22:14:52    ERROR -  Traceback (most recent call last):
22:14:52     INFO -    File "/builds/panda-0577/talos-data/talos/run_tests.py", line 329, in run_tests
22:14:52     INFO -      talos_results.add(mytest.runTest(browser_config, test))
22:14:52     INFO -    File "/builds/panda-0577/talos-data/talos/ttest.py", line 423, in runTest
22:14:52     INFO -      test_results.add(browser_log_filename, counter_results=self.counter_results)
22:14:52     INFO -    File "/builds/panda-0577/talos-data/talos/results.py", line 128, in add
22:14:52     INFO -      browserLog = BrowserLogResults(filename=results, counter_results=counter_results, global_counters=self.global_counters)
22:14:52     INFO -    File "/builds/panda-0577/talos-data/talos/results.py", line 322, in __init__
22:14:52     INFO -      self.error(match.group(1))
22:14:52     INFO -    File "/builds/panda-0577/talos-data/talos/results.py", line 337, in error
22:14:52     INFO -      raise utils.TalosError(message)
22:14:52     INFO -  TalosError: Exception caught: junit.framework.AssertionFailedError: EditText is not found! [browser_output.txt]
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915449
You need to log in before you can comment on or make changes to this bug.