Closed Bug 984238 Opened 6 years ago Closed 6 years ago

[tarako] keyboard sometimes didn't appear when sending sms through contact

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

Other
Other
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified, b2g-v1.4 verified, b2g-v2.0 verified)

VERIFIED FIXED
2.0 S1 (9may)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified
b2g-v1.4 --- verified
b2g-v2.0 --- verified

People

(Reporter: angelc04, Assigned: timdream)

References

Details

(Keywords: regression, Whiteboard: 1.3tarakorun1)

Attachments

(3 files)

Attached file adb logcat
Test environment: tarako v1.3t
-------------------------------------------------------------
gaia revision:"15385efaf840090391d182d821eaeda6d25cf0e0"
gecko revision="88b69c90707a51060b3c3164c95a16766553985d"
build ID: 20140317060055


Steps to reproduce
-------------------------------------------------------------
1.Launch Contact and create a contact with phone number
2.Select the contact created and open the contact detail page
3. Tap on send SMS button, SMS is launched
4. Tap on the Message body to input
   --> Sometimes keyboard cannot be launched. The reproduce rate is 3/5.

Log
--------------------------------------------------------------
Attached is the adb log. Test starts at: 03-17 13:52:14.031
how easy is it to reproduce this? thanks
Flags: needinfo?(pcheng)
It's pretty easy to reproduce.  It's a general keyboard issue.  First launch and tapping into any text field for any app ( ie SMS, email setup ) does not show the keyboard.

This bug does not occur on 1.3 Buri on today's build ( build id : 20140317004001 )
blocking-b2g: --- → 1.3T?
I will investigate, since there are strange things in the logcat.
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(fabrice)
Duplicate of this bug: 984319
Duplicate of this bug: 984635
The reproduce rate on today's build is lower: 1/10.

gaia revision="abf210d0ea2f6bf1c43be46fde67521aa36af0db"
gecko revision="3fb98dffed72c590ad831ae56a711ce406239720"
build id: 20140318104052

But on build 20140317060055, it's very easy to reproduce. The rate is about 3/5.
Flags: needinfo?(pcheng)
Marketplace shows a higher precentage of reproduction:
see bug 984635

It was marked off as a duplicate; I am not sure if it is.
I noticed that the Chinese keyboard is on by default?  Is that intentional?
Hm, I could not reproduce. :(
Flags: needinfo?(fabrice)
William, could you help us and see if this reproduces? Thanks.
Flags: needinfo?(whsu)
Hi, Tim,

It is easy to reproduce it.
I have filed a duplicate bug (Bug 984319).
Thanks.
Flags: needinfo?(whsu)
Update: I am getting an unknown old build from William and I cannot reproduce this bug. William said he will be able to tackle this bug by verifying against each build.

I suspect this is a platform regression since this part of code in 1.3/1.3t didn't change much in the development cycle.
Component: Gaia::Keyboard → Gaia::System::Input Mgmt
With app manager I can now confirm the problem lies on keyboard manager; it failed to recreate keyboard iframe after memorypressure event cause the previous iframe being removed.

Temporary assign this bug to myself before Rudy can finish his last 1.3 bug.
Assignee: nobody → timdream
I mistakenly wiped the tarako William gave me so I ask him to re-flash the build for me.
This cause of this bug is because memorypressure event will kill the keyboard we are about to show....

E/GeckoConsole( 1413): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] mozmemorypressure event
E/GeckoConsole( 1413): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] mozmemorypressure event
E/GeckoConsole( 1413): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] get focus event textarea
E/GeckoConsole( 1413): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] set layout to display: type=text index=0
E/GeckoConsole( 1413): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] mozmemorypressure event
Status: NEW → ASSIGNED
Depends on: 957880
Tim, we could ignore memory pressure during N seconds after "set layout to display:..." ?
With a quick patch I will be am able to protect the keyboard when it's being launched (but not shown yet)

E/GeckoConsole( 2593): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] get focus event textarea
E/GeckoConsole( 2593): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] set layout to display: type=text index=0
E/GeckoConsole( 2593): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] mozmemorypressure event
E/GeckoConsole( 2593): Content JS LOG at app://system.gaiamobile.org/js/keyboard_manager.js:91 in km_debug: [Keyboard Manager] resizeKeyboard: 230

The keyboard event on the 3rd line did not remove the keyboard.
(In reply to Fabrice Desré [:fabrice] from comment #15)
> Tim, we could ignore memory pressure during N seconds after "set layout to
> display:..." ?

I ended up protect the keyboard with it's active status.
Comment on attachment 8394576 [details] [review]
mozilla-b2g:v1.3t PR#17422

I thought about having the |active| state kept for each keyboard frame, but for 1.3 there is only going to be one keyboard frame, so it doesn't really matter.
Attachment #8394576 - Flags: review?(rlu)
Attachment #8394576 - Flags: feedback?(fabrice)
Comment on attachment 8394576 [details] [review]
mozilla-b2g:v1.3t PR#17422

I left a comment on github
Attachment #8394576 - Flags: feedback?(fabrice) → feedback+
Comment on attachment 8394576 [details] [review]
mozilla-b2g:v1.3t PR#17422

Looks good to me, r+.

Thanks for digging into this issue.
Attachment #8394576 - Flags: review?(rlu) → review+
This can land once the tree reopens.
Keywords: checkin-needed
We need this in the 1.4 too.
Tm, can you please request approval-gaia-v1.4: ? and help fill in the details to consider the 1.4 backport ?
Flags: needinfo?(timdream)
Whiteboard: [1.4-approval-needed]
Comment on attachment 8394576 [details] [review]
mozilla-b2g:v1.3t PR#17422

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 957880
[User impact] if declined: non-oop'd keyboard will sometimes not shown.
[Testing completed]: manually.
[Risk to taking this patch] (and alternatives if risky): unlikely, minimal code change.
[String changes made]: no
Attachment #8394576 - Flags: approval-gaia-v1.4?
Flags: needinfo?(timdream)
Whiteboard: [1.4-approval-needed]
Keywords: verifyme
Attachment #8394576 - Flags: approval-gaia-v1.4? → approval-gaia-v1.4+
Whiteboard: 1.3tarakorun1
Verified it on latest Tarako build.
Thanks for the help.

* Build Info.:
 - Gaia      d8ff994bd96c37ba9a93c343932a5441a78a0eec
 - Gecko     6db37b3f76b4fe2aa6f8fb5ae9e036ed99344772
 - BuildID   20140327060053
 - Version   28.1

* Result:
 - Cannot reproduce
Status: RESOLVED → VERIFIED
Just changing the status-b2g-V1.3T flag to not mess up with my uplift query.
Verified for v1.3T. I am unable to reproduce this issue on the latest v1.3T Tarako build:

v1.3T Environmental Variables:
Device: Tarako v1.3T MOZ RIL
BuildID: 20140530014002
Gaia: e68858693b71d917c9c5ee7e215f7ceea04635f7
Gecko: 1945abae19ff
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-5-12
You need to log in before you can comment on or make changes to this bug.