[Modern] Hover Over Sidebar Tabs Gives Flashing Images

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
Sidebar
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: sol, Assigned: Stuart Parmenter)

Tracking

({regression})

Trunk
mozilla0.9.8
x86
Windows NT
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-] [ETA 10/3])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
If you hover over the tab headings in Sidebar, the tabs flash. The angled and
highlighted Sidebar tab flashed with a block of grey.

Using Build 2001-09-03-03 commercial trunk on WinNT.

Steps to reproduce.

1. Launch the browser.

2. Hover over collapsed Sidebar tabs (go up and down over the collapsed tabs).

Expected result: As you hover over a collapsed Sidebar tab, the edge of the tab
changes from grey to a highlighted green/blue.

Actual result: As you hover over a collapsed Sidebar tab, a grey block is
quickly flashed on top of the Sidebar tab. Note that after the flashing grey
block goes away, the collapsed Sidebar tab is correctly highlighted.

Comment 1

17 years ago
confirmed 2001090508-trunk linux.

Comment 2

17 years ago
--> sgehani
Assignee: matt → sgehani

Comment 3

17 years ago
okay I see what Sol sees but in a different circumstance.

First of all, I only see this with modern theme.

1) launch netscape with sidebar open

make sure your mouse is on/over the sidebar

as the tabs are loading in the sidebar you'll see
a grey block on the tabs as you glide your mouse.
and if y u move your mouse up and down, you'll
see that same block over each tab.

but for me, it goes away really quickly and
they tabs go back to their normal state(the edge of the tab
changes from grey to a highlighted green/blue).

so I think its a themes bug/issue.

Sol, I think for you experience the problem more
than I do cause you might be on a slower machine.
In my case I experience it, but very briefly.

Samir, you can assign this bug to Themes if you like.
qa_contact = pmac@netscape.com and cc: sujay@netscape.com
and sgehani@netscape.com

Comment 4

17 years ago
--> Themes
Assignee: sgehani → hewitt

Updated

17 years ago
QA Contact: sujay → pmac
Summary: Hover Over Sidebar Tabs Gives Flashing Images → [Modern] Hover Over Sidebar Tabs Gives Flashing Images

Comment 5

17 years ago
taking
(Reporter)

Updated

17 years ago
Keywords: nsbranch, regression
Whiteboard: pdt
(Reporter)

Comment 6

17 years ago
I did not realize this was not already on the must fix radar. I think this is a
very visible regression that must be fixed.

My machine is not particularly slow (400 MHz) - I believe that this is probably
the median machine speed among users.

While the tabs do return to their correct state after you stop moving your
mouse, the problem does reappear as you begin moving your mouse over the sidebar
tab headings again.

Comment 7

17 years ago
I can't reproduce this on my computer, but I have seen it in action on
stephend's win2k box.

Something appears to be going awry in the painting code somewhere.  This
behaviour is definitely not caused by any error in the modern theme.

I'll take an initial guess and suggest that this may have regressed due to pav's
changes to background painting, since the images that you see flashing are
indeed css backgrounds.
Assignee: hewitt → pavlov
(Reporter)

Comment 8

17 years ago
Still seeing this using 2001-09-24 commercial (Modern theme) on Win98.

Pav: Will you have cycles to investigate?

Comment 9

17 years ago
Adding trudelle and gagan.

Comment 10

17 years ago
Is this happening on the branch builds as well?  I tried to reproduce this on
the 9-24 branch and trunk builds and was unable to.

Comment 11

17 years ago
I will try on branch and report back here.

Comment 12

17 years ago
I still see on branch....however the problem I see is not
as bad as what Sol sees...I see the grey boxes very breifly
on initial open of sidebar.

Sol seems to see it more often even after launch when he glides
his mouse over the tabs.

Pav ?

Comment 13

17 years ago
pav thinks this is a dup of bug 92248. We should wait till that one is resolved.

Updated

17 years ago
Keywords: nsbranch → nsbranch+

Comment 14

17 years ago
*** Bug 100197 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

17 years ago
keep an eye in 92248 for updates since thats where the work is happening.

Updated

16 years ago
Whiteboard: pdt → [PDT] [ETA 10/1]

Updated

16 years ago
Whiteboard: [PDT] [ETA 10/1] → [PDT] [ETA 10/3]
(Assignee)

Comment 16

16 years ago
The more I think about this, the less I think it is related to bug 92248.

Unfortunatly, I am unable to see any flashing in 0.9.4 or trunk builds on 
windows with or without my patch in 92248.  I only have modern and classic 
installed and I do not see this problem in either of them.  Are you using some 
other theme?  I know sujay said he saw this in modern, but I don't see it... :(

I need to see this on someone else's machine to get a better idea of what might 
be going on here.
(Reporter)

Comment 17

16 years ago
Pav: I can show you on 2 different machines in my cube - one running Win98 and
one running WinNT.

Both are running 2001-10-02 commercial branch with the modern theme.

When I hover over sidebar tabs, repainting is *really* slow.

I also have 6.1 RTM installed on the Win98 machine, using the modern theme, and
I do *not* see the problem.

I'll be away from my desk, but you can page me if you want, using the number in
the phonebook.

Comment 18

16 years ago
sorry to say, we have run out time = PDT-
Whiteboard: [PDT] [ETA 10/3] → [PDT-] [ETA 10/3]

Comment 19

16 years ago
I see this the first time I mouse over my sidebar tabs using a 094 branch build
from today. Once we've loaded the mouse over image once though, I don't see it
anymore.
(Reporter)

Comment 20

16 years ago
I am truly cursed - I see this *every* time I mouse over the sidebar tabs.
Created attachment 54288 [details]
1st screenshot showing bad painting
Created attachment 54289 [details]
Yet another, this time only on a few tabs

Comment 23

16 years ago
It seems to be related to the user's profile somehow. In some profiles I 
see it and in others I dont. But it's not consistent at all for me.

Comment 24

16 years ago
it's completely consistent for me.  I see it on my regular profile. But if i
create a brand new profile the problem goes away comletely!  switch back, it
comes back. switch again, it goes away. but if i switch back it comes back.
there's a definite pattern here.

i can't believe this is minused

Comment 25

16 years ago
can we get a target milestone for this bug please? thanks.

Updated

16 years ago
Blocks: 107066

Updated

16 years ago
Keywords: nsbranch+

Comment 26

16 years ago
so what have we decided to do on this one? can we at least
get a target milestone for now...

Comment 27

16 years ago
Pav? Stuart?  Mr. Parmenter?
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla0.9.8

Comment 28

16 years ago
Hmmmmm.... since the updates to Modern this week I haven't seen this anymore.

Comment 29

16 years ago
Ok, on build 2002020403 I am still seeing this, but is not as obvious... the
phantom grey square on mouseover appears and disappears a LOT quicker but it is
still there.  You have to look fairly hard to see it but basically it creates a
*very* brief flicker.

Updated

16 years ago
Keywords: nsbeta1
(Assignee)

Comment 30

16 years ago
this is fixed by the checkin for bug 108161.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Depends on: 108161
Resolution: --- → FIXED

Comment 31

16 years ago
Sol, check it out in tomorrow's build...let us know if its fixed for you.
(Reporter)

Comment 32

16 years ago
I am no longer seeing the problem.

Comment 33

16 years ago
marking verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.