Closed Bug 984379 Opened 6 years ago Closed 6 years ago

crashes [NS_ABORT_OOM(unsigned int) | nsAString_internal::Assign(wchar_t const*, unsigned int] because of loading streaming videos

Categories

(Core :: Internationalization, defect, critical)

27 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox28 --- wontfix
firefox29 --- wontfix
firefox30 --- wontfix
firefox31 --- verified

People

(Reporter: suburp212, Assigned: m_kato)

Details

(Keywords: crash, Whiteboard: [bugday-20140317])

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

I loaded two parallel youtube videos


Actual results:

firefox crashed, crash reporter appeared (https://crash-stats.mozilla.com/report/index/cba10729-8d3d-4fde-a57f-9e6ec2140302)


Expected results:

loaded normally
Crash Signature: NS_ABORT_OOM(unsigned int) | nsAString_internal::Assign(wchar_t const*, unsigned int)
Crash Signature: NS_ABORT_OOM(unsigned int) | nsAString_internal::Assign(wchar_t const*, unsigned int) → [@ NS_ABORT_OOM(unsigned int) | nsAString_internal::Assign(wchar_t const*, unsigned int) ]
Keywords: crash
Severity: normal → critical
Whiteboard: [bugday-20140317]
nsScriptableUnicodeConverter should use fallible_t.
Status: UNCONFIRMED → NEW
Component: Untriaged → Internationalization
Ever confirmed: true
Product: Firefox → Core
Attached patch FixSplinter Review
Assignee: nobody → m_kato
Attachment #8397039 - Flags: review?(smontagu)
Attachment #8397039 - Flags: review?(smontagu) → review+
Comment on attachment 8397039 [details] [diff] [review]
Fix

>     // No Adopt on nsACString :(
>-    _retval.Assign(str, len);
>+    if (!_retval.Assign(str, len, mozilla::fallible_t())) {
>+      rv = NS_ERROR_OUT_OF_MEMORY;
>+    }
>     moz_free(str);
The comment lies! It probably predates the "latest" string API overhaul. _retVal.Adopt(str, len) should be fine.
(In reply to neil@parkwaycc.co.uk from comment #4)
> Comment on attachment 8397039 [details] [diff] [review]
> Fix
> 
> >     // No Adopt on nsACString :(
> >-    _retval.Assign(str, len);
> >+    if (!_retval.Assign(str, len, mozilla::fallible_t())) {
> >+      rv = NS_ERROR_OUT_OF_MEMORY;
> >+    }
> >     moz_free(str);
> The comment lies! It probably predates the "latest" string API overhaul.
> _retVal.Adopt(str, len) should be fine.

really?  This issue will continue to bug 989835.
https://hg.mozilla.org/mozilla-central/rev/c8ecf1ba4139
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Suburp, can you confirm the latest Nightly no longer crashes for you?
Flags: needinfo?(suburp212)
I'm still seeing two crashes with this signature post-fix.

Firefox 31 2014-04-09: https://crash-stats.mozilla.com/report/index/c1960493-8b08-44fb-811c-e6f592140410
Firefox 31 2014-04-12: https://crash-stats.mozilla.com/report/index/95729cf6-3de5-4270-9e42-5476f2140414

Should this bug get reopened?
There is a user that was experiencing this in the forums for 30-31 [https://support.mozilla.org/en-US/questions/994049] Firefox is hanging or crashing. There are some screenshots in the thread as well.
i had yesterday a crashe linked to this report in Firefox 33. Therfore it seems to be not fixed :(
(In reply to lars.gusowski+bugzilla from comment #11)
> https://crash-stats.mozilla.com/report/index/d5e42902-5280-4f53-8b92-
> 799d92140613

Thanks for sharing your report, Lars. You might be getting a different crash with the same signature, your stack looks different than what was originally reported here. I'll leave it to the developers on this bug to determine if this bug report should be reopened or if you should file a new bug report.
(In reply to Liz Henry :lizzard from comment #13)
> m_kato, can you look at lars's crash from comment 11?  Do you think this is
> a different crash with the same signature? We have several new reports with
> the same signature:
> 
> https://crash-stats.mozilla.com/query/?product=Firefox&version=Firefox%3A31.
> 0b&range_value=1&range_unit=weeks&date=06%2F19%2F2014+22%3A00%3A00&query_sear
> ch=signature&query_type=contains&query=NS_ABORT_OOM%28unsigned+int%29+|+nsASt
> ring_internal%3A%3AAssign%28wchar_t+const*%2C+unsigned+int&reason=&release_ch
> annels=&build_id=&process_type=any&hang_type=any
> 
> Thanks!

It is different.   I think we should add nsAString_internal::Assign to skiplist of crash reporter.
Flags: needinfo?(m_kato)
filed as bug 1033883 for skiplist request.
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #7)
> Suburp, can you confirm the latest Nightly no longer crashes for you?

I couldn't reproduce the crash on the 31, but that doesn't mean it's fixed permanently, as these other comments suggest.
Flags: needinfo?(suburp212)
(In reply to Suburp from comment #16)
> (In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #7)
> > Suburp, can you confirm the latest Nightly no longer crashes for you?
> 
> I couldn't reproduce the crash on the 31, but that doesn't mean it's fixed
> permanently, as these other comments suggest.

Thanks for checking. The other comments will be addressed in a follow-up bug. Marking this verified fixed.
You need to log in before you can comment on or make changes to this bug.