Closed Bug 984530 Opened 7 years ago Closed 7 years ago

Bing search tags are not working properly

Categories

(Firefox for Android Graveyard :: General, defect)

27 Branch
All
Android
defect
Not set
critical

Tracking

(firefox29+ fixed, firefox30+ fixed, firefox31+ fixed)

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 + fixed
firefox30 + fixed
firefox31 + fixed

People

(Reporter: mconnor, Assigned: mconnor)

References

Details

Attachments

(1 file)

In looking into the Yahoo report (bug 983723) it looks like Bing is just plain broken on 27/28 (haven't looked into older bugs).  The plugin is set up to only send codes if the engine is default, but even if that's correct it's not working.  It's also using the desktop codes, rather than the codes for Firefox for Android.  I believe, and I'm waiting for Joanne to confirm, that we should be sending the codes at _least_ for all beta/official searches, and potentially for all channels.  The patch should be straightforward once we've decided exactly what it needs to do.
Group: mozilla-employee-confidential
Summary: Yahoo search tags are not working properly → Bing search tags are not working properly
Attached patch bingSearchCodesSplinter Review
These codes are not branch-specific, and not position-specific.  Making use of tablet vs. mobile because those tags are different.
Assignee: nobody → mconnor
Status: NEW → ASSIGNED
Attachment #8401626 - Flags: review?(mark.finkle)
Attachment #8401626 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/4846a0ac4a50
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8401626 [details] [diff] [review]
bingSearchCodes

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 903084
User impact if declined: missing rev credit for Bing
Testing completed (on m-c, etc.): baking for a while
Risk to taking this patch (and alternatives if risky): it's not working now, it won't change much
String or IDL/UUID changes made by this patch: none
Attachment #8401626 - Flags: approval-mozilla-beta?
Attachment #8401626 - Flags: approval-mozilla-aurora?
Comment on attachment 8401626 [details] [diff] [review]
bingSearchCodes

Approving because it is a small change.
Attachment #8401626 - Flags: approval-mozilla-beta?
Attachment #8401626 - Flags: approval-mozilla-beta+
Attachment #8401626 - Flags: approval-mozilla-aurora?
Attachment #8401626 - Flags: approval-mozilla-aurora+
The bing search is no longer present in the default search engines.
Logged bug 997179 for this issue.
Tested on Nightly 31.0a1 (2014-04-16) using Google Nexus 7 (Android 4.4.2).
Depends on: 997179
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.