Closed Bug 984548 Opened 7 years ago Closed 7 years ago

Can't pan on the entire page after zooming

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

28 Branch
All
Android
defect
Not set
normal

Tracking

(firefox28 unaffected, firefox29 unaffected, firefox30+ verified, firefox31 verified, b2g-v1.4 fixed, b2g-v2.0 fixed, fennec30+)

RESOLVED FIXED
Firefox 31
Tracking Status
firefox28 --- unaffected
firefox29 --- unaffected
firefox30 + verified
firefox31 --- verified
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed
fennec 30+ ---

People

(Reporter: marco, Assigned: kats)

References

()

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

STR:
1) Zoom on the right side of the page
2) Try to pan to the left
3) Notice that you can't pan all the way to the left

Works in Beta (28), doesn't work in Nightly (30).
Tested this against m-c (30) and m-a (29), reproducible.

Needs a regression-range. Flaviu?
tracking-fennec: --- → ?
Flags: needinfo?(flaviu.cos)
Flags: needinfo?(bugmail.mozilla)
Last good revision: b0e7f63c2138 (2014-03-07)
First bad revision: d01bf8596d3b (2014-03-08)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b0e7f63c2138&tochange=d01bf8596d3b
Flags: needinfo?(flaviu.cos)
bug 960146? I think this will need an inbound/fx-team range.
Last good revision: 9f57c9fd8d52
First bad revision: b0406a8daedd
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f57c9fd8d52&tochange=b0406a8daedd
That's still quite a hefty window. I do see bug 975962?
Can we not get a narrower window? The inbound window is larger than the m-c window!
Flags: needinfo?(bugmail.mozilla)
Last good revision: ee113a965f7a
First bad revision: 62c2807d9680
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ee113a965f7a&tochange=62c2807d9680
Called it, thanks Flaviu
Blocks: 975962
Assignee: nobody → bugmail.mozilla
Note to self - need to check if this happens on Firefox OS.
It probably won't. The problem is that we fixed overflow:hidden scrolling for B2G, which involved pieces that were in shared layout code as well as B2G-specific bits. So Fennec got the shared changes but no corresponding Fennec-specific bits.
tracking-fennec: ? → 30+
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #10)
> It probably won't. The problem is that we fixed overflow:hidden scrolling
> for B2G, which involved pieces that were in shared layout code as well as
> B2G-specific bits. So Fennec got the shared changes but no corresponding
> Fennec-specific bits.

Yup - you are right. Works fine on Firefox OS.
This restores the old behaviour for Fennec. I can look into making Fennec work the same way B2G does as a separate bug since it will be more involved (my quick attempt didn't work and it will need more time). I'll probably morph bug 886969 to do proper overflow:hidden handling in Fennec unless we just port Fennec to APZC first in which case we get it for free.
Attachment #8395669 - Flags: review?(tnikkel)
Attachment #8395669 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/25a9b5b26455
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8395669 [details] [diff] [review]
Ifndef the overflow:hidden changes for fennec

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 975962
User impact if declined: pages which have overflow:hidden on the body won't scroll leftwards or upwards
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): pretty low risk, assuming this is verified on m-c
String or IDL/UUID changes made by this patch: none
Attachment #8395669 - Flags: approval-mozilla-aurora?
Verified as fixed in build 31.0a1 (2014-03-26);
Device Asus Transformer Tab (Android 4.2.1).
I uplifted this to aurora while uplifting bug 957668. Bug 957668 was based on top of this and it would have been more error prone to not uplift this then to uplift it.
https://hg.mozilla.org/releases/mozilla-aurora/rev/e2f688901bb2
Comment on attachment 8395669 [details] [diff] [review]
Ifndef the overflow:hidden changes for fennec

just putting on the + for history - no worries, i understand the need to land it at that time.
Attachment #8395669 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed in build 30.0a2 (2014-04-03);
Device Asus Transformer Tab (Android 4.0.3).
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.