Closed Bug 984628 Opened 6 years ago Closed 6 years ago

share button no longer works

Categories

(Firefox Graveyard :: SocialAPI, defect)

x86
macOS
defect
Not set

Tracking

(firefox29 fixed, firefox30 fixed, firefox31 fixed)

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

Details

Attachments

(2 files, 2 obsolete files)

I've seen various broken issues with the share button in fx30, unable to repro in fx29.  Initially noticed on fx-team build from today on linux, reproduced on osx.

- after removing share providers button is still visible
- after adding first share provider button is not visible
- share button became visible after installing 3 share providers

str

all str using http://mixedpuppy.github.io/socialapi-directory/

- start with no share providers
- install facebook share
X share button becomes visible but will not open on click
- remove facebook share
X button remains visible, should not be
- add facebook share again
X share button becomes visible but will not open on click
- add g+ mockup
X share button remains visible but will not open on click
- add demo provider
X share button remains visible and CAN be opened on click
Attached patch fix button states (obsolete) — Splinter Review
regression caused by bug 894806, r? first come first serve.
Assignee: nobody → mixedpuppy
Attachment #8393719 - Flags: review?(mhammond)
Attachment #8393719 - Flags: review?(felipc)
Blocks: 894806
Comment on attachment 8393719 [details] [diff] [review]
fix button states

Review of attachment 8393719 [details] [diff] [review]:
-----------------------------------------------------------------

Seeing we regressed this I think we should consider adding a test for the regressed behaviour.
Attached patch fix button states (obsolete) — Splinter Review
now with tests!

I ran the tests without the fixes to ensure they properly failed.  One of the reasons these passed was that the share tests included a sidebar, which bypassed one of the primary bugs.  Now that we have some share-only providers I started hitting that bug.

I'm pretty sure this is fx30-only, but am going to test other versions tomorrow to make sure.
Attachment #8393719 - Attachment is obsolete: true
Attachment #8393719 - Flags: review?(mhammond)
Attachment #8393719 - Flags: review?(felipc)
Attachment #8393895 - Flags: review?(mhammond)
Comment on attachment 8393895 [details] [diff] [review]
fix button states

Review of attachment 8393895 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

::: browser/base/content/test/social/browser_share.js
@@ +14,4 @@
>  function test() {
>    waitForExplicitFinish();
>  
> +  //runSocialTestWithProvider(manifest, function (finishcb) {

just kill these commented lines

@@ +130,5 @@
> +        checkSocialUI();
> +        // share should not be enabled since we only have about:blank page
> +        let shareButton = SocialShare.shareButton;
> +        is(shareButton.disabled, false, "share button is enabled");
> +        // verify the attribute ifor proper css

same typo here

::: browser/base/content/test/social/browser_social_marks.js
@@ +82,5 @@
> +
> +      // bypass widget go directly to dom, check attribute states
> +      let button = document.getElementById(id);
> +      is(button.disabled, true, "mark button is disabled");
> +      // verify the attribute ifor proper css

typo here
Attachment #8393895 - Flags: review?(mhammond) → review+
review comments addressed.

https://tbpl.mozilla.org/?tree=Try&rev=c322276ccbc5
Attachment #8393895 - Attachment is obsolete: true
Attachment #8393915 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/5d6187699584
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8393915 [details] [diff] [review]
fix button states

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 894806
User impact if declined: share button will not open when clicked on
Testing completed (on m-c, etc.): fx-team, m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8393915 - Flags: approval-mozilla-aurora?
Attachment #8393915 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Beta is also affected by this to a lesser extent.  Whereas opening the share panel was broken in addition to ui glitches the patch fixed, for beta it is limited to the ui glitches.  The patch is largely the same, just one chunk removed from the beta version of the patch.
[Approval Request Comment]
Bug caused by (feature/regressing bug #): australis changes
User impact if declined: visual impact in button appearance in share and marks
Testing completed (on m-c, etc.): m-c, manually on beta
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8395766 - Flags: review+
Attachment #8395766 - Flags: approval-mozilla-beta?
Attachment #8395766 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.