Closed Bug 984630 Opened 6 years ago Closed 6 years ago

socialapi buttons have no hover state, incorrect padding, etc on linux

Categories

(Firefox Graveyard :: SocialAPI, defect)

x86
Linux
defect
Not set

Tracking

(firefox28 unaffected, firefox29+ verified, firefox30+ verified, firefox31 verified)

VERIFIED FIXED
Firefox 31
Tracking Status
firefox28 --- unaffected
firefox29 + verified
firefox30 + verified
firefox31 --- verified

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Details

Attachments

(1 file)

fx-team build from today looking to verify bug 984535, noticed lack of hover state for any socialapi buttons
Summary: socialapi buttons have no hover state on linux → socialapi buttons have no hover state, incorrect padding, etc on linux
This fixes a number of styling issues on linux, now hover and open states work, correct padding, which also happens to fix a hidden icon on the socialmarks button.
Assignee: nobody → mixedpuppy
Attachment #8393717 - Flags: review?(gijskruitbosch+bugs)
Attachment #8393717 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/9b2695a22c2f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8393717 [details] [diff] [review]
fix linux social button styling

[Approval Request Comment]
Bug caused by (feature/regressing bug #): australis
User impact if declined: incorrectly sized toolbar buttons, missing icons for socialmarks
Testing completed (on m-c, etc.): fx-team and m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8393717 - Flags: approval-mozilla-beta?
Attachment #8393717 - Flags: approval-mozilla-aurora?
Attachment #8393717 - Flags: approval-mozilla-beta?
Attachment #8393717 - Flags: approval-mozilla-beta+
Attachment #8393717 - Flags: approval-mozilla-aurora?
Attachment #8393717 - Flags: approval-mozilla-aurora+
Verified as fixed using Firefox 29 beta 3, latest Aurora and latest Nightly on Ubuntu 12.04 32bit.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.