Closed Bug 984677 Opened 6 years ago Closed 6 years ago

two step bookmarking requires too much effort

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- unaffected
firefox30 --- verified
firefox31 --- verified
fennec 30+ ---

People

(Reporter: kbrosnan, Assigned: bnicholson)

References

Details

Attachments

(2 files)

One of the things I love about Firefox is how simple it is to bookmark a site. I have been using the new two step bookmarking for a few weeks now and I have come to realize I hate having to make the second tap.

I don't have any solid step forward other than to ask Ian and Arun to consider different flows. Maybe make it a bookmark by default and show the sub-menu to allow users to move the check mark.
Flags: needinfo?(ibarlow)
Flags: needinfo?(abc)
Thanks Kevin. You aren't the first person to have mentioned this, we'll give it some thought.
Flags: needinfo?(ibarlow)
tracking-fennec: ? → 30+
Assignee: nobody → ibarlow
It seems like if we've marked this for 30, the safest play would be to revert back to what we had before. So, no submenu. 

I still want to find ways to increase the usage of some of our lesser known features. But I concede that this particular interaction may not be the best approach.
Brian, can you please back out bug 965453?
Assignee: ibarlow → bnicholson
This effectively backs out bug 965453, bug 976006, and bug 977669.
Attachment #8394343 - Flags: review?(mark.finkle)
Flags: needinfo?(abc)
For Fx30 uplift: same patch as above rebased onto Aurora but without the string removals.
Attachment #8394344 - Attachment description: Back out bookmark submenu → Back out bookmark submenu (for Aurora)
Attachment #8394344 - Flags: review?(mark.finkle)
Status: NEW → ASSIGNED
Comment on attachment 8394343 [details] [diff] [review]
Back out bookmark submenu

I am sad to see the good cleanup parts of these patches get backed out, heck I am not 100% sure I want this backed out at all.

I am resigned to back it out so we do not put pressure on Ian or Dev & QA to get this fixed before the trains move on.

Maybe you could file a bug to add back some of the refactor parts?
Attachment #8394343 - Flags: review?(mark.finkle) → review+
Comment on attachment 8394344 [details] [diff] [review]
Back out bookmark submenu (for Aurora)

Let's get some testing on this so we don't happen to find some bustage late in Aurora cycle. Please NI or qawanted this as soon as it lands so we get eyes on it.
Attachment #8394344 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #6)
> Maybe you could file a bug to add back some of the refactor parts?

Filed bug 987402.
Comment on attachment 8394344 [details] [diff] [review]
Back out bookmark submenu (for Aurora)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 965453
User impact if declined: Bookmark star opens a submenu, which UX decided is not the desired behavior.
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): Low risk; mostly backouts with a few lines rebased.
String or IDL/UUID changes made by this patch: None

Note to any auto-uplifters: Aurora patch is not the same as fx-team patch!
Attachment #8394344 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a593f2a9a80c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Blocks: 987722
Can we get approval on this? We'd like these changes to propagate to Aurora ASAP (see comment 7).
Flags: needinfo?(sledru)
Comment on attachment 8394344 [details] [diff] [review]
Back out bookmark submenu (for Aurora)

Sure. However, please note that Lukas is in charge of aurora. I am currently doing beta.
Attachment #8394344 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(sledru)
Thanks, good to know.

https://hg.mozilla.org/releases/mozilla-aurora/rev/cb32b49bf65a

Marking qawanted to get this verified quickly.
Verified as fixed in builds:
- 30.0a2 (2014-03-31);
- 31.0a1 (2014-03-31);
Device: Asus Transformer (Android 4.2.1) and Acer Iconia (Android 3.2.1)
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.