Closed Bug 984714 Opened 7 years ago Closed 7 years ago

Linux address bar theming from Nightly 30.0a1_2014-03-16 was great, what about keeping it?

Categories

(Firefox :: Theme, defect)

30 Branch
x86_64
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 477948

People

(Reporter: ronan, Unassigned)

Details

Attachments

(1 file)

I was pleasantly surprised by address bar changes in the 2014-03-16 build of Firefox (Australis) 30.0a1. Especially with dark themes (e.g. this one: https://addons.mozilla.org/en-US/firefox/addon/black-15433/ ), Firefox under Linux / GNOME Shell 3.10 looked much better.

See the attachment for a comparison:
* Absence of padding and border makes for a very clean look.
  * Padding just added noise.
  * Plus, the borders, as they are back in 2014-03-17, look weird: they're both square (exterior) and slighted rounded (interior)
* The round back button looked great too!

Sadly, these changes disappeared in 2014-03-17 :-/ . Were these changes intentional or a regression from another change? At any rate, they looked great, didn't feel like a regression, and it would be nice to see them popping back.
Depends on: australis-navbar
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
No longer depends on: australis-navbar
Resolution: --- → DUPLICATE
Duplicate of bug: 477948
Look at bug 477948 for details. In short:

They were intentional but, when the patch was merged, the Talos test system reported performance regressions.

Since the tests in question weren't around when that look was added to Windows and OSX, they don't know if that performance regressions are normal.

Since there are more urgent things to deal with, they backed the changes out until they have time to investigate further.
Thanks Stephan.

Just got build 31.0a1 (2014-03-28), where this fix is back, so far it works and looks great for me and I didn't notice any performance degradation.

Thanks to the team for this fix!
You need to log in before you can comment on or make changes to this bug.