Page load document inspector momentary flash/display

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
11 months ago

People

(Reporter: danemacmillan, Unassigned)

Tracking

({regression})

30 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When loading a page with the Developer Tools open, regardless of tab, the inspector highlighter that shows the dashed lines and padding of a node in the document, will momentarily flash on the page then disappear. Typically, it's the body node, as loading a new page means nothing was really selected.

It's reproducible on OSX Mavericks and Win7. I haven't tested others.
(Reporter)

Comment 1

5 years ago
In addition, if a document has been scrolled and you refresh, the flash will scroll the document back to the top. It's very disruptive if working on a section outside the visible viewport and refreshing regularly.
Confirmed in nightly 31.0a1 (2014-03-20), win 7 x64.

Last good nightly: 2014-03-14
First bad nightly: 2014-03-15

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2014-03-14&enddate=2014-03-15
Blocks: 663778
Status: UNCONFIRMED → NEW
Component: Developer Tools → Developer Tools: Inspector
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 4

5 years ago
Scrolling to an area in the document on refresh does not seem to occur on Windows (7). Unfortunately, I'm working on a Mac all day, and this bug is driving me loco.
(Reporter)

Comment 5

5 years ago
It doesn't scroll on OSX anymore! Quality of life +500. An update over the last few days must have indirectly resolved or inhibited that behaviour. The only problem that remains is the flash on screen of the highlighted node on page refresh.
(Reporter)

Comment 6

5 years ago
Just to note, this was happening on Friday, so the update rolled out over the weekend, or this morning, Tuesday.
(Reporter)

Comment 7

5 years ago
Update:

I've noticed this no longer happens. The fix probably slipped in over the last week or two, though my assumption is that it was resolved indirectly while addressing other areas of the tools, which is appropriate, as the problem was likely introduced in the same way. Also, no one was actually assigned to this task, but it's fixed. I suppose it's probably fine to close, but based on its history, I'd keep it in in case it creeps back.

Comment 8

5 years ago
It still does it.

Load web tools. Refresh page. Nothing flashes.
Go to Inspector page. Refresh page. BODY tag flashes with dotted border and highlighted rectangle covers entire client area.

Close web tools. Open them up again. Problem is gone until Inspector page activated again.


Its very annoying.
(Reporter)

Comment 9

5 years ago
What version are you running? I'm unable to reproduce it. I'm on Nightly 35.0a1 (2014-10-02).

Comment 10

5 years ago
Dane McMillan, version 32.0.3
(Reporter)

Comment 11

5 years ago
Yeah, the current stable build is a full three releases behind the Nightly (experimental preview) build. It has definitely gone away. In 32 I do see the issue. You just have to wait until the build trickles down to the stable release, or get on the Aurora or Nightly builds. If you're a developer and don't mind using a preview build, I recommend Nightly. I've been using it as a primary browser for close to two years and can't remember a single time that this build ever had any bug that prevented me from using it. It's arguably as stable as you'll ever need it to be, especially as a Web developer. In fact, as a Web developer, it's probably recommended, so you can test against future releases and be sure your work is forward-compatible, or to test out the latest additions to CSS and JavaScript. Also, the developer tools are constantly getting updated with notable and welcome additions; for example, you can start using the storage inspector now, or wait several months to get it in the stable build.
For now, let's close this, but please do reopen if it comes back in Nightly.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.