Closed Bug 984962 Opened 6 years ago Closed 6 years ago

Need for an easy app update url and channel switching from Developper menu in settings

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gerard-majax, Assigned: janx)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
vingtetun
: review+
Details | Review
To ease some work, being able to switch those URLs more easily would be awesome. Something like an Advanced Developper menu in Settings, hidden behind a pref or a magic trick would do the job.
Flags: needinfo?(anygregor)
Dogfood users might have to go there and change the channel. We should get some nice UX for this.
Flags: needinfo?(anygregor) → needinfo?(firefoxos-ux-bugzilla)
Flagging Omega for input on Settings.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(ofeng)
Not quite understand the request, so here are some questions:

1. Are we putting something in "Settings > Developer"?
2. How many fields do we need?
3. Are these fields single line text input? Or a value selector with some predefined options?
Flags: needinfo?(ofeng)
(In reply to Omega Feng [:Omega] from comment #3)
> Not quite understand the request, so here are some questions:
> 
> 1. Are we putting something in "Settings > Developer"?

That would be the idea.

> 2. How many fields do we need?

For now, I only see modification of app.update.channel and app.update.url.

> 3. Are these fields single line text input? Or a value selector with some
> predefined options?

I would prefer single input.
Flags: needinfo?(ofeng)
See Bug 995124 for the Developer UX spec update.
Flags: needinfo?(ofeng)
Duplicate of this bug: 841106
Attached file github pull request
Works but needs tests.
Depends on: 995206
Comment on attachment 8405399 [details] [review]
github pull request

Actually I'm not sure if/how to test this. Do unit tests make sense here? How can I also cover the gecko part of this feature in bug #995206?
Attachment #8405399 - Flags: review?(21)
Comment on attachment 8405399 [details] [review]
github pull request

Second try, please have a look.

(Also, please feel free to r- my patches when you want them changed prior to landing. I don't mind, and bugzilla doesn't count resetting the `review` flag as an actual review.)
Attachment #8405399 - Flags: review?(21)
Comment on attachment 8405399 [details] [review]
github pull request

Just make sure that the new pref name does not break updates, but since this pref is read-only it should be fine.
Attachment #8405399 - Flags: review?(21) → review+
See bug 995124 for the updated UX spec.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → janx
Blocks: 1035807
No longer blocks: 1035807
Depends on: 1035807
You need to log in before you can comment on or make changes to this bug.