Closed Bug 984976 Opened 6 years ago Closed 6 years ago

Australis - toolbar button type="menu-button" border behaviour is weird on Windows 8

Categories

(Firefox :: Theme, defect)

31 Branch
All
Windows 8
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: ntim, Assigned: mikedeboer)

References

Details

(Whiteboard: [Australis:P3-])

Attachments

(1 file)

STR :
- Find a toolbar button of type="menu-button" (bookmarks widget, colorzilla,...)
- Click the dropmarker icon
- The border is normal

Issue 1 
-------------------
- Mouse out from that button or from it's menupopup
- See that the split border is missing
- Screenshot : http://images.devs-on.net/Image/u74pkHPLhJ4wrQWx-Region.png

Issue 2
-------------------
- In that menu-button, hover the button that isn't the dropmarker
- See there's a 2px separator
- Screenshot : http://images.devs-on.net/Image/sxzNENpWbd0yt6GJ-Region.png
Blocks: theme-win8
Whiteboard: [Australis:P-]
Whiteboard: [Australis:P-] → [Australis:P?]
I don't have Win8 handy, but this seems like it's likely  to make the button feel wonky. Similar issues on OS X certainly did.
Whiteboard: [Australis:P?] → [Australis:P3-]
I can reproduce
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → mdeboer
Mike, can you address bug 981908 in the same patch? Seems like it's the same or a very similar problem...
See Also: → 981908
(In reply to :Gijs Kruitbosch from comment #3)
> Mike, can you address bug 981908 in the same patch? Seems like it's the same
> or a very similar problem...

I'll try, but it's not a very similar problem. If it manifests for type=menu-button buttons then I'll just go ahead and do it, but we both know that the UI elements for Bookmarks are different beasts, usually :-S
Attachment #8394202 - Flags: review?(gijskruitbosch+bugs)
This patch also fixes bug bug 981908.
Status: NEW → ASSIGNED
Blocks: 981908
Attachment #8394202 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed
remote:   https://hg.mozilla.org/integration/fx-team/rev/0909197d66d9
Keywords: checkin-needed
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0909197d66d9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Duplicate of this bug: 986507
Comment on attachment 8394202 [details] [diff] [review]
Patch v1: fix menu-button border states on Windows 8

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: Menu-button type buttons shift on Windows 8
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, CSS-only fix
String or IDL/UUID changes made by this patch: none
Attachment #8394202 - Flags: approval-mozilla-beta?
Attachment #8394202 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 986929
Attachment #8394202 - Flags: approval-mozilla-beta?
Attachment #8394202 - Flags: approval-mozilla-beta+
Attachment #8394202 - Flags: approval-mozilla-aurora?
Attachment #8394202 - Flags: approval-mozilla-aurora+
Verified this as fixed using the STR from the description on Windows 8 32bit and 64bit architectures using:
- latest Aurora (build ID: 20140324150430)
- latest Nightly (build ID: 20140324030203)
- Firefox 29 beta 2 (build ID: 20140324101726)
You need to log in before you can comment on or make changes to this bug.