Closed Bug 985058 Opened 7 years ago Closed 7 years ago

[Camera] [Mozilla][UX] 1.4 Viewfinder Assets not to spec

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: amylee, Assigned: wilsonpage)

References

Details

(Whiteboard: ux-tracking, visual design, jian [fxos:media])

Attachments

(4 files)

Attached image Viewfinder_Edits.png
Hi

I've reviewed the viewfinder and have attached my edits. Let me know if you have any questions.
Duplicate of this bug: 984621
What about the distance betweeen the gallery and the capture buttons? Still 18px?
Flags: needinfo?(amlee)
Attached image Single_Shutter_Spec.png
Hi Diego, 

The specs are optimized for the Madai camera which is 720px wide (See attached). If I increase the spacing between the camera shutter and the other 2 buttons, the buttons will be too close to the edges of the screen. Please keep the buttons at 18px distance between each other. Thanks.
Flags: needinfo?(amlee)
What about going for a more fluid design? What about aligning the mode switch and the gallery buttons to the front/back rear camera and settings buttons at the top? This would create horizontal balance in the controls since the buttons will make use of the available space and would create symmetry with respect to the buttons at the top.
Flags: needinfo?(amlee)
(In reply to Diego Marcos [:dmarcos] from comment #4)
> What about going for a more fluid design? What about aligning the mode
> switch and the gallery buttons to the front/back rear camera and settings
> buttons at the top? This would create horizontal balance in the controls
> since the buttons will make use of the available space and would create
> symmetry with respect to the buttons at the top.

Hi Diego, 

This was initially considered but the aim is to have the controls together as a unit. Depending on how wide the screen is, the controls may be too wide apart and we lose the feeling of them belonging as one cluster. I want to keep the controls as is for now (with the addition of the edits I've posted) and review them on the actual devices we are shipping the OS on.

Thanks!
Flags: needinfo?(amlee)
Summary: [Camera] [Mozilla] 1.4 Viewfinder Assets not to spec → [Camera] [Mozilla][UX] 1.4 Viewfinder Assets not to spec
There is currently a fade in highlight state when you press on the settings menu button. It should highlight blue right away without a fade in. Can you please change to 0 (see line 1192 in attachment). 

Thanks!
amlee: This bug is about viewfinder. Your last comment relates to settings menu or HUD
Flags: needinfo?(amlee)
amlee: I have implemented the change as part of bug 972137
Flags: needinfo?(amlee)
Assignee: nobody → wilsonpage
Attachment #8395759 - Flags: ui-review?(amlee)
Attachment #8395759 - Flags: review?(dmarcos)
Attachment #8395759 - Flags: ui-review?(amlee) → ui-review+
Attachment #8395759 - Flags: review?(dmarcos) → review+
Landed in camera new features:

https://github.com/mozilla-b2g/gaia/commit/6f04435499ea00f6b0f653863560e7cdf845423d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8395759 [details] [review]
pull-request (camera-new-features)

Sorry, the toggle switch is still 8 rem by 4 rem. it should be 7.6 rem by 3.8 rem
Attachment #8395759 - Flags: ui-review+ → ui-review-
Attachment #8395759 - Flags: ui-review?(tshakespeare)
Amy to confirm if this is still an issue or if it has been resolved since her last update was a review -.
Flags: needinfo?(amlee)
Bulk edit for camera bugs.

If earlier comments do not show how this bug landed to master, it probably landed as part of https://github.com/mozilla-b2g/gaia/pull/17599 which merged the camera-new-features branch into master.

This bug was uplifted from master to v1.4 as part of https://github.com/mozilla-b2g/gaia/commit/a8190d08e61316a86bba572ba8d894d081a20530
Target Milestone: --- → 1.4 S5 (11apr)
(In reply to Tiffanie Shakespeare from comment #12)
> Amy to confirm if this is still an issue or if it has been resolved since
> her last update was a review -.

I loaded the patch https://github.com/mozilla-b2g/gaia/pull/17599 and the toggle switch is still 8 rem by 4 rem. it should be 7.6 rem by 3.8 rem.
Flags: needinfo?(amlee) → needinfo?(wilsonpage)
Amlee: Can you file a follow-up bug?
Flags: needinfo?(wilsonpage)
You need to log in before you can comment on or make changes to this bug.