Intermittent Android 2.3 | application crashed [@ 0x0]

RESOLVED FIXED in Firefox 31

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gbrown, Assigned: jchen)

Tracking

({intermittent-failure})

unspecified
Firefox 31
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 unaffected, firefox30 unaffected, firefox31 fixed, firefox-esr24 unaffected)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
Occasional crashes occur in various Android 2.3 tests. We have not been able to get crash dumps for these due to bug 983417 (now fixed on Ash) and bug 980498. By landing the patch in bug 944612 on Ash, I was able to generate crash reports and they show:

https://tbpl.mozilla.org/php/getParsedLog.php?id=36188590&tree=Ash&full=1#error0

22:33:18     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/ash-android/1394820929/fennec-30.0a1.en-US.android-arm.crashreporter-symbols.zip
22:33:18  WARNING -  PROCESS-CRASH | /tests/dom/network/tests/test_tcpsocket_enabled_with_perm.html | application crashed [@ 0x0]
22:33:18     INFO -  Crash dump filename: /tmp/tmpJqzJsw/5fec6473-d856-9c97-75ce2fef-1cf5a045.dmp
22:33:18     INFO -  Operating system: Android
22:33:18     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
22:33:18     INFO -  CPU: arm
22:33:18     INFO -       0 CPUs
22:33:18     INFO -  
22:33:18     INFO -  Crash reason:  SIGSEGV
22:33:18     INFO -  Crash address: 0x0
22:33:18     INFO -  
22:33:18     INFO -  Thread 11 (crashed)
22:33:18     INFO -   0  0x0
22:33:18     INFO -       r4 = 0x0000001b    r5 = 0x00000001    r6 = 0x4742c750    r7 = 0x4742c6f0
22:33:18     INFO -       r8 = 0x4742c710    r9 = 0x4742c6a0   r10 = 0x00000004    fp = 0x4eb91eec
22:33:18     INFO -       sp = 0x4742c288    lr = 0xafd275fb    pc = 0x00000000
22:33:18     INFO -      Found by: given as instruction pointer in context
22:33:18     INFO -   1  libxul.so!mozilla::ThreadStackHelper::FillStackBuffer() [ThreadStackHelper.cpp:53d894de9425 : 191 + 0x5]
22:33:18     INFO -       sp = 0x4742c2f4    pc = 0x4d5462b9
22:33:18     INFO -      Found by: stack scanning
Reporter

Comment 1

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=36170474&tree=Ash&full=1#error0

16:50:03     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/ash-android/1394820929/fennec-30.0a1.en-US.android-arm.crashreporter-symbols.zip
16:50:03  WARNING -  PROCESS-CRASH | /tests/dom/tests/mochitest/bugs/test_bug458091.html | application crashed [@ 0x0]
16:50:03     INFO -  Crash dump filename: /tmp/tmpBVx3_y/16b60548-3dd1-e0c0-3c4c982e-7f0e29e1.dmp
16:50:03     INFO -  Operating system: Android
16:50:03     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
16:50:03     INFO -  CPU: arm
16:50:03     INFO -       0 CPUs
16:50:03     INFO -  
16:50:03     INFO -  Crash reason:  SIGSEGV
16:50:03     INFO -  Crash address: 0x0
16:50:03     INFO -  
16:50:03     INFO -  Thread 11 (crashed)
16:50:03     INFO -   0  0x0
16:50:03     INFO -       r4 = 0x0000001b    r5 = 0x00000000    r6 = 0x44155598    r7 = 0x559498c0
16:50:03     INFO -       r8 = 0x50defe20    r9 = 0x54b468e0   r10 = 0x00000002    fp = 0x44155938
16:50:03     INFO -       sp = 0x441551a0    lr = 0xafd275fb    pc = 0x00000000
16:50:03     INFO -      Found by: given as instruction pointer in context
16:50:03     INFO -   1  libxul.so!mozilla::ThreadStackHelper::FillStackBuffer() [ThreadStackHelper.cpp:53d894de9425 : 191 + 0x5]
16:50:03     INFO -       sp = 0x4415520c    pc = 0x4a32b2b9
16:50:03     INFO -      Found by: stack scanning
Reporter

Comment 2

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=36170546&tree=Ash&full=1#error0

16:51:27     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/ash-android/1394820929/fennec-30.0a1.en-US.android-arm.crashreporter-symbols.zip
16:51:27  WARNING -  PROCESS-CRASH | testOverscroll | application crashed [@ 0x0]
16:51:27     INFO -  Crash dump filename: /tmp/tmpq2PpGr/7a8cb396-8907-6abe-15958d54-0266af0f.dmp
16:51:27     INFO -  Operating system: Android
16:51:27     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
16:51:27     INFO -  CPU: arm
16:51:27     INFO -       0 CPUs
16:51:27     INFO -  
16:51:27     INFO -  Crash reason:  SIGSEGV
16:51:27     INFO -  Crash address: 0x0
16:51:27     INFO -  
16:51:27     INFO -  Thread 12 (crashed)
16:51:27     INFO -   0  0x0
16:51:27     INFO -       r4 = 0x0000001b    r5 = 0x00000001    r6 = 0x47d23608    r7 = 0x47d235a8
16:51:27     INFO -       r8 = 0x47d235c8    r9 = 0x47d23558   r10 = 0x00000003    fp = 0x4ed03eec
16:51:27     INFO -       sp = 0x47d23140    lr = 0xafd275fb    pc = 0x00000000
16:51:27     INFO -      Found by: given as instruction pointer in context
16:51:27     INFO -   1  libxul.so!mozilla::ThreadStackHelper::FillStackBuffer() [ThreadStackHelper.cpp:53d894de9425 : 191 + 0x5]
16:51:27     INFO -       sp = 0x47d231ac    pc = 0x4d6b82b9
16:51:27     INFO -      Found by: stack scanning
Reporter

Comment 3

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=36516721&tree=Ash&full=1#error0

12:32:34     INFO -  TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/security/manager/ssl/tests/unit/test_ocsp_stapling.js | running test ...
12:32:34     INFO -  TEST-KNOWN-FAIL | /builds/slave/test/build/tests/xpcshell/tests/security/manager/ssl/tests/unit/test_ocsp_stapling.js | test passed (time: 5036.452ms)
12:32:34     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/ash-android/1395414906/fennec-31.0a1.en-US.android-arm.crashreporter-symbols.zip
12:32:34  WARNING -  PROCESS-CRASH | /builds/slave/test/build/tests/xpcshell/tests/security/manager/ssl/tests/unit/test_ocsp_stapling.js | application crashed [@ 0x0]
12:32:34     INFO -  Crash dump filename: /tmp/tmpualOHU/3e06e4e9-371f-d37d-31c4f988-44e024fb.dmp
12:32:34     INFO -  Operating system: Android
12:32:34     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
12:32:34     INFO -  CPU: arm
12:32:34     INFO -       0 CPUs
12:32:34     INFO -  
12:32:34     INFO -  Crash reason:  SIGSEGV
12:32:34     INFO -  Crash address: 0x0
12:32:34     INFO -  
12:32:34     INFO -  Thread 0 (crashed)
12:32:34     INFO -   0  0x0
12:32:34     INFO -       r4 = 0x0000001b    r5 = 0x402a8c10    r6 = 0x00000045    r7 = 0x000003e0
12:32:34     INFO -       r8 = 0x42338100    r9 = 0x3e09187c   r10 = 0x3e09187d    fp = 0x00000000
12:32:34     INFO -       sp = 0xbeeabcc8    lr = 0xafd275fb    pc = 0x00000000
12:32:34     INFO -      Found by: given as instruction pointer in context
12:32:34     INFO -   1  libxul.so!mozilla::ThreadStackHelper::FillStackBuffer() [ThreadStackHelper.cpp:8764c14ce829 : 191 + 0x5]
12:32:34     INFO -       sp = 0xbeeabd34    pc = 0x822d3479
12:32:34     INFO -      Found by: stack scanning
12:32:34     INFO -  
12:32:34     INFO -  Thread 1
12:32:34     INFO -   0  libc.so + 0xc51c
12:32:34     INFO -       r4 = 0x40243180    r5 = 0x40204470    r6 = 0x00000000    r7 = 0x000000fc
12:32:34     INFO -       r8 = 0x83949ee8    r9 = 0xffffffff   r10 = 0x40204470    fp = 0x00000001
12:32:34     INFO -       sp = 0x100ffd10    lr = 0x823e63f5    pc = 0xafd0c51c
12:32:34     INFO -      Found by: given as instruction pointer in context
12:32:34     INFO -   1  libxul.so!event_base_loop [event.c:8764c14ce829 : 1607 + 0x5]
12:32:34     INFO -       sp = 0x100ffd38    pc = 0x823e403d
12:32:34     INFO -      Found by: stack scanning
12:32:34     INFO -   2  libxul.so!base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) [message_pump_libevent.cc:8764c14ce829 : 340 + 0x7]
12:32:34     INFO -       r4 = 0x00000000    r5 = 0x100ffdf8    r6 = 0x402018e0    r7 = 0x100ffdf8
12:32:34     INFO -       r8 = 0x00000000    r9 = 0x402231c0   r10 = 0x00100000    fp = 0x00000001
12:32:34     INFO -       sp = 0x100ffda0    pc = 0x823e6951
12:32:34     INFO -      Found by: call frame info
12:32:34     INFO -   3  libxul.so!MessageLoop::RunInternal() [message_loop.cc:8764c14ce829 : 226 + 0x5]
12:32:34     INFO -       r4 = 0x100ffdf8    r5 = 0x100ffdf8    r6 = 0x402231c0    r7 = 0x00000078
12:32:34     INFO -       r8 = 0x823e6c91    r9 = 0x402231c0   r10 = 0x00100000    fp = 0x00000001
12:32:34     INFO -       sp = 0x100ffdd0    pc = 0x823eb443
12:32:34     INFO -      Found by: call frame info
This might fix it. Not sure why we would have a null pseudostack here, though.
Reporter

Comment 5

5 years ago
I still get a crash with that patch applied --

https://tbpl.mozilla.org/php/getParsedLog.php?id=36765221&tree=Ash&full=1

15:45:10  WARNING -  PROCESS-CRASH | http://10.0.2.2:8854/jsreftest/tests/jsreftest.html?test=test262/ch11/11.9/11.9.1/S11.9.1_A7.8.js | application crashed [@ 0x0]
15:45:10     INFO -  Crash dump filename: /tmp/tmpFZDBgg/1696ab65-fafb-4d2b-13f8a1d2-1031447c.dmp
15:45:10     INFO -  Operating system: Android
15:45:10     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
15:45:10     INFO -  CPU: arm
15:45:10     INFO -       0 CPUs
15:45:10     INFO -  
15:45:10     INFO -  Crash reason:  SIGSEGV
15:45:10     INFO -  Crash address: 0x0
15:45:10     INFO -  
15:45:10     INFO -  Thread 11 (crashed)
15:45:10     INFO -   0  0x0
15:45:10     INFO -       r4 = 0x0000001b    r5 = 0x5a5fbe88    r6 = 0x00000000    r7 = 0x00000000
15:45:10     INFO -       r8 = 0x4725de78    r9 = 0x55861480   r10 = 0x00000000    fp = 0x5a98ab38
15:45:10     INFO -       sp = 0x4725da80    lr = 0xafd275fb    pc = 0x00000000
15:45:10     INFO -      Found by: given as instruction pointer in context
15:45:10     INFO -   1  libxul.so!mozilla::ThreadStackHelper::FillStackBuffer() [ThreadStackHelper.cpp:afa4760254d1 : 195 + 0x7]
15:45:10     INFO -       sp = 0x4725daec    pc = 0x4d78a641
15:45:10     INFO -      Found by: stack scanning
15:45:10     INFO -
Reporter

Updated

5 years ago
Summary: Intermittent crashes during Android 2.3 tests in mozilla::ThreadStackHelper::FillStackBuffer() → Intermittent Android 2.3 | application crashed [@ 0x0]
The reason this isn't suggested by TBPL is that the top frame isn't > 4 characters, per:
https://hg.mozilla.org/webtools/tbpl/file/0ff154c63807/php/inc/AnnotatedSummaryGenerator.php#l162

It probably goes without saying, but having a non 0x0 top frame would be really helpful here, even if we can't fix the crash itself for a bit.
(In reply to Phil Ringnalda (:philor) from comment #29)
> Anybody see any reason why these should remain visible?

Hidden in bug 967704 comment 46
Reporter

Comment 43

5 years ago
I happened upon: https://tbpl.mozilla.org/php/getParsedLog.php?id=37557500&full=1&branch=mozilla-inbound#error1

which seems to be the same crash signature, but in an xpcshell test. fwiw, this xpcshell test is a long-running test that sometimes times out.
The finding from deep dive was that FillStackBuffer() was a bogus stack frame, and the actual crash happened after sem_post() was called by ThreadStackHelper::SigAction() signal handler. The last discernible call was sem_post() calling __futex_wake_ex() [1] but somehow we end up at pc = 0x0.

[1] http://androidxref.com/2.3.7/xref/bionic/libc/bionic/semaphore.c#350
Would love an update here, since this has resulted in tests being hidden in trunk.
(In reply to Mark Côté ( :mcote ) from comment #46)
> Would love an update here, since this has resulted in tests being hidden in
> trunk.

Still looking but not many leads. I have a loaner VM from IT that I'm trying to reproduce this in.
Reporter

Comment 48

5 years ago
I notice the stack traces for recent crashes are different now -- FillStackBuffer is gone. Did we change something?

https://tbpl.mozilla.org/php/getParsedLog.php?id=38167485&tree=Mozilla-Inbound&full=1

13:06:10     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1398019707/fennec-31.0a1.en-US.android-arm.crashreporter-symbols.zip
13:06:10  WARNING -  PROCESS-CRASH | /tests/dom/datastore/tests/test_oop.html | application crashed [@ 0x0]
13:06:10     INFO -  Crash dump filename: /tmp/tmpfuWMS9/431f9692-0989-614e-23965bda-39497554.dmp
13:06:10     INFO -  Operating system: Android
13:06:10     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
13:06:10     INFO -  CPU: arm
13:06:10     INFO -       0 CPUs
13:06:10     INFO -  
13:06:10     INFO -  Crash reason:  SIGSEGV
13:06:10     INFO -  Crash address: 0x0
13:06:10     INFO -  
13:06:10     INFO -  Thread 11 (crashed)
13:06:10     INFO -   0  0x0
13:06:10     INFO -       r4 = 0x0000001b    r5 = 0x46eaa950    r6 = 0x00000000    r7 = 0xe08ea648
13:06:10     INFO -       r8 = 0x000001c1    r9 = 0x4d6bb6c7   r10 = 0x4e882cc8    fp = 0x00000001
13:06:10     INFO -       sp = 0x47c2de48    lr = 0xafd275fb    pc = 0x00000000
13:06:10     INFO -      Found by: given as instruction pointer in context
13:06:10     INFO -   1  libxul.so + 0x2d9a6b
13:06:10     INFO -       sp = 0x47c2deb4    pc = 0x4d6cfa6d
13:06:10     INFO -      Found by: stack scanning
13:06:10     INFO -   2  libxul.so!nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser_internal::INIValue> > >::s_MatchEntry(PLDHashTable*, PLDHashEntryHdr const*, void const*) [nsTHashtable.h:9dde6cd3739b : 428 + 0x9]
13:06:10     INFO -       sp = 0x47c2df08    pc = 0x4d6bb6c7
13:06:10     INFO -      Found by: stack scanning
13:06:10     INFO -   3  0xffffffff
13:06:10     INFO -       sp = 0x47c2df10    pc = 0x00000001
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -   4  libxul.so!PL_DHashTableOperate(PLDHashTable*, void const*, PLDHashOperator) [pldhash.cpp:9dde6cd3739b : 563 + 0xb]
13:06:10     INFO -       sp = 0x47c2df1c    pc = 0x4d6a46d7
13:06:10     INFO -      Found by: stack scanning
13:06:10     INFO -   5  0x47c2e17e
13:06:10     INFO -       r4 = 0x4d6a298a    r5 = 0x60000830    r6 = 0x45de3000    r7 = 0x00001204
13:06:10     INFO -       r8 = 0x00000000    sp = 0x47c2df34    pc = 0x47c2e180
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -   6  libxul.so!nsACString_internal::Assign(nsACString_internal const&) [nsTSubstring.cpp:9dde6cd3739b : 367 + 0x3]
13:06:10     INFO -       sp = 0x47c2df48    pc = 0x4d6abc3b
13:06:10     INFO -      Found by: stack scanning
13:06:10     INFO -   7  libxul.so!mozilla::dom::indexedDB::Key::operator=(mozilla::dom::indexedDB::Key const&) [nsTString.h:9dde6cd3739b : 74 + 0x3]
13:06:10     INFO -       r4 = 0x47c2e180    sp = 0x47c2df58    pc = 0x4d6d5637
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -   8  libxul.so!mozilla::ipc::StandardURLParams::Assign(unsigned int const&, int const&, int const&, nsCString const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, mozilla::ipc::StandardURLSegment const&, nsCString const&, bool const&, bool const&, unsigned int const&) [URIParams.cpp:9dde6cd3739b : 221 + 0x3]
13:06:10     INFO -       r4 = 0x47c2e108    sp = 0x47c2df60    pc = 0x4d88af85
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -   9  libxul.so!mozilla::ipc::StandardURLParams::operator=(mozilla::ipc::StandardURLParams const&) [URIParams.h:9dde6cd3739b : 255 + 0x6f]
13:06:10     INFO -       r4 = 0x47c2e108    r5 = 0x47c2dffc    r6 = 0x4ed56eec    r7 = 0x5413fb44
13:06:10     INFO -       r8 = 0x47c2e108    r9 = 0x00000000   r10 = 0x55ce70c0    fp = 0x4ede2dbc
13:06:10     INFO -       sp = 0x47c2df90    pc = 0x4d88b015
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  10  0x46e01fd2
13:06:10     INFO -       r4 = 0x47c2e108    r5 = 0x47c2dffc    r6 = 0x4ed56eec    r7 = 0x5413fb44
13:06:10     INFO -       r8 = 0x47c2e108    r9 = 0x00000000   r10 = 0x55ce70c0    fp = 0x4ede2dbc
13:06:10     INFO -       sp = 0x47c2dfe0    pc = 0x46e01fd4
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  11  libxul.so!base::subtle::RefCountedThreadSafeBase::Release() [atomic_ref_count.h:9dde6cd3739b : 29 + 0x7]
13:06:10     INFO -       sp = 0x47c2dff0    pc = 0x4d7efc35
13:06:10     INFO -      Found by: stack scanning
13:06:10     INFO -  12  libxul.so!base::RefCountedThreadSafe<base::MessagePump>::Release() [ref_counted.h:9dde6cd3739b : 106 + 0x3]
13:06:10     INFO -       sp = 0x47c2dff8    pc = 0x4d7ec6fb
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  13  libxul.so!scoped_refptr<base::MessagePump>::~scoped_refptr() [ref_counted.h:9dde6cd3739b : 196 + 0x5]
13:06:10     INFO -       r4 = 0x47c2e010    sp = 0x47c2e000    pc = 0x4d7ec719
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  14  libxul.so!MessageLoop::PostTask_Helper(tracked_objects::Location const&, Task*, int, bool) [message_loop.cc:9dde6cd3739b : 315 + 0xb]
13:06:10     INFO -       r4 = 0x50ff8df8    sp = 0x47c2e008    pc = 0x4d7edb7f
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  15  libmozglue.so!arena_dalloc [jemalloc.c:9dde6cd3739b : 4455 + 0x5]
13:06:10     INFO -       r4 = 0x46cfd044    r5 = 0x53e67000    r6 = 0x000004c0    sp = 0x47c2e040
13:06:10     INFO -       pc = 0x8031a047
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  16  0x46cfd042
13:06:10     INFO -       r4 = 0x53e97080    r5 = 0x53e97094    r6 = 0x00000000    r7 = 0x00000000
13:06:10     INFO -       r8 = 0x4d817901    r9 = 0x4d7f8daf   r10 = 0x5837b830    sp = 0x47c2e060
13:06:10     INFO -       pc = 0x46cfd044
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  17  libxul.so!mozilla::ipc::MessageChannel::CxxStackFrame::~CxxStackFrame() [MessageChannel.cpp:9dde6cd3739b : 178 + 0x5]
13:06:10     INFO -       sp = 0x47c2e070    pc = 0x4d7f8e2d
13:06:10     INFO -      Found by: stack scanning
13:06:10     INFO -  18  libxul.so!mozilla::ipc::MessageChannel::Send(IPC::Message*) [MessageChannel.cpp:9dde6cd3739b : 417 + 0x11]
13:06:10     INFO -       r4 = 0x00000001    r5 = 0x53e97980    r6 = 0x001a0024    sp = 0x47c2e080
13:06:10     INFO -       pc = 0x4d7f8e9f
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  19  libxul.so!mozilla::dom::PContentParent::SendLoadAndRegisterSheet(mozilla::ipc::URIParams const&, unsigned int const&) [PContentParent.cpp:9dde6cd3739b : 1273 + 0x9]
13:06:10     INFO -       r4 = 0x53e97980    r5 = 0x5837b800    r6 = 0x001a0024    sp = 0x47c2e0a0
13:06:10     INFO -       pc = 0x4d81efcb
13:06:10     INFO -      Found by: call frame info
13:06:10     INFO -  20  libxul.so!mozilla::dom::ContentParent::InitInternal(mozilla::hal::ProcessPriority, bool, bool) [ContentParent.cpp:9dde6cd3739b : 1628 + 0x5]
13:06:10     INFO -       r4 = 0x4d88b179    r5 = 0x47c2e108    r6 = 0x00000000    r7 = 0x47c2e108
13:06:10     INFO -       r8 = 0x4d88b121    r9 = 0x5837b800    sp = 0x47c2e0d8    pc = 0x4dc04b3d
13:06:10     INFO -      Found by: call frame info
Pretty sure the crash is due to a kernel bug in some older kernels where signal handler calls are hit or miss. We actually ran into the same problem in B2G not long ago in bug 919901.

This patch provides a workaround for the bug and seems to fix the crash, https://tbpl.mozilla.org/?tree=Try&rev=6fd90376d723&showall=1
Attachment #8409733 - Flags: review?(snorp)
Comment on attachment 8409733 [details] [diff] [review]
Add signal trampoline on ARM Linux to work around kernel bug (v1)

Review of attachment 8409733 [details] [diff] [review]:
-----------------------------------------------------------------

Wow.
Attachment #8409733 - Flags: review?(snorp) → review+
The patch gives a workaround, but it's still best if we upgrade the kernel in the 2.3 images (bug 998431)
Depends on: 998431
Taking.
Assignee: snorp → nchen
Status: NEW → ASSIGNED
Keywords: checkin-needed
OS: Linux → Android
Hardware: x86_64 → ARM
Attachment #8409733 - Flags: checkin?
Attachment #8409733 - Flags: checkin? → checkin+
https://hg.mozilla.org/mozilla-central/rev/f0c86af8d0b1
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Can these tests now be unhidden in TBPL?
(In reply to Jonathan Griffin (:jgriffin) from comment #55)
> Can these tests now be unhidden in TBPL?

Yup.
Done, and whee, they're no longer my exclusive responsibility!
Backed out bug 980074 for the last 3 crashes.
You need to log in before you can comment on or make changes to this bug.