Non-ascii filters are not diffirentiated from ascii filters if more than one criteria

VERIFIED WORKSFORME

Status

MailNews Core
Internationalization
P3
normal
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: marina, Assigned: nhottanscp)

Tracking

({intl})

Trunk
mozilla0.9.7
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
**** observed with 2001-09-06 build ****
Steps to reproduce:
- open mail;
- go Edit|Message filters;
- create an ascii filter with following criteria: Name "filter", subject
contains "filter", priority "high" , move to "Trash";
- create a non-ascii filter with the following criterias: Name "f+
Alt+0+252"lter" ( the first char could also be c,d.etc), subject contains
"s+Alt+0 +252bject", priority "high", move to folder ( any folder, ascii,
non-ascii doesn't matter);
- send 2  mails with the above criterias;
//note the result: both mails ended up in Trash
NB: if there is only one criteria for the filter than it is working correctly
(Reporter)

Comment 1

17 years ago
changing qa contact
Keywords: intl
QA Contact: ji → marina

Comment 2

17 years ago
== assigning Mail bugs to ftang until nhotta comes back
Assignee: yokoyama → ftang
(Reporter)

Comment 3

17 years ago
and one more condition to be met: the non-ascii filter should follow the ascii
one. You can test it by moving ascii filter to the top and non-ascii filter down
, after the ascii one. If the first (ascii) filter has a condition to move all
messages that meet certain criteria to Trash then the non-ascii filter will do
just the same despite that its condition was to move messages to say "Travel".
That's a very annoying bug, i found a lot of important messages deleted (moved
to Trash...)

Comment 4

17 years ago
move to nhotta. It seems our filter code treat non ASCII char not as expected.
Assignee: ftang → nhotta
(Assignee)

Comment 5

17 years ago
Is this about non ASCII filter name or filter criteraia in non ASCII?
Marina, could you attach a screen shot of "Filter Rules" dialog?
Status: NEW → ASSIGNED
(Reporter)

Comment 6

17 years ago
Naoki,
this is non-ascii filter that follows the ascii filter, i do have a non-ascii
criteria as well but the key here is to have more than one criteria, for example
"priority", as soon as the second criteria is added and the non-ascii filter is
beneath the ascii filter it is behaving as the ascii filter. If the condition of
the ascii filter is to throw messages to Trash then the non-ascii one will do
just the same. "Filter rules" and the first screen of the filter window to follow
(Reporter)

Comment 7

17 years ago
Created attachment 52074 [details]
here is a screen shot of the first window that shows all filters i have
(Reporter)

Comment 8

17 years ago
Created attachment 52076 [details]
here is a screen shot of the first(ascii ) "Filter Rules" dlgbox
(Reporter)

Comment 9

17 years ago
Created attachment 52077 [details]
here is a screen shot of the non-ascii "Filter Rules" dlgbox
(Assignee)

Comment 10

17 years ago
If you change the filter name from "büg" to "bug", then a mail with subject
contains "büg" and priority high message won't go to the trash?
(Assignee)

Updated

17 years ago
Priority: -- → P3
(Assignee)

Comment 11

17 years ago
I cannot reproduce, created the two filters as the screen shots, tested on 
Windows 2000 US with 0.9.4 branch build 10/05.
Subject with 'büg' did not move to trach but moved to the folder which I 
specified in the filter.
Any other condition I have to set?
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 12

17 years ago
This works for me.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

17 years ago
verified as wfm
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.