Closed Bug 985475 Opened 6 years ago Closed 4 years ago

[User Story] Mechanism to Change Homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P2)

All
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog)

RESOLVED FIXED
tracking-b2g backlog

People

(Reporter: pdol, Assigned: gmarty)

References

Details

(Keywords: feature, Whiteboard: [ucid:System170, ft:systemsfe, 2.1])

User Story

As a user, I want to be able to change my homescreen to an alternate one if more than one homescreen is available on my device so that I can pick a homescreen suited to me.

Acceptance Criteria:
1. I can see a list of available homescreens to choose from.
2. I am made aware which homescreen is currently in use.
3. I can choose a different homescreen than the one currently being used and the homescreen is updated to reflect my selection.
4. I switch from homescreen A to homescreen B.  I move apps within the B grid.  I return to homescreen A.  The position of apps within the homescreen A layout remains unchanged from the original position (ie. changes to B layout have no effect on A)
5. I switch from homescreen A to homescreen B.  I delete an app within B.  I return to homescreen A.  The app deleted in B is no longer available in A.
6. Home apps do not display within the task manager.
7. Mechanism to change homescreens matches UX spec.

Note: A mechanism already exists for this.  This bug is to clean up that implementation and bring it in line with a UX spec, to follow.

Attachments

(1 file, 1 obsolete file)

No description provided.
User Story: (updated)
Lets add Evelyn and Tim here since this lives in the settings app.
User Story: (updated)
User Story: (updated)
User Story: (updated)
No longer blocks: vertical-homescreen
Blocks: 980768
No longer blocks: 980768
blocking-b2g: --- → backlog
Whiteboard: [ucid:System170], [ft:systemsfe] → [ucid:System170, ft:systemsfe, 2.0]
feature-b2g: --- → 2.0
Flags: in-moztrap?(jlorenzo)
Priority: -- → P3
Duplicate of this bug: 1015492
Attached file Homepage_Settings_May28.pdf (obsolete) —
Adding settings screen for changing the homescreen. 
Let me know if there are any other questions around this.
Target Milestone: --- → 2.0 S3 (6june)
Updating spec to the most recent version of the settings screen.
Attachment #8430222 - Attachment is obsolete: true
feature-b2g: 2.0 → 2.1
Target Milestone: 2.0 S3 (6june) → ---
Whiteboard: [ucid:System170, ft:systemsfe, 2.0] → [ucid:System170, ft:systemsfe, 2.1]
This feature is no more in 2.0. When it's back, I'll in-moztrap? me again.
Flags: in-moztrap?(jlorenzo) → in-moztrap-
Flags: in-moztrap-
feature-b2g: 2.1 → ---
Priority: P3 → P2
blocking-b2g: backlog → ---
Assignee: nobody → gmarty
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → All
This user story is now fully implemented.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.