Edit Bookmark panel button doesn't have an open state

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: shorlander, Assigned: jaws)

Tracking

Trunk
Firefox 31
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 wontfix, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [Australis:P4+])

Attachments

(2 attachments, 2 obsolete attachments)

When you have the Edit Bookmark panel open there is no open state on the button.

Updated

5 years ago
Duplicate of this bug: 985674

Updated

5 years ago
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Posted patch Patch (obsolete) — Splinter Review
Mike, what do you think about this?
Attachment #8395083 - Flags: review?(mconley)
Comment on attachment 8395083 [details] [diff] [review]
Patch

I think the idea is fine, but I think we're probably going to want the same thing for OS X and Linux. :D
Attachment #8395083 - Flags: review?(mconley) → review-
Posted patch WIP Patch (obsolete) — Splinter Review
Attachment #8395083 - Attachment is obsolete: true
Posted patch Patch v2Splinter Review
Tested on OSX, Linux, and Windows.
Attachment #8407697 - Attachment is obsolete: true
Attachment #8407724 - Flags: review?(mconley)
Comment on attachment 8407724 [details] [diff] [review]
Patch v2

Review of attachment 8407724 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome - thanks Jared!
Attachment #8407724 - Flags: review?(mconley) → review+
https://hg.mozilla.org/integration/fx-team/rev/b3ea0d746ee4
OS: Mac OS X → All
Whiteboard: [Australis:P4+] → [Australis:P4+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b3ea0d746ee4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [Australis:P4+][fixed-in-fx-team] → [Australis:P4+]
Target Milestone: --- → Firefox 31
Comment on attachment 8407724 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug introduced with Australis when the bookmarks button was separated out of the location bar
User impact if declined: when the Edit Bookmarks panel is open, the originating button wont look pressed-in.
Testing completed (on m-c, etc.): locally, and now on m-c
Risk to taking this patch (and alternatives if risky): none expected
String or IDL/UUID changes made by this patch: none
Attachment #8407724 - Flags: approval-mozilla-aurora?
Attachment #8407724 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I will hold off on uplifting this until we have a proper fix for bug 998687.

Comment 11

5 years ago
Comment on attachment 8407724 [details] [diff] [review]
Patch v2

NOTE : The approval flag was asked for Aurora 30 but one cycle passed by, and now the patch is on Aurora. So let's ask for Beta 30 approval now.

*****
[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug introduced with Australis when the bookmarks button was separated out of the location bar
User impact if declined: when the Edit Bookmarks panel is open, the originating button wont look pressed-in.
Testing completed (on m-c, etc.): locally, and now on m-c
Risk to taking this patch (and alternatives if risky): none expected
String or IDL/UUID changes made by this patch: none
Attachment #8407724 - Flags: approval-mozilla-beta?
Attachment #8407724 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 12

5 years ago
This needs to be checked in along with bug 998687
Keywords: checkin-needed
I was able to confirm the fix for this issue on Firefox 30 Beta 6 build2 (Build ID: 20140520115057) and Aurora 31.0a2 (2014-05-20), using:
  * Windows 7 64-bit [1], 
  * Windows 8.1 32-bit [2],
  * Mac OS X 10.9.2 [3],
  * Ubuntu 12.04 32-bit [4]. 

[1] Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
[2] Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0
[3] Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
[4] Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.