Closed Bug 985578 Opened 7 years ago Closed 7 years ago

[Camera] [Madai] [Mozilla][UX] Self-Timer not to spec

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: amylee, Assigned: wilsonpage)

References

Details

(Whiteboard: ux-tracking, visual design, jian [fxos:media] [m+])

Attachments

(7 files)

The Self-Timer animation is not to spec. I've attached the animation and the spec to this bug. 

Circle Background Animation:
Circle fades in and starts at 110% scale and then scales to 100% 
(See self-timer.mov).

Text Animation:
Text appears at 160% scale and then scales to 100%. Text opacity starts at 100% and fades to 0% (See self-timer.mov).

Confirmation Text:
When self-timer is selected from the settings menu, the self-timer text remains on the screen except during self-timer countdown. Self-timer message reappears after image is captured (See self-timer.mov).

Timer Font: Fira Sans Light (Currently looks like Fira Sans Regular)

Image Capture Button:
Image capture button should stay in highlighted pressed state (blue circle), until the photo is captured 

On image capture, the image transparency should drop to 20%
Attached video Self-Timer.mov
self-timer is hyphenated

- toggling the self-timer options, the confirmation text when menu closes is missing 
- according to the spec, "The camera sounds a quick beep when the self-timer hits exactly three, two and one seconds." I'm not hearing a beep, but I do hear the shutter noise
- it also seems like there is a delay between the counter hitting zero and the photo being taken?

So as far as reseting the self-timer to off, this is the behaviour I noticed. 

When turning the self-timer on, exiting the app and coming back after about 30min, the self-timer was still on.

When I left the phone overnight and tried tapping on the camera app, it seemed like it was launching it again and the self-timer was off.

According to the spec, "the self-timer setting resets to off after the Camera is not in the foreground for 30 minutes or more."
amlee:

- Should the capture transition (20% opacity) be the same when photos without a timer? We currently don't have any visual feedback of this kind. Would be nice.
- This is the lightest font-weight I could get. Not sure what we can do about that. Still haven't found anyone who knows much about using fonts in Gaia.
- Animation was not implemented due to time constraints. Does this block 1.4?

tiffanie:

- Beep has since landed on camera-new-features
- Timer text rotation has since landed on camera-new-features
- I can't open these kind of box.com links. I think they need to be fully open.
Flags: needinfo?(tshakespeare)
Flags: needinfo?(amlee)
The animation doesn't block 1.4
(In reply to Wilson Page [:wilsonpage] from comment #4)
> amlee:
> 
> - Should the capture transition (20% opacity) be the same when photos
> without a timer? We currently don't have any visual feedback of this kind.
> Would be nice.
> - This is the lightest font-weight I could get. Not sure what we can do
> about that. Still haven't found anyone who knows much about using fonts in
> Gaia.
> - Animation was not implemented due to time constraints. Does this block 1.4?
> 
> tiffanie:
> 
> - Beep has since landed on camera-new-features
> - Timer text rotation has since landed on camera-new-features
> - I can't open these kind of box.com links. I think they need to be fully
> open.

Hi Wilson, 

Yes please also include the capture transition (20% opacity) for photo capture not on timer. Thanks for bringing that up. 

I think it's important that we investigate how we can actually implement the different font weights for Fira Sans since this affects the entire OS. Also, we are expecting to have even more font weight varieties in the future.

Diego just answered that blocking question. If we can still please include this into our schedule somewhere to be implemented at some point that would be great.

Thanks!
Flags: needinfo?(amlee)
(In reply to Wilson Page [:wilsonpage] from comment #4)
> amlee:
> 
> - Should the capture transition (20% opacity) be the same when photos
> without a timer? We currently don't have any visual feedback of this kind.
> Would be nice.
> - This is the lightest font-weight I could get. Not sure what we can do
> about that. Still haven't found anyone who knows much about using fonts in
> Gaia.
> - Animation was not implemented due to time constraints. Does this block 1.4?
> 
> tiffanie:
> 
> - Beep has since landed on camera-new-features
> - Timer text rotation has since landed on camera-new-features
> - I can't open these kind of box.com links. I think they need to be fully
> open.

Looks like Amy has added it to the attachments.

I just updated with the new features branch and I'm not hearing a beep and icon is still jumping instead of rotating. I'm not sure what you mean Wilson but the "timer text rotation", I don't see text when I toggle the timer.
Flags: needinfo?(tshakespeare)
Flags: needinfo?(wilsonpage)
Attached image icon-orientation.png
I couldn't get the icon into that upside-down state.
Attachment #8394455 - Flags: feedback?(tshakespeare)
Depends on: 986217
Spoke with Wilson just now on IRC about the issue with the icon and rotating the phone. He understands what the issue is now.
Summary: [Camera] [Madai] [Mozilla] Self-Timer not to spec → [Camera] [Madai] [Mozilla][UX] Self-Timer not to spec
The change is in the attached pull-request open to cover all these issues.
Flags: needinfo?(wilsonpage)
Assignee: nobody → wilsonpage
Comment on attachment 8394455 [details]
icon-orientation.png

Yay! Icon stays in place on rotation!

Wasn't able to see the other outstanding changes - were they supposed to be in this patch?

- self-timer hyphenated
- confirmation text when toggling self-timer options
- beep when the countdown turns red
Flags: needinfo?(wilsonpage)
Hi, 

I've noticed a few outstanding items as well. Should we be reviewing all the items in this patch?
Flags: needinfo?(wilsonpage)
(In reply to Amy from comment #14)
> Hi, 
> 
> I've noticed a few outstanding items as well. Should we be reviewing all the
> items in this patch?

- The on-pressed state (full blue highlight on shutter button) should remain until the image is captured.
- The opacity of red circle in the final 3 second count-down should transition from 12% - 70% opacity.
- On start of count-down, the grey circle should appear at 110% scale and quickly shrink to 100%.
- There should be the 20% fade out of the image when the photo is captured.

Thanks
tiffanie:

- Just pushed hyphenation (don't sure where this got lost)
- Confirmation text is part of another notification related bug that is expected to land soon.
- The beep is currently using the same sound effect as the video record. This is toggled off by default in Gaia sounds settings. I see these options:
  a. Self timer always beeps no matter what
  b. Self-timer sound is tied directly to the record sound effect (current case, seems strange though)
  c. Self timer beep respects phone's global volume level and is not togglable like picture/record sound effects from Gaia settings app.
  d. We add another toggle option in Gaia settings app for 'self-timer' (could involve work from other app devs)
Flags: needinfo?(wilsonpage)
amlee:

- Is this always the case for picture capture, or just self-timer? IE. When focusing/capturing the button should be blue until we hear the shutter sound.
- Agreed red circle transitions need addressing, I was unsure as to the desired behaviour.
- I couldn't see this transition in the video spec. Over what time-period should this transition occur?
- Capture effect has been addressed as part of a separate issue.
Flags: needinfo?(tshakespeare)
Flags: needinfo?(amlee)
(In reply to Wilson Page [:wilsonpage] from comment #17)
> amlee:
> 
> - Is this always the case for picture capture, or just self-timer? IE. When
> focusing/capturing the button should be blue until we hear the shutter sound.
> - Agreed red circle transitions need addressing, I was unsure as to the
> desired behaviour.
> - I couldn't see this transition in the video spec. Over what time-period
> should this transition occur?
> - Capture effect has been addressed as part of a separate issue.

Hi Wilson, 

-This is just the case for self-timer. 
-The red circle transparency should transition from 12% opacity to 70% opacity in the span of 3 seconds (i.e as soon as the circle turns red to when the image is captured). 
- The circle size transition from 110% to 100% should happen right at the start when the circle fades in from 0% to 12%. The size transition and opacity transition should happen at the same time. This is a fairly quick transition, I would say half a second? If you pause the animation and drag the slider to see it in slow-motion you can see what I am talking about. Let me know if you have any questions.
Flags: needinfo?(amlee)
(In reply to Wilson Page [:wilsonpage] from comment #16)
> tiffanie:
> 
> - Just pushed hyphenation (don't sure where this got lost)
> - Confirmation text is part of another notification related bug that is
> expected to land soon.
> - The beep is currently using the same sound effect as the video record.
> This is toggled off by default in Gaia sounds settings. I see these options:
>   a. Self timer always beeps no matter what
>   b. Self-timer sound is tied directly to the record sound effect (current
> case, seems strange though)
>   c. Self timer beep respects phone's global volume level and is not
> togglable like picture/record sound effects from Gaia settings app.
>   d. We add another toggle option in Gaia settings app for 'self-timer'
> (could involve work from other app devs)

Hyphenation looks good :)

I agree, it being tied to the record sound setting is strange and not obvious. But I also don't think it should beep no matter what or not be able to be turned off. 

That leaves the last option you gave - adding a new setting, which doesn't seem immensely appealing either but may be our only doable option in the short term. Let me discuss with our team...
Comment on attachment 8394455 [details]
icon-orientation.png

orientation looks good! sorry forgot to update the feedback section.
Attachment #8394455 - Flags: feedback?(tshakespeare) → feedback+
Hey Wilson, I just spoke with our Settings UX Designer in Taipei about how to handle the beep. Apparently there are some changes coming in regards to volume and sounds. He suggests that we tie the countdown beep to notifications so that the volume can be controlled but not turned off completely. Putting the whole phone on vibrate will silence it though. 

Does that sound doable?

I'm going offline for the night, but the designers name is Omega and I have cc'd him on this bug so if you need help you can ping him. Thanks!
Flags: needinfo?(tshakespeare)
ofeng: Do I have do do anything to tie the sound effects to the volume key?
Flags: needinfo?(ofeng)
Whiteboard: ux-tracking, visual design, jian [fxos:media] → ux-tracking, visual design, jian [fxos:media] [m+]
(In reply to Wilson Page [:wilsonpage] from comment #22)
> ofeng: Do I have do do anything to tie the sound effects to the volume key?

We are developing new Sound Guidelines related to this. There will be 4 types:
1. Media (content)
2. Ringer & Notifications (ringer, notification, public notification, system)
3. Alarm (alarm)
4. Telephony (telephony)

Self-timer sound belongs to 2. Ringer & Notifications (system). That means in gaia Settings when user adjusts the volume of Ringer & Notifications, Self-timer sound volume changes accordingly.
Flags: needinfo?(ofeng)
Omega: So can you instruct on how I would ensure this particular sound is in the #2 category?
Flags: needinfo?(ofeng)
I'm moving the sounds related stuff to bug 984764, so that we can land the visual stuff today. I just need r+ from amlee and engineering.
Attachment #8394484 - Flags: ui-review?(amlee)
Attachment #8394484 - Flags: review?(dmarcos)
This need some engineering review as his patch also includes code that was missed from the self-timer that originally landed in camera-new-features. The missing commits added unit-tests and addressed some comments by djf.
Comment on attachment 8394484 [details] [review]
pull-request (camera-new-features)

Found a bug - On press state is activated when you switch from video record to camera:

To reproduce: 

1. Go to video record mode
2. Record a video 
3. Switch to camera mode - The shutter button is in an active state without being pressed.
Attachment #8394484 - Flags: ui-review?(amlee) → ui-review-
Flags: needinfo?(wilsonpage)
The switch button is hidden while recording. covered buy bug 986763. Please when doing ui reviews stay focus on the context of the bug. You shouldn't be giving a ui-review- for an unrelated reason. If you find a different bug or some other UI concern file a different bug. It's the way to bring visibility on problems for other people to jump an help.
Flags: needinfo?(amlee)
Attachment #8394484 - Flags: review?(dmarcos) → review+
Rebased on master and carrying over r+
Flags: needinfo?(amlee)
Attachment #8394484 - Flags: ui-review- → ui-review+
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/9315b5e0ea0646b1647008ceac04cd316546c8d3
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 988721
Attachment #8394484 - Flags: ui-review?(tshakespeare)
(In reply to Wilson Page [:wilsonpage] from comment #24)
> Omega: So can you instruct on how I would ensure this particular sound is in
> the #2 category?

Dominic, could you help answer comment #24?
Flags: needinfo?(ofeng) → needinfo?(dkuo)
Please move discussion to: bug 984764
Wilson, unless stated otherwise, UX will ui-review the patches in this bug. Please let me know if these are moving along with discussion about them, or if they'll stay here as-is.
(In reply to Omega Feng [:Omega] from comment #32)
> (In reply to Wilson Page [:wilsonpage] from comment #24)
> > Omega: So can you instruct on how I would ensure this particular sound is in
> > the #2 category?
> 
> Dominic, could you help answer comment #24?

Answered in bug 984764 comment 6.
Flags: needinfo?(dkuo)
Bulk edit for camera bugs.

If earlier comments do not show how this bug landed to master, it probably landed as part of https://github.com/mozilla-b2g/gaia/pull/17599 which merged the camera-new-features branch into master.

This bug was uplifted from master to v1.4 as part of https://github.com/mozilla-b2g/gaia/commit/a8190d08e61316a86bba572ba8d894d081a20530
Target Milestone: --- → 1.4 S5 (11apr)
Cannot verify the fix with two reasons
1) Self-timer message doesn't reappear after image is captured (See self-timer.mov).
2) No beeping sound on master build but it can be heard on 1.4
#1 - I think that might be weird video quirk that is reseting the video so it appears like the self-timer is showing up again after the image is captured. Amy? The confirmation message should only appear when toggling the self-timer options.

#2 - beeping has been pushed to the next release. I put it in another self-timer bug that I can't seem to find at the moment.
Flags: needinfo?(amlee)
Just talked it over with Rob and Amy - apparently the original intent was to have the self-timer confirmation text persist while self-timer was enabled. Given that this wasn't in the UX spec nor called out before now, we are going to leave things as they are and revisit and 2.0.
Flags: needinfo?(amlee)
You need to log in before you can comment on or make changes to this bug.