Closed Bug 985685 Opened 6 years ago Closed 6 years ago

DrawRangeElements does not trigger a blit/resolve of MSAA buffers

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox30 + fixed
firefox31 --- fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

Details

Attachments

(3 files)

We recently added support for glDrawRangeElements, but I forgot to brace it with our Before/AfterGLDrawCall() calls.
Attached patch patchSplinter Review
Attachment #8393766 - Flags: review?(dglastonbury)
Attachment #8393766 - Flags: review?(dglastonbury) → review+
https://hg.mozilla.org/mozilla-central/rev/322885ddb693
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
This needs a test, and a backport to Aurora30.
Flags: needinfo?(jgilbert)
Attached file testcase
Attachment #8398873 - Flags: review?(dglastonbury)
Attachment #8398873 - Flags: review?(dglastonbury) → review+
Needs uplift.
Flags: needinfo?(jgilbert)
Comment on attachment 8393766 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 982960
User impact if declined: Bad WebGL rendering on many pages
Testing completed (on m-c, etc.): Local, Try, test landed on m-i.
Risk to taking this patch (and alternatives if risky): None.
String or IDL/UUID changes made by this patch: None.
Attachment #8393766 - Flags: approval-mozilla-aurora?
Attachment #8393766 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.