Closed Bug 985830 Opened 9 years ago Closed 9 years ago

Preferences.jsm:378 - mutating the [[Prototype]] of an object warning

Categories

(Toolkit :: Preferences, defect)

defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 982856

People

(Reporter: dougt, Unassigned)

Details

I am seeing this on the console of a B2G run:

System JS : WARNING resource://gre/modules/Preferences.jsm:378 - mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create

"""
Some startup code must be using |obj.__proto__ = ...| to change the prototype chain of an object.  Doing so is bad -- it makes accesses on that object and every other along its prototype chain slow, forever, and may throw away JIT code in the process of using that object, and generally just isn't cool.  Fixing code to not use __proto__ will eliminate the resulting pathological slowdowns.
"""
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 982856
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.