PerLDAP ::Conn->search() fails but ::API succeeds



17 years ago
14 years ago


(Reporter: Eric Schult, Assigned: Leif Hedstrom)


Firefox Tracking Flags

(Not tracked)




17 years ago
Attempting to perform a search with the 'examples/' script fails (no
error, no results).   The same search with 'test_api/' works.  I am
using Perl 5.004_04 + PerLDAP 1.4.1 + the Netscape C SDK 4.14 connecting to
Netscape Directory Server 4.12.  I built PerLDAP from scratch w/ gcc 2.95.2.

Trussing the script shows that the results are being returned as

truss -r3 -t !all perl examples/ -b -h '(uid=bos.ssb.eschult)'
read(3, 0x0002D808, 8192)                       = 497
   08201DF020102 d8201D804 0 u i d = b o s . s s b . E S c h u l t
   , o u = U s e r s ,   o = e - g l o b a l l i n k . c o m 08201
  A2 0\r0402 o u 1070405 U s e r s 0130402 c n 1\r04\v E r i c   S
   c h u l t 0180403 u i d 111040F b o s . s s b . E S c h u l t 0
  1304\t g i v e n n a m e 1060404 E r i c 00E0402 s n 1\b0406 S c
   h u l t 0 &04\f c r e a t o r s n a m e 1160414 c n = d i r e c
   t o r y   m a n a g e r 0 $040F c r e a t e t i m e s t a m p 1
  11040F 2 0 0 0 1 2 1 4 1 8 0 1 0 1 Z 0\t0401 c 1040402 U S 0 304
  \f u s e r p a s s w o r d 1 #04 ! { S H A } H 1 5 C I 7 z i G /
   N m w A A S C f Y E C W L Y T j 8 = 0 `04\v o b j e c t c l a s
   s 1 Q0403 t o p0406 p e r s o n0414 o r g a n i z a t i o n a l
   P e r s o n04\r i n e t O r g P e r s o n04\t s s b P e r s o n
  04\t p i n P e r s o n0407 c o u n t r y 0 '04\r m o d i f i e r
   s n a m e 1160414 c n = D i r e c t o r y   M a n a g e r 0 $04
  0F m o d i f y t i m e s t a m p 111040F 2 0 0 1 0 6 2 6 1 4 2 3
   4 6 Z 0\f020102 e07\n01\004\004\0
Searched for `(uid=bos.ssb.eschult)':


I reverted to PerLDAP 1.4 and kept everything else the same, and now it works.

Happy to provide additional info  (about the bug, that is).


Comment 1

17 years ago
This was on Solaris 8

Comment 2

16 years ago
Me too.

AIX box. Reverting to 1.4.0 fixed the problem


Comment 3

15 years ago
Spam for bug 129472
QA Contact: nobody → nobody


15 years ago

Comment 4

14 years ago
Can you try the development branch (devel-branch-1_4_2) see if this is still a
problem? If so, please reopen this bug.
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
Since devel-branch-1_4_2 's Makefile.PL requires 5.005, I can't re-test my
original case w/ 5.004_04. 

I re-tested my original case using perldap-1.4.1 and a newer perl (5.8.5) and
gc(3.2.3), which worked correctly.   The identical envrionment EXCEPT perl
5.004_04 (w/ gcc 323) failed as my original environment failed.

Apologies for the apparent red-herring, as the newer perl seems to have fixed
the issue. 
You need to log in before you can comment on or make changes to this bug.