Closed Bug 985903 Opened 7 years ago Closed 7 years ago

Investigate test_camera_capture_video.TestCamera intermittent fail on master

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: AndreiH, Assigned: viorela)

Details

Attachments

(2 files)

Attached image Screenshot.png
This fails with, also could be reproducible locally:

Traceback (most recent call last):
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 163, in run
testMethod()
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui/tests/python/gaia-ui-tests/gaiatest/tests/functional/camera/test_camera_capture_video.py", line 30, in test_capture_a_video
self.camera.record_video(3)
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py", line 64, in record_video
self.wait_for_video_capturing()
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py", line 114, in wait_for_video_capturing
self.wait_for_condition(lambda m: self.marionette.find_element(
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 54, in wait_for_condition
Wait(self.marionette, timeout).until(method, message=message)
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.0104351044 seconds
This is failing intermittently on v1.4 too. Im working on it
Attachment #8394661 - Flags: review?(zcampbell)
Attachment #8394661 - Flags: review?(florin.strugariu)
Attachment #8394661 - Flags: review?(andrei.hutusoru)
Comment on attachment 8394661 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/17389

I just replace this outdated wait here: https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py#L87
with
self.wait_for_condition(
            lambda m: m.find_element(
                *self._controls_locator).get_attribute('buttons-enabled') == 'true')

And I cannot reproduce the fail again. Please make these changes and let's start and adhoc job.
Attachment #8394661 - Flags: review?(andrei.hutusoru) → review-
Attachment #8394661 - Flags: review- → review?(andrei.hutusoru)
Attachment #8394661 - Flags: review?(florin.strugariu) → review+
Comment on attachment 8394661 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/17389

r+ thanks Viorela.
Attachment #8394661 - Flags: review?(zcampbell)
Attachment #8394661 - Flags: review?(andrei.hutusoru)
Attachment #8394661 - Flags: review+
Assignee: nobody → viorela.ioia
Bulk edit for camera bugs.

If earlier comments do not show how this bug landed to master, it probably landed as part of https://github.com/mozilla-b2g/gaia/pull/17599 which merged the camera-new-features branch into master.

This bug was uplifted from master to v1.4 as part of https://github.com/mozilla-b2g/gaia/commit/a8190d08e61316a86bba572ba8d894d081a20530
Target Milestone: --- → 1.4 S5 (11apr)
You need to log in before you can comment on or make changes to this bug.