Closed Bug 985948 Opened 7 years ago Closed 7 years ago

When contact is added without name/surname (for example with only phone number) and it is edited you can see empty title

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

VERIFIED FIXED
1.4 S4 (28mar)
tracking-b2g backlog

People

(Reporter: lolimartinezcr, Assigned: fcampo)

Details

Attachments

(2 files)

Attached image 2014-03-20-09-47-57.png
1.4
Build ID: 20140320052229
Platform version: 30.0a2
Git commit:4ab2166a
Reproducible: 100%

STR
1) Tap contact aplication.
2) Tap "+" button
3) Write only a field (for example phone number)
4) Tap "Done" button
5) Tap in contact added

Actual result:
You can see contact edited but title empty. (Attached image)


Expected result:
You can see contact edited with (in my case) phone number in title. I have tested with my Android device this behavior but I need info UX.
Flags: needinfo?(aymanmaat)
Hmm, I have answered this before ages ago :)

The solution is:

If a phone number is present 
      in header output phone number
If phone number is not present but an email address is present 
      in header output email address
If a phone number or email address is not present but any other field is present 
      in header output ‘no name’
Flags: needinfo?(aymanmaat)
I would say this is a bug that should be fixed and i would think it is relatively easy to do so because the solution outlined in Comment1 is actually how the Contact List is behaving i notice.
nominating as per comment2
blocking-b2g: --- → 1.5?
Assignee: nobody → fernando.campo
its not a blocker for 1.5 (1.4/1.3 seem to behave the same), please fix it and land it
blocking-b2g: 1.5? → backlog
Comment on attachment 8394831 [details] [review]
Link to PR - https://github.com/mozilla-b2g/gaia/pull/17452

left comments on GH. Another round needed
Attachment #8394831 - Flags: review?(jmcf)
Comment on attachment 8394831 [details] [review]
Link to PR - https://github.com/mozilla-b2g/gaia/pull/17452

Comments addressed, please review again
Attachment #8394831 - Flags: review?(jmcf)
Comment on attachment 8394831 [details] [review]
Link to PR - https://github.com/mozilla-b2g/gaia/pull/17452

good work Fernando. merge once Travis is green
Attachment #8394831 - Flags: review?(jmcf) → review+
master - 55cd51cfdf26af3d13cc596ef6acb71e14d7327f
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S4 (28mar)
tested and working
1.5 
Gecko fa7c5ad
Gaia 7c73c66

1.4
Gecko a15cb07
Gaia 441c4bc
Status: RESOLVED → VERIFIED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.