Closed Bug 986047 Opened 7 years ago Closed 7 years ago

[B2G][Dialer]Cannot select 'Add Comment' when creating a new contact through the dialer app

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S4 (28mar)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: astole, Assigned: crdlc)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

When going to the contacts section in the dialer app and creating a new contact, the user cannot add a new comment. When selecting 'Add Comment' the Comment box is selected instead of a new comment section being created.

Repro Steps:
1) Update a Buri to BuildID: 20140320000349
2) Open the Dialer app and go to 'Contacts' section
3) Select the '+' to add a new contact
4) Scroll to the bottom of Add Contact page and select 'Add comment'

Actual:
Cannot select 'Add Comment' when creating a new contact

Expected:
Seleecting 'Add Comment' adds a new comment box

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140320000349
Gaia: 53edbf08b0a750c31e8c6b2c20f2b1315b1412d1
Gecko: 9b482d6994fd
Version: 30.0a2
Firmware Version: v1.2-device.cfg

Repro frequency: 100%
See attached: Video
What happened on 1.3?
Component: Gaia::Dialer → Gaia::Contacts
Keywords: qawanted
QA Contact: astole
This issue does not occur on the latest 1.3. The user is able to add a new comment following the repro steps.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140319004003
Gaia: f2f2be55dcca1d6775592ef478948045935a91ed
Gecko: 87d90ecfe616
Version: 28.0
Firmware Version: v1.2-device.cfg
Confirmed this - looks like you can only have a single comment when creating a contact in which you launched the dialer first.
blocking-b2g: --- → 1.4?
traige: 1.4+ regression
Francisco, mind taking a look? Thanks
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(francisco.jordano)
QA Contact: astole → pbylenga
This regression range is outside of what we have available in Tinderbox and Inbound builds.  B2G-RIL builds were used and the gaia-gecko swap test revealed that it is a Gaia issue.

Last Working B2G-RIL build:
v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140109040203
Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
Gecko: 9409405e0739
Version: 29.0a1
Firmware Version: v1.2-device.cfg

First Broken B2G-RIL build:
v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140110040206
Gaia: f400efc804366c7b7cf5476d1d5d325e6651ee71
Gecko: 37516445a0b5
Version: 29.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia / First Broken Gecko: Issue Does NOT reproduce
Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
Gecko: 37516445a0b5

Last Working Gecko / First Broken Gaia: Issue DOES reproduce
Gaia: f400efc804366c7b7cf5476d1d5d325e6651ee71
Gecko: 9409405e0739

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/47206ac66b084c6f6c4503a3b10d0e0760df2b6f...f400efc804366c7b7cf5476d1d5d325e6651ee71
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Go to github
Attachment #8395609 - Flags: review?(etienne)
Flags: needinfo?(francisco.jordano)
Attachment #8395609 - Flags: review?(francisco.jordano)
Comment on attachment 8395609 [details]
Go to github

Still wondering how that css in dialer is preventing the contacts details to add a comment.

Anyway this falls into Etienne's land, what I did was trying it in contacts and I can add the notes to the the newly created contact.

Thanks Cristian!
Attachment #8395609 - Flags: review?(francisco.jordano) → review+
Target Milestone: --- → 1.4 S4 (28mar)
Basically no only comments, whatever at the end of the viewport. It is because article[role="tab"] are there with pointer-events: all as I could see with the app manager
Attachment #8395609 - Flags: review?(etienne) → review?(anthony)
Looking at the patch, this was a regression from bug 947099.
Blocks: 947099
Comment on attachment 8395609 [details]
Go to github

Can you also remove the pointer-events: none in the selector below?
#views.hide-toolbar > article[role="tab"]:before,
#views.hide-toolbar > article[role="tab"] > .icon {
Attachment #8395609 - Flags: review?(anthony) → review+
Thanks, done, waiting for Travis
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/442b613e084b9043c22647d14aa84f91c13c92d1
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
While heading off to the contacts segment in the dialer application and making another contact, the client can't include another remark. When choosing 'Include Comment' the Comment box is chosen rather than another remark segment being made.
Resolution provided by http://researchpaperonline.net/write-my-research-paper .
You need to log in before you can comment on or make changes to this bug.