Closed Bug 986063 Opened 7 years ago Closed 7 years ago

Uplift patches to v1.3

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(b2g-v1.3 fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S4 (28mar)
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.4 --- fixed

People

(Reporter: mdas, Assigned: mdas)

References

Details

Attachments

(1 file)

From Bug 940915, we can benefit from mirroring marionette to v1.3. I was successfully able to apply 35 patches and run them in try:

https://tbpl.mozilla.org/?tree=Try&rev=d452e1a9bc1a <-- Mn tests
https://tbpl.mozilla.org/?tree=Try&rev=231c3e2163fd <-- Gu tests
Attached patch squashed patchesSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 940915 

User impact if declined: MTBF team will have greater difficulty in running their long-standing tests and will have difficulty getting performance data

Testing completed: Mn and Gu tests passed on try: https://tbpl.mozilla.org/?tree=Try&rev=231c3e2163fd and https://tbpl.mozilla.org/?tree=Try&rev=d452e1a9bc1a

Risk to taking this patch (and alternatives if risky): Only downstream consumers of the Marionette automation framework will be affected if anything goes wrong, nothing critical in a production build. If this introduces a problem with the Marionette framework, we can revert or I can fix in a following patch. Risk is low, since this is tested on v1.3, and this code is merely an uplift of patches already running on master.
Attachment #8394307 - Flags: approval-mozilla-b2g28?
Hi Fabrice, can you help with the approval? I'd like to push this out so MTBF team can use these tools, thanks!
Flags: needinfo?(fabrice)
Attachment #8394307 - Flags: approval-mozilla-b2g28? → approval-mozilla-b2g28+
Flags: needinfo?(fabrice)
Thanks, fabrice!

Pushed to v1.3: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/pushloghtml?changeset=8a68f981ed16
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Mnw tests failed, I forgot to test that in try. Will update the patch and test on a full suite on try. I got the OK from fabrice to land it in v1.3 once it goes green on try.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Landed green on v1.3
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
\m/

As I mentioned before, please make sure that any of the patches that landed on trunk after last week's uplift get on to Aurora too.
Target Milestone: --- → 1.4 S4 (28mar)
Yup, thanks. I've landed the needed patches for aurora.
You need to log in before you can comment on or make changes to this bug.